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Introduction 
Welcome to Serif PhotoPlus 10.0—the best value in image creation and 
editing software for any home, school, organization, or growing business. 
PhotoPlus is your number one choice for working with photographs and 
paint-type images, whether for the Web, multimedia, or the printed page.  

PhotoPlus has the features you’ll need... from importing or creating pictures 
and animations, through manipulating colours and effects all the way to final 
export. Built-in support for TWAIN scanners and cameras makes it easy to 
bring in your own photos, while comprehensive import filters let you open 
just about any standard bitmap image. 

Once you’ve got your image into PhotoPlus, you can enhance and alter its 
on-screen appearance with a diverse toolkit of functions and effects. A full 
range of export options (with special attention to Web graphics), plus 
powerful optimization capabilities, round out this high-performing package. 

About the Companion 
This Companion is your guide to getting started and getting results with 
PhotoPlus—from the basics to advanced techniques. The chapter sequence 
begins with basic concepts and proceeds gradually through various tools and 
features. Hands-on Projects are integrated each step of the way. Here’s a 
quick summary of chapter contents: 

1 Welcome. There, we’ve said it again! 
2 Getting Started. Will have you up and running in no time with an 

overview of key concepts and the PhotoPlus interface. 
3 Manipulating Images. A rundown of basic techniques for selecting 

and operating on all or just part of an image. 
4 Working with Paint, Shapes, and Text. How to proceed from the 

proverbial blank slate, using the PhotoPlus creation tools.  
5 Using Layers and Masks. Understanding and mastering the creative 

possibilities of these more advanced features.  
6 Preparing Web Graphics. A review of Web image formats and 

step-by-step guidance on animation and image preparation. 
7 Macros and Batch Processing. Automate your PhotoPlus actions to 

increase your efficiency. 
8 Colour and Output Options. Combines essential background 

material and terminology with helpful tips to improve your images. 
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What’s New in PhotoPlus 10.0 
Whether you’re a new or returning PhotoPlus user, you’re sure to appreciate 
all the advances that keep it at the cutting edge of value and performance: 

♦ Macros (p. 157) 
Ever wanted to apply the same adjustment, effect or change of photo 
properties to multiple photos? A new Macros feature enables you to 
automate your actions by using one of up to 200 categorized macro 
presets—alternatively, record and apply your own macro to any number 
of photos—give all your photos the same frame, age them or make a 
colour enhancement all at the same time! 

♦ Batch processing (p. 161) 
Use batch processing to repeat your tasks, e.g. changing file types, all at 
the same time without user intervention. When used in conjunction with 
macros the possibilities are endless. 

♦ Channels (p. 55) 
PhotoPlus’s advanced layer facilities are now joined by the ability to edit 
the Red, Green and Blue channels independently. This fine tuning 
enables noise to be reduced from the Green channel, blurring to be 
applied on the Blue channel and sharpening on the Red channel—all 
established methods for improving photo quality. 

♦ Filter Gallery (p. 133) 
The distort, blur, edge, render and other miscellaneous effects can now 
be applied singularly or in combination within a Filter Gallery. The 
gallery boasts a resizable large preview window in which to test the 
effect of your filters in turn...guaranteed to keep you up late! 

♦ Histogram Support (p. 174) 
The Histogram is now located in it’s own dockable window and is 
“live”. It dynamically responds to show the values for the currently 
active selection within your document. See how curves and level 
adjustments affect your image as they happen! 

♦ Digital Camera Raw Capture 
For digital photographers, PhotoPlus will directly open the increasingly 
popular unprocessed RAW file formats from manufacturers such as 
Canon, Olympus and Nikon—over 150 digital camera models are 
supported!  
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♦ Shadow/Highlight/Midtone Adjustments (p. 58) 
Easily enhance your photographs with this amazing filter. Correct 
underexposed portions of the photo and calm down overexposed skies in 
one single operation without having to resort to manipulating curves and 
levels! 

♦ EXIF Information 
View Exif information present on photos taken with a digital camera. 
Make changes to photos while still preserving Exif information by using 
Save Original. 

♦ Layer Management (from p. 107) 
Already comprehensive and professional layer editing capabilities are 
taken to new heights with the addition of Layer groups (p. 112) to help 
manage complex documents. Keep related layers together and to restrict 
the scope of a layer’s effect. In addition, switching on/off, collapsing 
and expanding groups will make you more efficient when working with 
the Layers tab. You can also flatten a group with Merge Layer Group, 
and, as enhancements from before, Distribute linked layers into one of 
six possible positions and Duplicate layers to another currently open 
document directly. Leading edge advanced bleeding is now possible 
between layers using the Blend Ranges option. 

♦ Blend Ranges (p. 114) 
Advanced users step right up—masking effects can be achieved by 
selectively including or excluding the ranges of luminance (grey), red, 
green or blue present in upper and underlying layers.    

♦ More Power with Effects (p. 121) 
Layer effects have been given a major enhancement by applying 
multiple Instant Effects onto a layer’s existing effects—add a shadow, 
emboss, glowing text, etc. for stunning design output. You can also copy 
and paste effects between layers.  Instant Effect categories Bevel & 
Emboss, Glows and Shadows have been added. 

♦ Brush Enhancements (from p. 74) 
Control the build up of colour on your brush with the Paintbrush Flow 
option. When painting on masks, the brush tool supports fixed-level 
opacity and blend modes.  Use Shift-click to draw straight lines from the 
end of the previous brush stroke to the current position. The pattern 
brush now works on masks and depth maps. As a new brush option, try 
Wet Edges to give your brush edge a watery effect. New brush 
categories Charcoal, Paint, Pen, Watercolour, and Pencil have been 
added. 
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♦ Cropping (p. 49) 
Control the region selection by setting a Fixed Size (in pixels) or Fixed 
Aspect ratio (e.g. 4x3). 

♦ QuickShapes/Outlines  (p. 86) 
Your QuickShapes and outlines can now be drawn directly as a Shape 
layer, path or as a filled bitmap on a raster layer. In addition, scaling and 
snapping is now supported for the QuickShape selection tool. 

♦ Image Management (p. 50) 
Rotate your images by fractional degrees via the Custom option. More 
image rotation options have also been added to the Image menu. 

♦ Tab Management (p. 25) 
You’ll notice some improvements in the way tabs can be used—collapse 
and expand tabs, resize the tab windows in any direction, and dock or 
undock your tabs at any time. 

♦ Context Bar (p. 77) 
A major improvement from the Tools Properties tab in previous 
versions, a single Context Bar improves your efficiency by allowing the 
viewing and editing of a tool’s properties in context with the tool 
currently selected—it’s always at hand whenever you need it. 

♦ Workspace Management (p. 25) 
It’s now possible to save your tab window positions, sizes, and docking 
settings to a workspace file (.wtb) for safe keeping. You can swap 
between different workspace files quickly and easily. 

♦ Enhanced Animations Management (p. 144) 
Animation capabilities now include Tweening to make creating 
animations easier and more accurate. Convert to Animation makes the 
process of taking any image into animation mode a breeze! You can 
even combine animations with 2D and 3D layer effects. 

♦ And to round up some other important additions... 
Flood fill selected regions and layers with Patterns or Fill paths with 
your chosen colour. More flexibility with the Lock feature—lock pixel 
opacity, pixels, layer positions or lock a whole layer independently. 
Reselect in the Select menu will remember the previously drawn 
selection instead of having to store it. Ruler units can not only be 
changed on the ruler bar but can also now be expressed in 
percentages...great when using macros or when changing your canvas 
size relatively. Press the spacebar for immediate panning. During 
zooming, use the Resize Windows to Fit. Perform intelligent 
sharpening with the new Sharpen Edges effect and use the Glass effect 
to create stunning artistic images. 
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Special Note: If you’ve upgraded to PhotoPlus 10.0 and want a quick-start 
preview of what’s new and different, check out the “New Features” tutorial! 

Plus These Established Features... 
PhotoPlus brought professional image editing to everyone—with features 
like these: 

♦ Editable QuickShapes 
Easy to create, easy to change! Simply drag sliders to morph chevrons, 
hearts, badges, teardrops, moons, zigzags, and many more... apply layer 
effects and gradient fills... and edit any shape at any time. Create 
multiple shapes on a single layer—add, subtract, intersect, or exclude 
with previous shapes for frames, cutouts and custom contours. 

♦ Freehand and Bézier Curve and Shape Drawing 
Powerful vector-drawing tools let you produce any shape under the sun 
with controllable, connectable, editable line segments. 

♦ Browse Image Files and Folders 
The built-in Image Browser rapidly displays image thumbnails— 
a folder at a time—so you can preview clip art or saved work and 
inspect file details in a convenient, Explorer-style interface. 

♦ Unique Selection Options 
PhotoPlus goes well beyond the basic rectangle and lasso tools, adding 
more than a dozen completely customizable selection shapes like 
polygons, spirals, and stars. Use Magnetic Selection to find edges as you 
trace them. Or define a selection shaped like text—using any font and 
style! Advanced options let you fine-tune the selection and its properties 
for smoother blends and precise effects. Paint to Select mode lets you 
literally “brush on” selectedness. Border, Threshold, and Smooth 
commands for more versatility. Store and load selections between any 
open file. Use combination buttons (as for shapes) to define cutout 
selection regions. Convert selections into paths or layers. 

♦ Paths 
Use the full range of line- and shape-drawing tools to create editable 
outlines via the Paths tab. Convert paths to or from selections on any 
layer. “Stroke” paths using any brush to create bordered shapes! 

♦ Stamp and Spray 
Use Picture Brushes to lay down colourful arrays of single or multiple 
mini-images: realistic machine cogs, colourful tubes, falling leaves, 
flowers, jelly beans, jewels, raindrops, marbles, planets, and more... 
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♦ Powerful Image Export Optimizer 
The Export Optimizer lets you see how your image will look (and how 
much space it will take up) before you save it! Its multi-window display 
provides side-by-side WYSIWYG previews of image quality at various 
output settings, so you can make the best choice every time. 

♦ Web Animation Tools 
It’s easy and fun to create or edit animations for the Web. You can 
import and export animated GIFs, apply special effects, even let 
PhotoPlus create entire animations for you automatically. Or export to 
the .AVI format for movies and multimedia! 

♦ Editable Text 
Add formatted colour text to an image, reposition and scale it, integrate 
it with your design. Text layers keep the contents separate so you can go 
back and alter the words or formatting at any time! 

♦ Special Erase Options 
Need to remove that blue sky and leave the clouds? Use the Flood Eraser 
to fill the blue regions with transparency. Want to isolate a shape from a 
flat colour background? The Background Eraser samples pixels under 
the brush, so only unwanted colours drop out. 

♦ Image Enhancement 
Apply professional, darkroom-style colour and histogram adjustments to 
your images. Employ the Blur and Sharpen tools to enhance or reduce 
local detail... blend multiple layers more cleanly. There’s even a 
dedicated tool for removing “red eye” from flash photos.  

♦ Special Effects, Image Correction Filters 
A wild and whimsical assortment for instant creativity! Powerful image 
correction functions for fingertip control over tones and colours. Add 
Shadow, Bevel, Emboss layer effects for a sophisticated 3D look on text 
or other image elements. Instant Artist effects turn your photos into 
works of art. PhotoPlus supports third-party Photoshop® plug-ins, and 
even lets you design your own custom filters. 

♦ Astounding 3D Lighting and Surface Effects 
Advanced algorithms bring flat shapes to life! Vary surface and source 
light properties. Start with a pattern or a function, adjust parameters for 
incredible surface contours, textures, fills. Optimized for Intel® 
Pentium® 4 processors. 

♦ 3D Painting using Depth Maps 
Add instant dimensionality to your artwork. Painting or erasing on a 
layer’s depth map appears as raised or lowered strokes on the image! 
Use with 3D layer effects to achieve “carved” side-view textures. 
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♦ Editable Adjustment Layers 
Not only apply colour corrections and special effects, but store each 
change on a separate layer or group. To fine-tune any adjustment later, 
just click its layer and change the settings! The Instant Effects gallery 
puts 3D technology and layer effects at your disposal. 

♦ Versatile Deform and Warp Tools 
“Swiss Army Knife” of image tools, Deform lets you rotate, resize, 
skew, reshape, or add perspective to any selection or layer. Warp tools 
pull, stretch, and distort image details, or shrink and enlarge. Pixels turn 
to putty with the Mesh Warp tool! Use a customizable grid of points and 
lines to bend images with precision. 

♦ Gradient Fills 
Take your pick of radial, linear, conical, or square fills—perfect for 
masking, to hide or reveal parts of your photo using smooth graduated 
blends to transparency. One master dialog allows editing of five 
gradient fill types combining both colour and transparency. Choose from 
a built-in gallery of presets, add your own categories and fills. (Of 
course, there’s standard flood fill as well.) 

♦ Image Slicing and Image Maps 
Now it’s not just the pros who can use these techniques to add links to 
Web graphics! Simply click to divide images into segments—each with 
its own hyperlink and popup text—or add hotspots to specific regions. 
PhotoPlus outputs the HTML code and lets you preview the results 
directly in your Web browser. 

♦ Advanced Tools and Features 
Built-in support for most pressure-sensitive graphics tablets. RGB, 
CMYK, HSV, and Greyscale colour modes. The Deform Mesh tool for 
reshaping any freeform region. Robust and convenient layer 
management with pop-up preview and masking support (on shape and 
text layers, too)! Extract command to isolate a face, feature, or object.  

♦ Professional Colour Management  
ICC colour profiling means you’ll achieve more accurate colours with 
specific monitors and printers—for printed output that more closely 
matches on-screen colours. 
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♦ Professional Input and Output Options 
Support for Photoshop® (.PSD) and Paint Shop Pro® (.PSP) files 
including translation of layers and effects where possible! And import 
Paint Shop Pro (.TUB) picture tubes to use as PhotoPlus Picture 
Brushes! Output using CMYK separations or print directly to your 
desktop printer with powerful controls (e.g., positional printing of single 
or multiple images). Portable Document Format (PDF) support for 
WYSIWYG electronic document delivery to web or pre-press.   Include 
registration marks, crop marks, file information, greyscale and colour 
bars, and tile or scale your output if required. 

♦ Productive MDI Interface 
Open and view multiple images and edit them simultaneously. Dockable, 
floating tab windows work in conjunction with convenient toolbars. The 
Navigator and Layers tab provide full control over all regions and 
planes. Each document stores a massive Undo range with dynamic 
memory and disk management, compressing information for optimized 
performance. Built-in Autoselect for rapid navigation in multi-layered 
images... handy Measure tool for checking pixel dimensions... layout 
guides plus optional snapping to grid or guides for finer control when 
painting or erasing... the Undo History tab so you never lose track of 
where you’ve been. And PhotoPlus remembers your preferred export 
settings, so your creative flow is undisturbed. 

And that’s only part of the story! The PhotoPlus feature set includes all the 
standard capabilities you’d expect in a photo editor. Tools like Paintbrush, 
Clone, Smudge, and Erase. Customizable brush tips, opacity, and blend 
mode settings. Flip, rotate, and crop. Anti-aliasing. TWAIN support for 
scanner and digital camera input. A full range of supported file formats for 
both import and export. Bonus TrueType fonts.  

Registration, Upgrades, and Support 
If you see the Registration Wizard when you launch PhotoPlus, please take a 
moment to complete the registration process. Just call Serif toll-free and 
provide the installation number and code shown. We’ll give you a 
personalized registration number in return. Remember, if you need technical 
support please contact us. We aim to provide fast, friendly service and 
knowledgeable help. 



Welcome    11 
 

 

Installation 
PhotoPlus system requirements 
PhotoPlus runs with Windows 98 SE or later, so you’ll need a PC setup 
which runs Windows adequately. If you need help installing Windows, or 
setting up your printer, see Windows documentation and help. 

Minimum: 
♦ IBM compatible Pentium PC with CD-ROM drive and mouse (or other 

Microsoft compatible pointing device) 
♦ Microsoft Windows® 98 SE, Me, 2000, or XP operating system 
♦ 64MB RAM (Windows 98 SE), see manufacturer’s requirements for 

other operating systems 
♦ 130MB (recommended install) free hard disk space 
♦ SVGA display (800x600 resolution, 16-bit colour or higher) 

Additional disk resources and memory are required when editing large and/or 
complex images. 

Optional: 
♦ Windows-compatible printer 
♦ TWAIN-compatible scanner and/or digital camera 
♦ Stylus or other input device, including pressure sensitive pen 



12    Welcome 

What you need to know 
PhotoPlus is very easy to use, and you don’t need to have any prior design 
experience. However, if you’re new to Windows computing, you will find it 
much easier if, before installing and using PhotoPlus, you spend a little time 
becoming familiar with the Windows operating environment.  

 From the Windows desktop, click the Start button at the lower left and 
choose Help.  

First-time install 
To install PhotoPlus, simply insert the Program CD-ROM into your CD-
ROM drive. The AutoRun feature automatically starts the Setup process and 
all you need to do is select the PhotoPlus Install option and answer the on-
screen questions. If the AutoRun does not start the install, use the manual 
install instructions below.  

Manual install/re-install 
To re-install the software or to change any part of the installation at a later 
date, select Settings/Control Panel from the Windows Start menu and then 
click on the Add/Remove Programs icon. Make sure the correct CD-ROM 
is inserted into your CD-ROM drive, click the Install… button, and then 
simply follow the on-screen instructions. To install just one particular 
component to your hard drive, choose the Custom option and check only that 
component. 
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Seven Key Concepts 
If you’re new to photo editing programs, or perhaps have only worked with a 
basic painting program like Microsoft Paint, a number of the concepts in 
PhotoPlus may be new to you. Don’t be daunted! Many thousands of artists 
have made the leap—the rewards are well worth it!  

This section collects in one place some background material that should 
serve as a concise introduction and save you some “head-scratching” later 
on. We recommend you read through it before racing ahead to the rest of the 
chapter. And check out the “Key Concepts” tutorial for a hands-on 
walkthrough! 

1  Image size and canvas size 
Sometimes a tricky distinction if you haven’t encountered it before, this is an 
important one when working with digital pictures. You probably know that 
image dimensions are given in pixels (think of pixels as the “dots of paint” 
that comprise a screen image)—say, 640 wide by 480 high. If you want to 
change these dimensions, there are two ways to go about it, and that’s where 
image and canvas come into play. Changing the 
image size (I) means scaling the whole image or just a 
selected region up or down. Changing the canvas size 
(C), either by pixel or by relative percentage, means 
adding or taking away an area at the edges of the 
image—rather like adding a border around a mounted 
photo, or taking a pair of scissors and cropping the photo to a smaller size. 
Either way, after resizing, the image and canvas dimensions are once again 
identical. 

2  Interacting tools and tabs 
The Tools toolbar (see the PhotoPlus Toolbars and 
Tabs diagram later in this chapter) is at the heart of 
PhotoPlus. Among its many offerings you’ll find several basic 
painting/drawing tools, plus tools for erasing, filling a region, and cloning 
a region (all covered in detail in Chapter 4). As you try each of these tools, 
keep in mind that the Context Bar,a properties bar that dynamically changes 
depending on which tool is selected, extends each tool’s functionality by 
letting you customize its settings. 

Tabs available in windows within the PhotoPlus workspace may also let you 
customize a tool’s functionality, e.g. the Brush Tip tab can be used to set 
brush tip characteristics when using the Paintbrush tool in the Tools toolbar. 
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3  Making a selection 
In any photo editing program, the selection 
tools (see Chapter 3) are as significant as any 
of the basic brush tools or commands. The 
basic principle is simple: quite often you’ll 
want to perform an operation on just a portion 
of the image. The wide range of selection options in PhotoPlus lets you: 

♦ Define just about any selection shape 
♦ Modify the extent or properties of the selection 
♦ Carry out various manipulations on the selected pixels, including cut, 

copy, paste, rotate, adjust colours, apply special effects, etc.  

Although the techniques for using each selection tool vary a bit, the end 
result of making a selection is always the same: a portion of the image has 
been roped off from the rest of the image. The boundary is visible as a 
broken line or marquee around the selected region.  

4  Foreground and background colours 
At any given time, PhotoPlus allows you to work 
with just two colours—a foreground colour and 
a background colour. These are always visible 
as two swatches on the Colour tab. Electronic 
artists expend much of their creative energy deciding which of the millions 
of available colours should fill those two slots. The actual steps involved, 
however, can be quite simple (see Chapter 4). 

5  Layers 
If you’re accustomed to thinking of 
pictures as flat illustrations in books, 
or photographic prints, the concept 
of image layers may take some 
getting used to. In a typical PhotoPlus image—for example, a photograph 
you’ve scanned in, a new picture file you’ve just created, or a bitmap file 
you’ve opened—there is one layer that behaves like a conventional “flat” 
image. This is called the Background layer, and you can think of it as 
having paint overlaid on an opaque, solid colour surface. (Don’t confuse the 
“background colour” with the “Background layer”—there’s absolutely no 
connection!) 
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On top of the Background layer, you can create any number of new layers in 
your image. Each new one appears on top of another, comprising a stack of 
layers that you can view and manipulate with the Layers tab. We call these 
additional layers standard layers to differentiate them from the Background 
layer. Standard layers behave like transparent sheets through which the 
underlying layers are visible. 

With few exceptions, you will work on just one layer at any given time, 
clicking in the Layers tab to select the current or active layer. Selections (see 
above) and layers are related concepts. Whenever there’s a selection, certain 
tools and commands operate only on the pixels inside the selection—as 
opposed to a condition where nothing is selected, in which case those 
functions generally affect the entire active layer. 

If your image has multiple layers, and you switch to another layer, the 
selection doesn’t stay on the previous layer—it follows you to the new active 
layer. This makes sense when you realize that the selection doesn’t actually 
include image content—it just describes a region with boundaries. And 
following the old advice “Don’t confuse the map with the territory,” you can 
think of the selection as a kind of outline map, and the active layer as the 
territory. 

There are a few other special-purpose layers. For example, you can add 
adjustment layers (see Chapter 3) that let you try out effects on lower layers 
without actually applying them until you’re ready to do so. PhotoPlus stores 
the text you create on text layers, while shapes go on shape layers. Both 
text and shape layers (see Chapter 5) work pretty much like standard 
transparent layers, and keep their respective elements editable so you can go 
back and make changes later.  

We’ll delve further into layers later in this chapter. Chapter 5 provides in-
depth coverage.  

6  Opacity and transparency 
Opacity and transparency are complementary—
like “half full” and “half empty.” They both refer 
to the degree to which a particular pixel’s colour 
contributes to the overall colour at that point in the 
image. (Pixels again are the “screen dots” that comprise a bitmap image in 
PhotoPlus.) Varying opacity is rather like lighting a gauze backdrop (scrim) 
in a theatre: depending on how light falls on it, it can be rendered either 
visible or invisible, or in between. Fully opaque pixels contribute their full 
colour value to the image. Fully transparent pixels are invisible: they 
contribute nothing to the image. 
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In-between pixels are called semi-transparent. You’ll primarily encounter 
these terms in two contexts. First, as a property of the pixels laid down by 
individual paint tools, which can be more or less opaque, depending on the 
tool’s opacity setting. Second, as a property of individual layers, where 
opacity works like a “master setting” that you can vary after paint has been 
laid down. 

7  Saving and exporting 
Saving a file in PhotoPlus means storing the image 
in the native PhotoPlus file format, using the .SPP 
extension. This format preserves image information, 
such as multiple layers, masks, or image map data, 
that would be lost in conversion to most other 
graphic formats. On the other hand, suppose you’ve 
opened a .BMP or .JPG file and want to save it back 
to its original format. In this case, you can use the 
Save Original command. 

In yet another instance, you may be ready to save an .SPP file (or convert 
some other image type) to one of the standard graphics formats. In 
PhotoPlus, this is known as exporting. PhotoPlus includes a powerful Export 
Optimizer that serves as your “command centre” for exporting images to 
various formats. It not only provides a variety of options for each supported 
format, but lets you compare image quality using different settings and even 
retains your preferred settings for each format. And because PhotoPlus 10.0 
is interoperable with Adobe Photoshop, if you export to Photoshop’s .PSD 
format, image information (layers etc.) is preserved—just as if you’d saved 
to .SPP!  

There’s more on saving and exporting later in this chapter, and Chapter 8 
includes details on file formats and optimizing images. 

Starting PhotoPlus 
Enough tedious lecture—on to the demonstrations! (We’ll skip the quiz.) It’s 
time to begin exploring PhotoPlus. 

 NOTE: Throughout the Companion, you’ll see  checkbox bullets 
that mark steps we’d like you to complete as you follow along with 
the text. You’ll come across many other descriptions and examples of 
commands, tools, and procedures (and of course you’re encouraged to 
experiment). But remember—unless a step has a checkbox, it’s 
entirely optional! 
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The Setup routine adds a Serif PhotoPlus 10.0 item to the Programs 
submenu of the Windows Start menu. 

 Use the Windows Start button to pop up the Start Menu and click on the 
PhotoPlus item. 

 
PhotoPlus launches and displays the Startup Wizard, with a variety of 
choices: 

♦ Open Saved Work displays a browser that lets you preview and open 
saved image files—pictures in any supported format as well as animated 
GIFs (see Chapter 6). 

♦ Create New Picture opens a new image window using a size and 
background colour you specify (see Chapter 4). 

♦ Create New Animation opens a new image window and displays the 
Animation tab, with controls for creating animation frames (see Chapter 
6). 

♦ Import from TWAIN lets you bring in pictures from devices like 
scanners and digital cameras (see Chapters 2 and 8). 

♦ View Samples opens the gallery of PhotoPlus images. 

♦ View Tutorials opens the easy-to-follow PhotoPlus Tutorials. 

If you don’t care to see the Startup Wizard again, uncheck the “Use the 
Startup Wizard next time” box. However, we suggest you leave it checked 
until you’re familiar with the equivalent PhotoPlus commands. 

 Click Open Saved Work and then click the Browse button in the 
dialog.  
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 PhotoPlus is set to initially display the contents of the PhotoPlus 

PROJECTS folder, located on your hard disk. If the Open dialog displays 
a different folder, browse to PROGRAM FILES\SERIF\PHOTOPLUS\10.0\ 
PROJECTS. 

 NOTE: Whether or not you use the Projects folder to store your own 
work, remember its location so you’ll know where to find Companion 
source files when they’re needed later on. 

 Select the file CAT.JPG in the Projects folder and click Open.  

 
The cat photograph opens in a new image window (your precise screen 
layout may vary somewhat from the illustration). 
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Getting Your Bearings 
Now that you’ve got an image open, and the PhotoPlus menus and tools are 
available, let’s take a quick look around the PhotoPlus environment. Even if 
you’re in a rush to start working, don’t skip the rest of the chapter! At the 
very least, take note of what’s here so you’ll know where to find the 
information when you need it later. 

Introducing the interface 
PhotoPlus is an MDI application. MDI stands for Multiple Document 
Interface and it means that you can have multiple documents—images, in 
PhotoPlus terms—open at the same time. Each image window contains one 
image, with the image’s name shown in the window’s titlebar. At any given 
time, one image window will be active in front of any others, with its name 
shown in the main PhotoPlus titlebar. 

You can use commands from the Window menu to arrange the image 
windows. If you have more than one image open, then you can switch to 
another window using the Window menu or the keyboard shortcut Ctrl+Tab. 
Double-click on an image window’s titlebar to maximize it.  

The PhotoPlus toolbars and tab windows (tabs for short) are essential 
features of the PhotoPlus environment. The PhotoPlus Toolbars and Tabs 
diagram on the next page identifies the principal tabs and provides an 
overview of what they do. 

 To display the related online help topic for any tab, first click the Help 
button on the top toolbar, then click the tab. 

When you first launch PhotoPlus, it opens with the PhotoPlus toolbars and 
tabs all visible in default positions, with certain tabs “docked” or joined 
together. You can hide, show, or move them individually as needed, and 
dock or undock the tabs. Chances are you’ll want to keep the Tools toolbar 
visible, but if your display area is large enough you might consider moving it 
to a horizontal position alongside the top (Standard) toolbar—or “floating” it 
as a separate palette. Remember, there’s nothing fixed about the PhotoPlus 
interface, so feel free to try different arrangements until you’re satisfied.
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Principal PhotoPlus Toolbars and Tabs 

Standard toolbar 
Provides standard file and Clipboard commands, plus 
Zoom, Pan, Measure, and Web graphics tools.  
Click the [?], then any tab, for context-sensitive help! 

Tools toolbar 
Features tools for selecting regions of the screen, 
painting and erasing, cropping and deforming selections, 
adding shapes and text, retouching... and more 

Context Bar 
Access your tool properties 
quickly and easily with this 
dynamic toolbar 

Brush Tip tab 
Lets you choose and customize 

brush tips for the painting tools, 
define custom brushes 

Colour tab 
Lets you select foreground and 
background colours and change 
the colour mode 
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Layers tab 
Controls for creating, deleting, 
arranging, merging, and setting 
properties of layers in the image 

Navigator tab
Lets you quickly see different parts 
of the image and change the zoom 

i

Instant Effects tab 
Provides multiple categories of 
preset effects for spectacular 
textures and dimensionality 

 
 
 
 

History tab 
Maintains a record of PhotoPlus 
actions and lets you retrace your 
steps 

Histogram tab
Analyze your photo’s colour 

channels individually or when 
combined.
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Paths tab 
Stores independent outlines 
you can convert to (or from) 
selections, apply to any layer

Macros tab
Lets you automate 

commands to increase your 
efficiency and productivity

Animation tab
Provides controls for editing 
animation files (only appears 

in Animation mode)

Channels tab 
View and set your composite 
and individual colour 
channels 
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If you need more room on-screen for a particular operation, press the Tab 
key to turn all the visible tabs off, and again to turn them back on. 

To collapse a tab window, click the  button (click the  button to expand) 
or to turn off a tab window or particular tab, click the  Close button in its 
upper corner. Alternatively, to turn a tab or toolbar off or on, uncheck or 
check its name on the View menu. 

To dock or undock a tab, double-click on its label or drag the tab label to the 
new position, either floating independently or docked in a window next to 
another tab. 

It’s easy to get online help in PhotoPlus. For a summary, see the “Getting 
Help” section at the end of this chapter.  

Setting preferences 
To specify the ruler units, grid interval, and other preferences, choose 
Preferences… from the File menu to open the Preferences dialog. Select the 
appropriate options on the General, Undo, Transparency, Plugins, Layout, 
and/or Browser tab of the dialog. Note that switching off compression in 
Undo will provide faster performance.  

Changes to the Plugins folder will not take effect until PhotoPlus is closed 
and restarted. 

When you have made your choices, click the OK button to save your 
changes or click Cancel to abandon them. 

Managing Workspace Tabs 
At some point in your photo editing session you may want to save the layout 
of your tabs in the current workspace, with respect to positioning, their size, 
whether they are switched on/off and if docked or not. This is easy to achieve 
by selecting Save Workspace tabs… in the View menu. The settings are 
saved to a Workspace file (*.wtb) to a folder of your choice. 

At any point you can Reset Workspace Tabs... to revert back to the default 
tab layout or Load Workspace Tabs... to load another previously saved 
Workspace .wtb file; both options are available via the View menu. 

Note that your PhotoPlus tool properties and view settings remain 
unaffected. 



26    Getting Started 

Setting the view 
Zooming (changing the relative size of the image in relation to its window) 
and panning (moving the image in relation to its window) are essential when 
you’re operating at different levels of detail, or on different portions or an 
image. PhotoPlus provides standard Zoom and Pan tools, plus the Navigator 
tab which combines the best of both—it lets you quickly see different parts 
of the image and change the zoom view.  

 To change the image scale, choose the Zoom tool the Standard toolbar. 
To zoom in, left-click on the image. To zoom in on a particular region, drag 
with the tool to outline the region. To zoom out, right-click on the image. 
The current zoom percentage appears in the titlebar of the image window, 
next to the file name. By the way, if you have a wheel mouse, you can simply 
spin the wheel to change the zoom view! 

You can also change the zoom ratio by choosing Zoom In or Zoom Out 
from the View menu. To restore a 1:1 viewing ratio, choose Normal 
Viewing from the View menu. To scale the window and image to the 
workspace, choose Zoom to Fit. 

 To pan, Choose the Pan tool from the Standard toolbar (or press the 
spacebar) and drag the image to move it in relation to its window. 

The Navigator tab lets you quickly see different parts of the image and 
change the zoom view.  

The red view box rectangle on the preview 
window marks the area of the image 
currently visible in the image window. You 
can drag it around or click the preview to 
change how the image is framed in its 
window. 

Click the “-” button to zoom out, “+” to 
zoom in, or drag the slider to change the 
zoom view. The current view ratio appears at the right. 
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How to Get an Image into PhotoPlus 
Before you can manipulate an image, you’ll need something to work with! 
PhotoPlus can open images saved in a wide variety of industry-standard file 
formats, and acquire images from your TWAIN-compliant digital camera or 
scanner.  

To get a saved image into PhotoPlus, you select Open Saved Work from 
the Startup Wizard. The dialog displays image files you’ve recently worked 
on; select a file or click the Browse button to locate other saved files. As an 
alternative to using the Startup Wizard, you can select the name of a recently 
opened file from the File menu or choose File/Open… to display the Open 
dialog. 

The Open dialog shows dimensions and bit depth (see Chapter 8) 
information for each selected image. To display a thumbnail of the image, 
check Show preview. 

Another option is to use the PhotoPlus Image Browser, which automatically 
creates thumbnails for images in the folders you open. To launch the Image 
Browser, choose Image Browser... from the File menu (or Browse 
Resource CD-ROM... to view content on the PhotoPlus Resource CD). 
Select source folders and preview thumbnails until you find the image you 
need. Right-click a thumbnail for information about the source image. 

As a shortcut from either Windows Explorer or the Image Browser, you can 
simply drag and drop a file icon or preview thumbnail into PhotoPlus. You 
can even drag and drop an active selection from any OLE server application, 
such as another photo editor. If you drop onto an open PhotoPlus image 
window, the image data appears as a new layer. To open a new image 
window, drop onto a blank region within the main workspace. 

If your scanner or digital camera supports the industry-wide TWAIN 
standard, you can bring pictures from these devices directly into PhotoPlus. 
(To set up your TWAIN device for importing, see the documentation 
supplied with the device for operating instructions.)  

To begin scanning a picture into PhotoPlus, either select the Import From 
TWAIN option in the Startup Wizard, or, if the program is already running, 
choose Import from the File menu and then select Acquire. (If PhotoPlus is 
running but there’s no image window open, choose New from the File menu 
to display the Startup Wizard.) If you have more than one TWAIN-
compatible device installed, you may be prompted to select one as the 
source—or you can specify a different source by choosing Import/Select 
Source from the File menu.  
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The acquisition software for the selected device will start up and display its 
window, and you can then carry out the scan, possibly having made a few 
basic adjustments. Note that the features available in image acquisition 
software vary widely and are not under the control of PhotoPlus. Usually, 
you will at least be able to adjust settings for the image source (such as a 
colour photograph, black and white photograph, or colour halftone) and the 
resolution at which the image is to be scanned. For colour theory and tips on 
scanning, see Chapter 8. 

Whether you import the image via the Open dialog or the TWAIN interface, 
it will appear in a new image window in PhotoPlus. Assuming the image is 
not in the native PhotoPlus (.SPP) format or the Adobe Photoshop (.PSD) 
format, it will always have just a single layer, called the Background layer 
(see “Seven Key Concepts” earlier in the chapter). Chapter 5 will explore 
layers in considerable detail; until then we’ll be focusing on techniques that 
work perfectly well on one—or at most two—layers. 

Once you’ve opened an image, you can create an instant working copy in a 
new window by choosing Duplicate... from the Image menu. To revert to the 
saved version of the current image, choose Revert from the File menu. 
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Saving and Exporting Files 
PhotoPlus can save images in its own .SPP format, or export them to any 
standard format (again, see “Seven Key Concepts”). 

Use File/Save (or 
click the Save button) 
to save images in 
PhotoPlus’s own .SPP 
format. SPP images 
preserve information 
such as multiple layers, 
masks, or image map 
data that would be lost 
in conversion to almost 
any other graphic 
format (the one 
exception is the 
Photoshop .PSD 
format). 

Use File/Save As… to save the image as an .SPP file under a different path 
or name. You can store files anywhere on your system. It’s a good idea to 
group your images, for example into project-oriented or thematic folders. 

Suppose you’ve opened a .BMP or .JPG file, done some editing (without 
adding layers), and now wish to save it back to its original format. In this 
case, you can use the File/Save Original or File/Save Original As... 
commands. Using the former will overwrite the original file—so be sure 
that’s what you want to do. 

In many situations, you’ll want to save a file to one of the standard graphics 
formats. In PhotoPlus, this is known as exporting. You can use the Export 
Optimizer to preview image quality before at various settings before going 
ahead with the export.  
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The File menu offers 
two ways of 
accessing the 
Optimizer. Either 
choose File/Export 
Optimizer... to 
display it directly, or 
choose File/Export... 
and then click the 
Optimizer button in 
the dialog. The 
Export dialog itself is 
a standard file dialog 
where you can 
specify the path, 
name, and format for 
the image file. 

The Export Optimizer consists of a left-hand preview display and a right-
hand settings region, with additional buttons along the left of the dialog. In 
animation mode, there’s an extra tab for changing output settings. 

 
To display a different portion of the image, drag the image in the preview 
pane. To change the display scale, choose the Zoom button at the left and 
left-click to zoom in or right-click to zoom out (or choose a zoom percentage 
at the lower left). 
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To adjust the preview display, click one of the View buttons at the left to 
select Single, Double, or Quad display. The illustration above shows Double 
view. The multi-pane (Double and Quad) settings let you compare different 
export settings for one or more file formats. Just click one of the display 
panes to select it as the active pane, then use the Options panel at the right to 
choose an export format and specific settings. Each time you make a new 
choice, the active pane updates to show the effect of filtering using the new 
settings, as well as the estimated file size! 

The Options tab lets you pick a preferred export format, tailor the settings—
including transparency and matte (background) colour—to your needs. Use 
the Size tab if you need to scale the image (typically downward, to preserve 
quality) or squash it horizontally or vertically. When you’ve picked the 
optimum export settings, click the dialog’s Export or OK button to proceed 
to the Export dialog. Again, since the exported image is stored separately 
from your original .SPP file, you won’t have altered the master file at all. 

For details on image file formats and optimization, see Chapter 8. 
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Print Output 
PhotoPlus provides several print-based output options: standard single-
image printing, multi-image printing, and PDF (Portable Document Format) 
export. We’ll cover standard printing here; see Chapter 8 for coverage of 
multi-image and PDF output. 

To print a single image, choose Print… from the File menu, click the Print 
button on the Standard toolbar, or press Ctrl+P. 

 
The General tab provides basic control over printed output, and the preview 
on the left shows the margins of the printable page. Choose a printer from the 
drop-down list; if necessary, click the Properties button to set up the printer 
for the correct page size, etc. It’s very important to set up your printer 
correctly to get the best results. Select the Layout, Separations, and/or 
Prepress tabs if you need to set special options such as scaling, tiling, CMYK 
colour separations, or printer marks. (These advanced print options are 
detailed in Chapter 8.) 

After setting the printer properties and the print options, click the Print 
button to send the image to the printer. Depending on the size and 
complexity of the image, and the printer you’re using, it may take several 
minutes before the printed page emerges. 

You can also use the Print Multiple command (see Chapter 8) to position one 
or more images precisely on the printed page. 
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Getting Help 
The PhotoPlus online help system is designed to work for you. Whatever 
your background, you’ll find it easy to navigate. 

♦ To begin learning about PhotoPlus tools and menus, just move the 
mouse pointer around the screen. Watch the HintLine at the lower left 
for capsule descriptions of each feature. Event Tips pop up as you try 
new tools and actions. 

♦  For help on interface elements like toolbars and tab windows, click 
the Help button on the top toolbar, then click on an element. 

♦ For help on dialog boxes, click their internal Help button. 

Several Help menu choices take you to key features of online help: 

♦ Choose PhotoPlus Help to display the main help menu screen, 
displaying the table of contents and Visual Reference. Click the Index 
button to view an alphabetical list of terms and topics.  

♦ Choose Effects Gallery to display a visual sampler of colour 
adjustments, special effects, and blend modes—cross-referenced to help 
topics (see Chapter 3 for more). 

Once inside online help, use the Visual Reference to explore elements of the 
interface, or choose How To topics from the table of contents for a step-by-
step approach—whichever you prefer. The Previous and Next buttons let 
you browse adjacent topics, while the topic list keeps your place for you. 
Extensive cross-references make sure all the information is interlinked.  

If you’ve purchased the PhotoPlus 10.0 Resource CD-ROM, you can choose 
View PhotoPlus Tutorials to access a set of illustrated, step-by-step mini-
lessons. Stored in HTML format, the tutorials supplement the Companion’s 
hands-on exercises to let you explore features in more depth. Check at the 
end of each Companion chapter for a handy summary of relevant tutorials. 
And be sure to visit the Serif Web site regularly to view the latest tips and 
tutorials! 
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This chapter will focus on ways of manipulating existing pictures, especially 
photos. We’ll begin with a Hands-on Project using the “cat” image you 
briefly opened in the previous chapter. Note that all of the techniques 
described here can also be applied to images created from scratch, and to 
animations. 

There are many reasons why you might want to manipulate a photo, 
including: 

♦ Cleaning up an old, damaged photo 
♦ Removing an unwanted item or slogan from the background 
♦ Preparing an image for printing, use on the World Wide Web, or in 

another package 

If you agree that it’s time to do something about that smug-looking cat from 
Chapter 2, here’s a Hands-on Project that provides an introduction to 
manipulating images. Remember, the bullet checkboxes denote the actual 
steps you should complete; anything else is optional. 

HANDS ON: Captioning a Cat 
 Open CAT.JPG in the PhotoPlus PROJECTS folder, if it’s not already 

open. (See the section “Starting PhotoPlus” in Chapter 2.) 

Cropping the image 
Cropping is one of the easiest ways to improve the appearance of a 
photograph—by creating a more pleasing composition of its main elements. 
In this particular photo, there’s just one main element, and it fills the whole 
image! However, there are a couple of problems with leaving the image 
uncropped. One is the rather boring curtain in the background; the other is 
the large blurry tail in front. So let’s crop away everything except the cat’s 
face. 

PhotoPlus offers two basic ways of cropping an image. You can either select 
a region of pixels, using any of the various selection tools, and then use the 
Image/Crop to Selection command. We’ll cover this method later in the 
chapter. If you’re cropping to a rectangular shape it’s generally easier to use 
the Crop tool. 
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  Choose the Crop tool from the Tools 
toolbar and drag out a crop selection 
around the cat’s head, as in the 
illustration. Start at one corner and drag 
to the other. Once you release the mouse 
button, you can adjust the selection 
rectangle by dragging its edges or 
corners, or from the centre to move it. 

 Once you’ve selected the correct area, 
double-click within the selection 
rectangle to complete the cropping. 

By the way, if you make a mistake, don’t worry. Most actions in PhotoPlus 
can be undone using Undo from the Edit menu, the Undo button on the 
Standard toolbar, or the keyboard shortcut Ctrl+Z. You can even undo an 
“undo”—use Redo on the Edit menu, the Standard toolbar, or with Ctrl+Y. 
(The File/Preferences... dialog lets you set options for the Undo function.) 
Or you can use the Undo History tab to review recent actions and jump 
back more than one step at a time. 

Adjusting brightness and contrast 
You may have noticed that this image is a little dark. No problem. We’ll use 
one of the PhotoPlus image adjustment filters to improve it.  

 Choose Adjust>Brightness/Contrast… from the Image menu to open 
the Brightness/Contrast dialog. 

 Experiment with the Brightness and Contrast sliders. Each time you 
change a slider setting, the image updates. Alternatively, you can type 
values directly into the fields at the right. 

Although you may not achieve perfection with just the Brightness/Contrast 
adjustment, try to obtain solid “bottom” and “top” (shadow and highlight) 
regions without obscuring details or washing out the image. The Brightness 
slider tends to move all the tones in the image one way or the other; Contrast 
compresses or expands the spread between bottom and top. Try the values 
shown—but remember that monitor settings and room lighting can make a 
difference. 
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 When the picture looks better, click OK. (If you click Cancel, the photo 

returns to its previous state.) 

Besides Brightness/Contrast, the PhotoPlus Image menu affords a number of 
functions you can apply to correct shadow/highlight values in an image. 
Adjust>AutoLevels or Adjust>AutoContrast may do the job in one go; if 
not, you can use Adjust>Levels... to apply the same correction algorithms 
with precise control over the results. (See online help for details.) 

 At this point, you may wish to save the picture as a PhotoPlus (.SPP) file 
using File/Save….  
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Adding a caption  
Finally, we’ll venture into uncharted territory. Adding a caption to the photo 
is easy, but it will introduce several new operations: choosing a colour, using 
the Text tool, and working with more than one layer. Don’t worry—it will be 
a very mild introduction! 

 Locate the Colour tab, which is 
probably still open at the right side of 
the screen—but if it’s hidden, check 
its item on the View menu to display 
it. Click the tab so it comes to the front 
and you can see all of it. 

The Colour tab includes (among other 
things) two colour swatches that show the 
current foreground and background colour 
(another of those “Key Concepts”), and a spectrum box that lets you change 
them.  

 Move the “dropper” cursor over the spectrum box and a preview swatch 
(as shown in the illustration) will appear, showing the exact colour under 
the cursor. Find a very light colour that you like, and left-click. You’ll 
see the foreground swatch update. If you want to choose a different 
colour, move the cursor and click again. 

  Now choose the Text tool from the Tools toolbar. Notice there are 
two text tools on the flyout. Pick the first one, which is for solid text (the 
other is for creating selections in the shape of text).  

 Once your cursor has changed to an “A,” click it on the picture in the 
approximate position where you want the text to be. This opens the Add 
Text window.  

 Type the caption text (on two lines, if you’re using our example) and 
choose a font, pointsize, and style (we used Arial 14pt Bold).  
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Note that the formatting is applied to all the text in the window (no need to 
select it first), and that the text is black (for visibility) rather than the 
foreground colour at this point. The dialog also has an Adjust Colour 
button—but let’s leave that for later. 

 Click OK to insert the caption.  

The text appears (in the foreground colour) on a new text layer above the 
Background layer that has the photo. The text layer is now the active layer. 
Because it’s on a separate layer, the text is editable and can be repositioned 
independently of any other image layers. (Chapter 4 will have more on 
working with text.) 

  Choose the Move tool from 
the Tools toolbar and drag the 
text around until it is in the right 
position on the image. 

Finally, save the modified image again 
and/or export it to another format, 
such as .BMP or .JPG. Since 
exporting (to any format other than 
.PSD) “flattens” the image into a 
single layer, you’ll probably want to 
retain an .SPP image with the layers 
intact, in case you decide to do some 
more editing later.  

Making Selections 
Before you can apply effects or filters, or copy parts of a picture to the 
Clipboard, you must define an active selection area. 

Selection options 
In the example just completed, you adjusted brightness and contrast in the 
image as a whole, and dragged an entire text layer around. Many times, 
however, you’ll want to select just a subset of the image (or layer) to work 
on. Selecting, you may recall, was one of the “Key Concepts” presented in 
Chapter 2. Understanding what you can do with selections opens up exciting 
creative possibilities. 
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Whenever there’s a selection, certain tools and commands operate only on 
the pixels inside the selection—as opposed to a condition where nothing is 
selected, in which case those functions generally affect the entire active 
layer. For example, when there’s a selection, the brush tools only work inside 
the selection; the colour simply doesn’t affect outside pixels. If you apply an 
adjustment or special effect from the Image or Effects menus, it only affects 
the selected region. 

Clicking a layer’s name on the Layers tab makes it the active layer. To select 
the whole active layer, choose Select All from the Select menu or press 
Ctrl+A. To select just opaque pixels, Ctrl-click the layer thumbnail. To 
deselect use Ctrl+D. 

PhotoPlus offers a very wide range of selection methods, and a variety of 
commands for modifying the extent or properties of the selected pixels.  

  The standard selection tools are located on the Standard Selection 
Tools flyout on the Tools toolbar. There you can choose from the Rectangle, 
Ellipse, Freehand, Polygon, or Magnetic selection tools. 

To select a rectangular or elliptical area, select the  Rectangle or  
Ellipse tool from the flyout and drag to define a region on the image. 

          
  Rectangle / Square     Ellipse / Circle 

The selected region is bounded by a broken line or marquee, and the cursor 
over the selection changes to the Move Marquee cursor, which lets you 
reposition just the marquee as needed without affecting the underlying 
pixels. 

 Holding down the Ctrl key during dragging constrains the selection 
shape to either a square or a circle. If the Snapping feature is enabled (via 
View/Snapping or the HintLine button shown), the marquee’s edges jump 
as you drag to align with visible grid points, guide lines, and/or document 
edges. (See “Using screen layout tools” in online help for details.)  

 To select a freehand (irregular) area, select the Freehand selection tool 
and just drag to draw around the area to be selected, making a closed area.  

 Or use the Polygon selection tool to draw a series of line segments 
(double-click to close the polygon). 
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Freehand                                 Polygon 

The Adjustable Selection Tools flyout, a unique 
PhotoPlus feature, offers 20 different variable selection 
shapes, including pie, star, arrow, heart, spiral, wave, 
and so on.  

Here’s how the adjustable selection tools work. We’ll 
use the regular polygon selection shape as an example. 

Choose a tool from the flyout and drag out a shape on the image. You can 
hold down the Shift key to constrain the selection’s aspect ratio, move, scale 
or snap your selection to the grid as appropriate. 

The regular polygon appears as an outline with 
two slider tracks bounding it. Each of the 
slider tracks has a square handle, and when 
you move the cursor on to the handle it will 
change to a small + sign. As you drag the 
sliders, the shape’s properties change. In the 
case of the polygon, one slider varies the 
number of sides, while the other rotates the 
shape. Once you’re satisfied with the selection, 
double-click in the centre (just as with the 
Crop tool or Magnetic selection tool) to 

complete the marquee. 

 The Magnetic Selection tool makes it 
easy to isolate part of an image where there’s 
already a bit of an edge showing. You simply 
trace around the edge, and PhotoPlus snaps 
the selection marquee to the nearest dramatic 
colour change. Click once on the image to 
place a starting node along an edge. With the 
mouse button up, trace along the edge; the 
marquee line follows the nearest edge. At regular distances, nodes 
automatically appear along the line. Only the portion of the line beyond the 
last node remains adjustable.  

You can add a node manually (for example, at a corner), by clicking once, or 
“back up” by pressing Delete to undo recent nodes one at a time. To close 
the selection region, double-click or click again on the starting node. On the 
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Context Bar, you can adjust the tool’s Frequency (distance between 
automatic nodes) and Contrast (edge sensitivity) for best results. As a 
shortcut, press the up and down arrow keys (or use your mouse’s spinwheel) 
to adjust the contrast setting on the fly. 

If you’re trying to lift a region away from its background and find the 
Magnetic selection tool still too laborious, try the Edit menu’s Extract... 
command. This lets you mark the edge contour rapidly using a broad brush, 
and then applies edge-detection within the swath you’ve marked. Note that 
Extract directly affects the layer or selection—pixels outside the detected 
edge vanish to transparency, while interior pixels are preserved. (See online 
help for details.) 

 Using the Colour Selection tool, you can select a region based on the 
colour similarity of adjacent pixels. 

To make a selection in this way, choose the tool from the Tools toolbar and 
then click on a starting pixel. This selects the pixel you clicked, and any 
adjacent pixels that are similar in colour, as measured by the tolerance value 
shown on the Context bar (see p. 77). You can raise or lower the tolerance 
setting to include more or fewer pixels.  

To make a selection based on “tagging” a specific range of colours in the 
image, choose Colour Range... from the Select menu. To initially tag a 
particular colour group, such as “Reds” or “Midtones,” choose the group’s 
name from the Select list. Alternatively, you can tag a range by hand: click 
the  Colour Picker button and drag in the Preview window (with this 
method, the Tolerance slider lets you include a wider or narrower range of 
colours in the selection).  

Once you’ve made an initial selection, you can use the Add Colour and 
Subtract Colour buttons and drag to tweak the tagged range. Meanwhile, the 
dialog provides visual feedback. If Show Selection is checked, the greyscale 
Selection window on the right shows tagged values as brighter, with 
untagged pixels darker. You can customize what’s displayed in the Preview 
window on the left by picking an option from the Preview list: “None” shows 
the original image, “White Matte” shows tagged pixels through a white 
background, and so on. 
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PhotoPlus also offers a Text Selection tool that lets you create a text-shaped 
selection region and vary its size or font (see the next chapter). 

Modifying the selection 
Once you’ve used a selection tool to select a region, you can carry out a 
number of additional steps to fine-tune the selection before you actually 
apply an effect or manipulation to the selected pixels. 

Any time you’re using one of the selection tools, the cursor over a selected 
region changes to the Move Marquee cursor, which lets you drag the 
marquee outline to reposition it. You can also use the keyboard arrows to 
“nudge” the selection. In this case you’re only moving the selection outline—
not the image content inside it. You’d use the Move tool (see below) to drag 
the selection plus its image content. 

If the selection you’ve made isn’t quite the right shape, or doesn’t quite 
include all the necessary pixels (or perhaps includes a few too many), you 
can continue to use the selection tools to add to, or subtract from, the selected 
region. To add to the existing selection, drag with the selection tool while 
holding down the Shift key. To subtract, drag while holding down the Alt 
key. Pressing the Ctrl key changes the tool temporarily to the Move tool (see 
below), so you can move the selection’s content. 
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When a standard  selection tool is active, the Context bar includes four 
combination buttons (  New,  Add,  Subtract, and  Intersect) that 
determine the effect of each new operation with a selection tool. You may 
find this easier than using the keyboard shortcuts, and the Intersect option is 
unique. Starting with a standard square selection, here’s what a second 
selection operation might produce with the other combination settings: 

 
  New                Add                Subtract            Intersect 

The Modify item on the Select menu provides a submenu with several 
functions that can save you the trouble of hand-drawing to change the 
selection boundaries. Choose Contract... to shrink the borders of the 
selection, or Expand... to extend its borders. Border... creates a new 
selection as a “frame” of a specified pixel width around the current selection. 
If the selected area has ragged edges or discontinuous regions (for example, 
if you’ve just used the Colour Selection tool), you can use the Smooth... 
command to even them out. 

Grow and Similar both expand the selection by seeking out pixels close (in 
colour terms) to those in the current selection. Grow only adds pixels 
adjacent to the current selection, while Similar extends the selection to any 
similar pixels in the active layer. Both of these use the current tolerance 
value entered for the Colour Selection tool (see above). 

To remove the current selection, choose Deselect from the Select menu, or 
use the keyboard shortcut Ctrl+D. 

The Invert command on the Select menu (shortcut Ctrl+Shift+I) selects the 
portion of the active layer outside the current selection. Unselected pixels 
become selected, and vice versa. 

Variable selections 
Just as greyscale is more than black-and-white, a selection can be more 
complex than an all-or-nothing proposition. Within the selected/marqueed 
region, individual pixels can have varying degrees of “selectedness.”  



Manipulating Images    47 

 

 

Anti-aliasing and feathering are properties of the various selection tools 
that can help you achieve softer edges and smoother blending of elements 
that are being combined in the image. You can turn either option on or off 
for the Standard and Adjustable Selection tools, using the check boxes on the 
Tools Properties tab. Anti-aliasing makes the selection’s edge pixels semi-
transparent, while feathering reduces the sharpness of a selection’s edges not 
by varying transparency, but by partially selecting edge pixels. If you lay 
down paint on a feathered selection, the paint will actually be less intense 
around the edges.  

You can apply feathering “after the fact” to an existing selection (but before 
applying any editing changes) using the Select menu’s Modify>Feather... 
command. Modify>Threshold converts a feathered, soft-edged selection into 
a hard-edged selection. As with feathering, you won’t see an immediate 
effect on the image, but painting and other editing operations will work 
differently inside the selection. 

Paint to Select mode is a convenient way to achieve varying degrees of 
selectedness on a layer. Using the standard painting and editing tools in this 
mode, you can create a selection from scratch or modify an existing 
selection. Check Paint to Select on the Select menu and the image view 
switches to indicate selected regions using a coloured mask. Choose 
Select/Paint to Select Options to specify whether to mask selected or 
unselected areas, and which colour and opacity to use. In the default view, 
fully selected regions are masked 50% with red and semi-selected regions 
appear pinkish, while deselected regions have no colouration. In Paint to 
Select mode you can paint or use other manipulations on the temporary mask 
to directly modify the selection according to the lightness of the colours you 
apply. Painting in white adds to the selection; black subtracts from it; grey 
creates partial selection.  

This view shows “selectedness” much more clearly than the standard 
marquee mode, so it’s also a good way to preview or check a complex 
selection. 

In the illustration below, (A) depicts the incomplete result of using the 
Magnetic Selection tool on a white flower. In Paint to Select mode (B) the 
selected regions appear as red (grey here) and we are busy filling in the 
selected regions with a white brush. (C) shows the completely filled-in 
flower and (D) the fully selected result.  
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Once you have selected precisely the pixels you want to work on (as covered 
so far in this chapter), the question arises: what can you do with the 
selection—or technically speaking, with the pixels you’ve outlined? The rest 
of the chapter will survey the many possible manipulations you can perform. 

Using the Move Tool 

 The Move tool (unlike the Move Marquee cursor associated with the 
selection tools) is for pushing actual pixels around. With it, you can drag the 
contents of a selection from one place to another, rather than just moving the 
selection outline. To use the tool, simply click on the selection and drag to 
the new location (or use the keyboard arrows to nudge). The selected part of 
the image moves also. If the Snapping feature is enabled (via 
View/Snapping or the HintLine button), the moved region’s edges align 
with visible grid points, guide lines, and/or document edges.  

If nothing is selected, dragging with the Move tool moves the entire active 
layer. (Or, if the Move tool’s Automatically Select Layer property is 
selected, the tool intelligently moves to the first visible layer.) Moving image 
content on the Background layer exposes a “hole” that appears in the current 
background colour; on standard layers, the exposed region is transparent. 

To duplicate the contents of the selection on the active layer, press the Alt 
key and click, then drag with the Move tool. 

As a shortcut if you’re working with any one of the selection tools, you can 
press the Ctrl key to switch temporarily to the Move tool. Press Ctrl+Alt to 
duplicate. Release the key(s) to revert to the selection tool.  

Cut, Copy, Paste, Delete 
These operations work pretty much as you’d expect. You can use the buttons 
on the Standard toolbar, choose commands from the Edit menu, or use 
conventional keyboard shortcuts.  
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As with the Move tool, “holes” appear as either the current background 
colour or transparent, depending which layer you’re working on. Also keep 
in mind the handy Alt+Move tool operation (above) for quickly duplicating 
selected pixels.  

When pasting from the Clipboard, PhotoPlus offers several options. The 
standard paste (Ctrl+V) operation creates a new, untitled image window. You 
can use other Edit menu choices to paste the Clipboard contents as a new 
layer (Ctrl+L), or centred into the current selection (Shift+Ctrl+L). The Into 
Selection option is useful if you’re pasting from one layer to another. 
Because the selection marquee “follows” you to the new layer, you can use it 
to keep the pasted contents in registration with the previous layer. 

Cropping 
Cropping is the electronic equivalent of taking a pair of scissors to a 
photograph, except of course with a pair of scissors there is no second 
chance! Cropping deletes all of the pixels outside the crop selection area, and 
then resizes the image canvas so that only the area inside the crop selection 
remains. 

 If you tried the captioning project earlier in the chapter, you’ve already 
used the Crop tool to reduce an image to a regular, rectangular area. Just 
select the Crop tool from the Tools toolbar and drag out a rectangular crop 
selection area on the image. (Hold down the Ctrl key while dragging to 
constrain the selection to a square.) Adjust the selection rectangle as needed, 
then double-click to complete cropping.  

               
You can also crop an image to any selection region, no matter what shape, as 
defined with one of the selection tools (see above). 

Make a selection using one of the selection tools and then choose Crop to 
Selection from the Image menu. For example, here’s cropping applied to a 
marquee drawn with the Freehand Selection tool: 
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PhotoPlus always crops to a rectangular image. If the selection region is non-
rectangular, the left-over surrounding region will be either transparent (on a 
standard layer) or the background colour (on the Background layer).  

Try also cropping your selection using the Fixed Size 
(shown) and Fixed Aspect in the Context Bar when the 
crop tool is selected. Choose a pixel dimension or an 
aspect ratio, respectively, and set crop selection values.  

Tip: To convert the Background layer to a standard layer, right-click 
Background on the Layers tab and choose Promote to Layer. Now 
operations on the layer’s content (such as moving, cutting, or irregular 
cropping) will leave transparent “holes.” 

Flipping, Rotating, and Deforming 
Flipping and rotating are standard manipulations that you can carry out on 
the whole image, the active layer, or just on a selection.  

To flip, choose either Flip Horizontally or Flip Vertically from the Image 
menu, then select Image, Layer, or Selection from the submenu. If you flip 
an image horizontally, be careful not to accidentally reverse things like text, 
numbers, and so on. 

To rotate, choose Rotate… from the Image menu to and select an option: the 
object (Image, Layer, or Selection), rotation angle (90º, 180º, or enter a 
custom angle), and the direction (clockwise or anti-clockwise). The image 
will rotate about the centre point. 

   
Original image 15° anti-clockwise 10° clockwise 



Manipulating Images    51 

 

 

 The Deform tool is a “Jack of all trades” that lets you move, scale, 
rotate, or skew a selection or layer. Try it on a text 
layer for unique results! Start by making a selection if 
desired, then choose the tool. A rectangle appears 
with handles at its corners and edges, and a fixed 
point (initially in the centre of the region). If there’s 
no selection, the rectangle includes the whole active 
layer.  

The tool’s action depends on the exact position of the mouse pointer. As you 
move the pointer around the enclosed region, the cursor changes as shown 
below to indicate which action is possible. 

 To move the region without any deformation, drag from its neutral 
midsection. This action works just like the Move tool. 

To reshape the region, drag from an edge or corner handle. A 
variety of options are available when you drag from a corner (watch 

the HintLine for tips). You can resize in two dimensions or relative to the 
fixed point, either with or without a constant aspect ratio. In addition, you 
can get skew or perspective effects that move either one corner by itself, or 
two adjacent corners! 

To rotate the region about the fixed point, drag from just outside a 
corner. To constrain rotation in 15-degree steps, press the Shift key 
after you’ve begun rotation, and hold it down until after you release 

the mouse button. 

To reposition the fixed point, move the cursor to the exact centre 
until a small target appears, then drag. The fixed point can be moved 

anywhere—even outside the deformation region. 

HANDS ON: Deforming text 
To get a feel for the versatility of the Deform tool, let’s try a short project.  

 To begin, choose New from the File menu and (on the Startup Wizard) 
click Create New Picture.  

 In the New Image dialog, set the image dimensions to 500x500 or so. 
The background type should be set to White. 

 Click OK, and the new image window opens. The image initially has a 
single Background layer. 
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 Now choose the  Text tool and click in the image to open the Add 
Text window. Type some text, set it large (around 24pt), and click OK. 
(You’ve done this before in the captioning project.) The new text 
appears on a separate text layer. 

 Choose the Deform tool, which automatically grabs the text on the layer. 

 
 Move the cursor near a corner handle until you it changes to a double-

headed arrow. Then drag to resize the letters either vertically or 
horizontally.  

 

 Hold down the Shift key and drag from a corner to resize in both 
dimensions at the same time.  

 

 Hold down the Ctrl key over a corner handle. Continue to hold down the 
Ctrl key while dragging to skew the object. 

 
 Move the cursor outside one corner of the text and it will change to a 

curved arrow. Try dragging to rotate the text, and holding down the Shift 
key for constrained rotation.  
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 Press Shift+Ctrl+Alt while dragging from a corner for a perspective 

effect. Note that you can still apply layer effects, fills, and other 
manipulations to deformed image content. And once you have rotated or 
deformed text, you can still edit it as long as it’s on a text layer!  

 

Using Mesh Warp 

 The Mesh Warp tool works like the Deform tool (see above) outfitted 
with complex curves. It lets you define a flexible grid of points and lines that 
you can drag to distort an image, or part of an image (or layer). You can edit 
the mesh to vary its curvature, and even custom-design a mesh to match a 
particular image’s geometry, for more precise control of the warp effect. 

When you first select the tool, a simple rectangular mesh appears over the 
image, with nine nodes: one at each corner, one at the centre, and one at the 
midpoint of each edge. Straight lines connect adjacent nodes. The Context 
bar also changes to reflect the settings appropriate for the Mesh toolbar. 
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These “straight” line segments are actually bendable curves. When you alter 
the contours of the mesh and distort the initial rectangular grid, the 
underlying image deforms accordingly. To change the mesh, you simply 
move nodes, handles, or connecting lines; add or subtract nodes as needed; 
and/or edit nodes to change the curvature of adjoining lines. 

 
To select a mesh node, click it. (Shift-click or drag a marquee to select 
multiple nodes.) One or more attractor handles appear on the selected 
node(s) and on any adjacent nodes.  

To warp the mesh, drag any mesh node or line segment, or drag a node’s 
attractor handles. The image responds immediately as the mesh is warped. 

 To add a new node, double-click on a line segment or click the Add 
Node button on the Context bar.  

 To delete nodes, select them and press Delete, or click the Delete 
Node button on the Context bar. 

 The special Deform Mesh tool makes it easy to move, scale, skew, or 
rotate a portion of the mesh about a fixed point. It works just like the 
standard Deform tool (described above) on multiple nodes. 

The bendability of line segments depends on the type of nodes at either end. 
You can change a node from one type to another simply by selecting it and 
using the Context bar buttons: 

 Sharp means that the curves on either side of the node are completely 
independent, so the contours can be adjusted separately. 

 Smooth means that the slope of the curve is the same on both sides of 
the node, but the depth of the contours on either side can differ. 

 Symmetric nodes join curves with the same slope and depth on both 
sides of the node. 
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See PhotoPlus online help for further details on Mesh Warp, including Setup 
mode, which lets you create an initial custom mesh that conforms to the 
underlying image, for more precise shaping of image contours.  

Channels 
Before looking into adjusting images, it’s a good time to look at colour 
channels in PhotoPlus. 

It goes without saying that every colour photo that you use in PhotoPlus will 
have channels associated with it. For the colour mode RGB, the individual 
channels will be Red (R), Green (G) and Blue (B), plus a combined channel 
called the composite RGB channel. Each channel stores that particular 
colour’s information, which when combined with the other channels, bring 
about the full colour image.  

Within PhotoPlus, the use of multiple layers could possibly confuse the user 
with respect to understanding channels. What do the channels refer to? —the 
entire photo, part of it, a layer? The answer is simple—channels are always a 
colour sub-set of the active selected layer, whether this is a background, 
standard, shape or text layer. Remember that an imported photo will have a 
single background layer by default.  

PhotoPlus lets you show, hide, switch on, or switch off the channels of any 
photo from a single point, called the Channels tab.  This tab lists the 
composite RGB and each individual Red, Green and Blue channel in turn. 

 

  Channels can be shown or hidden by clicking the eye icon next to 
the channel. When the eye is open the channel is visible. The composite 
RGB channel is shown only when all the other channels are shown. When a 
single or pair of single channels is shown the composite channel will never 
be shown. Give it a try—remember to study the effect this has on your photo. 
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An equally powerful feature of the Channels tab is the opportunity to select 
individual channels for edit. You may have noticed the thumbnail to the left 
of the channel name. By default, the channels are always selected, as 
indicated by the dark border around the thumbnail (compare the deselected 
Green channel to the selected Blue channel).  

You can select the channels by simply clicking the 
thumbnail once. Note that this is independent of the 
show/hide channel setting discussed previously. The 
selected channel(s) can be viewed as greyscale or in 
colour (via a right-click on the channel name).  

Note that making the channel you are editing the only channel visible will 
help you during the editing process. 

 Why do we want to select channels anyway? This is because you can apply 
an edit to a selected individual channel in isolation. Typically, you could: 

♦ Apply a filter effect 
♦ Make an image adjustment 
♦ Paint onto a channel 
♦ Use the magic wand 
♦ Paste selections 
♦ Fill the channel 
♦ ... and many more! 

This is because a colour channel is treated as a subset of a layer, so anything 
you could apply to a layer can pretty much be applied to a channel.  

Adjusting Image Values 
PhotoPlus provides a number of different adjustment filters that you can 
apply to a selection or to a standard layer. Typically, these adjustments are 
used to correct deficiencies in the original image. You can apply them either 
directly, via the Image/Adjust menu, or (in most cases) by using an 
adjustment layer.  

Each of the adjustment options works in a similar way. Alter the values by 
dragging on a slider, moving it to the left to decrease the value, or the right to 
increase the value, or enter a value in the field at the right of the slider. 
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Tip: Instead of dragging the slider with the mouse, you can click on it and 
then jog it with the left or right cursor arrow keys. 

Here’s a quick summary of the PhotoPlus image adjustments. 

♦ AutoLevels and AutoContrast redistribute the lightness (luminance) 
values in the image, making the darkest image pixel black and the 
lightest one white, and adjusting the spread in between. AutoLevels 
performs this adjustment separately for each of the Red, Green, and Blue 
channels, while AutoContrast operates on the image as a whole. 

♦ Levels pops up a dialog that affords more precise control than either 
AutoLevels or AutoContrast. While viewing a histogram plot of 
lightness values in the image, you can adjust the tonal range by shifting 
dark, light, and gamma values. 

♦ Curves displays lightness values in the image using a line graph, and 
lets you adjust points along the curve to fine-tune the tonal range. 

♦ Colour Balance lets you adjust colour and tonal balance for general 
colour correction in the image. 

♦ Brightness/Contrast: Brightness refers to overall lightness or darkness, 
while contrast describes the tonal range, or spread between lightest and 
darkest values. 

♦ Hue/Saturation/Lightness: Hue refers to the colour’s tint—what most 
of us think of as rainbow or spectrum colours with name associations, 
like “blue” or “magenta.” Saturation describes the colour’s purity—a 
totally unsaturated image has only greys. Lightness is what we 
intuitively understand as relative darkness or lightness—ranging from 
full black at one end to full white at the other. 

♦ Replace Colour lets you “tag” one or more ranges of the full colour 
spectrum that require adjustment in the image, then apply variations in 
hue, saturation, and/or brightness to just those colour regions. 

♦ Selective Colour lets you add or subtract a certain percentage of cyan, 
magenta, yellow, and/or black ink for creating effects. 

♦ Channel Mixer lets you modify a colour channel using a mix of the 
current colour channels. 

♦ Gradient Map lets you remap greyscale (lightness) information in the 
image to a selected gradient. The function replaces pixels of a given 
lightness in the original image with the corresponding colour value from 
the gradient spectrum. 
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♦ Threshold creates a monochromatic (black and white) rendering. You 
can set the threshold, that is the lightness or grey value above which 
colours are inverted. 

♦ Equalize evenly distributes the lightness levels between existing bottom 
(darkest) and top (lightest) values.  

♦ Negative Image inverts the colours, giving the effect of a photographic 
negative. 

♦ Greyscale reduces a colour picture to 256 shades of grey.  
♦ Posterize produces a special effect by reducing the image to a limited 

number of colours. 
♦ Shadow/Highlight/Midtone alters the intensity, range, and radius of 

shadows, highlights, and contrast within the image. 

For an overview of image adjustments, take 
a look at the Effects Gallery, a component 
of PhotoPlus online help. It’s a great way to 
get an overview of what Adjustments and 
Effects do. From the Help menu, choose 
Effects Gallery... then select the Filters & 
Tools tab. 

The Effects Gallery provides illustrations of 
all the Image and Effects menu adjustments 
and effects, plus the various Blend Modes 
(used for paint tools and layers, and 
discussed later in the Companion). For each 
category, there’s a list of names. Clicking on 
the name shown in red text displays an 
example, and then clicking the name again (now in green text) displays the 
corresponding help topic in an adjacent window. This way you can browse 
the illustrations and read about them at the same time. 

Click on the View Original button above each illustration to view the image 
as it appeared before the filter was applied. Click on the Apply Effect button 
to see the after state. 
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Adjustment layers 
Adjustment layers let you introduce any number of effects experimentally. 
Instead of altering the image or layer directly, you allow yourself the option 
of revisiting the settings for a given adjustment as often as needed, while 
continuing to edit the image in other ways. If you later decide you don’t even 
need an effect, you can simply remove it! 

 To create an adjustment layer, click the New Adjustment Layer button 
on the Layers tab (or choose the item from the Layers menu) and select the 
name of the adjustment to be applied; most of those listed above are 
available. Then, just as if you’d selected the same effect from the Image 
menu, you use a dialog to pick the settings to be applied. The image responds 
as if you’d used the Image menu—but if you look over on the Layers tab, 
you’ll see a new adjustment layer has been inserted above the active layer. 

Unlike the other layer types (as described in Chapter 5), adjustment layers 
don’t store content in the form of bitmap images, text, or shapes. Rather, 
each adjustment layer applies one effect to content on the layers below it. 
You can even combine multiple effects by stacking several adjustment 
layers. 

To change the specific settings for an effect, simply double-click the 
adjustment layer’s name in the list and then use the dialog again. Right-click 
to access conventional layer properties such as name and blend mode. You 
can drag an adjustment layer up or down within the list to determine exactly 
which other layers are below and therefore affected by it. To see how the 
image looks without the effect, click the Hide Layer button next to the 
adjustment layer’s name. If you decide to permanently remove the effect, you 
can delete the layer. 
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Applying Effect Filters 
 The PhotoPlus Effects menu 
includes a number of commands 
that apply special effects to the 
active layer or selection. As with 
the image adjustment filters you 
can use these effects to improve 
the image—for example Unsharp 
Mask for crisper detail, Median 
to remove digital camera artifacts, 
or Fix Red Eye to make baby look 
human—but more often the 
emphasis here is on the wild and 
wacky (or perhaps we should say 
“creative”) possibilities. If you’re 
creating animations, you can turn 
most of these effects into animated 
transitions (see Chapter 6).  

PhotoPlus lets you place industry-standard Photoshop plug-in filters in a 
Plugins folder and access them from the Effects menu. You can even define 
your own custom filters (see online help for details).  

The Effects Gallery, as mentioned earlier, includes examples of all the 
special effects, cross-referenced to explanatory text for each effect. 

To access a group of effects, choose Effects and select one of the commands. 

At the top of most of the dialogs there is a preview window that updates as 
you adjust the sliders or enter new values. To see a different part of the 
image, drag it with the hand cursor. Click the Zoom buttons to zoom in or 
out. 

Effects menu filters are not the only way to apply special effects. Several 
PhotoPlus tools let you use brushes to warp, smudge, blur, or sharpen the 
image locally. For details, see Chapter 4’s discussion of the Warp and 
Retouch flyouts. 

Finally, we should mention the wide range of PhotoPlus 2D and 3D layer 
effects, available from the Effects>Effects option on the Layers menu. 
Unlike image adjustments and Effects menu manipulations, layer effects 
don’t directly change image pixels—they work like mathematical “lenses” 
that transform how a layer’s bitmap appears. Since the settings are 
independent, you can adjust them ad infinitum until you get the result you 
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want! You’ll find detailed coverage of layer effects in Chapter 5. 

Multiple effects 
It’s quite possible to apply several effects to the same image, and, depending 
on the order in which they are applied, to end up with a different final result.  

   
The original image Blurred by 20 Embossed by 70 

   
Original Embossed by 70 Blurred by 20 
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HANDS ON: Photo-painting I 
This fun project will apply a series of experimental manipulations that make 
a photograph of a Paris street scene look more like an abstract painting. In 
the following project you can give the Instant Artist effects a try. 

 Open the file FRANCE.JPG in the PhotoPlus PROJECTS folder. 

 To reduce clutter, use the Crop tool to create a new composition as 
shown in the illustration. This will let you see the results of each filter 
more clearly.  

 
 Choose Adjust>Brightness/Contrast from the Image menu and, in the 

dialog, increase the brightness by 17. 

 Choose Blur>Gaussian Blur from the Effects menu and apply a 
Gaussian Blur with a Radius of 2. 

 Choose Adjust>Posterize… from the Image menu and apply a posterize 
value of 13. 

 Choose Adjust>Hue, Saturation, Lightness from the Image menu and 
boost the saturation to 30. 

 To crispen the colour regions, choose Sharpen>Unsharp Mask... from 
the Effects menu, and set a Radius value of 10 pixels. Et voilà! 
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If you try repeating this sequence using adjustment layers for the brightness, 
posterize, and saturation steps, you’ll see that the edge enhancement step, 
which produced such dramatic results before, is now barely noticeable. 
That’s because it’s applied directly to the Background layer, and so changes 
the actual pixels there before the adjustment layer effects are figured in. It 
doesn’t matter that you inserted the adjustment layers earlier: they are still 
just commands to post-process pixels they find on the layers below. That’s a 
useful concept to keep in mind when you work with adjustment layers. 

HANDS ON: Photo-painting II 
Here we’ll start with the same source image and see what kind of results we 
can achieve with the Instant Artist effects.  

 Open FRANCE.JPG and again crop the image as shown below.  

It’s generally a good idea to optimize the image and clean up any scratches 
or noise before applying an Instant Artist effect. 

 To improve the tonal range this time, use Image/Adjust>Levels. Note 
in the histogram that this particular image has preponderantly dark 
pixels, with a small cluster of very light pixels (Before, below). Before 
applying Auto contrast enhancement to even out the distribution, click 
the Options... button. The Enhance Contrast method will probably be 
“Per Channel,” which is equivalent to the AutoLevels command we’ve 
previously mentioned. If the Clip Whites value is below 1.0%, increase 
it to that level. By clipping (excluding) this one percent of the brightest 
pixels we can improve the algorithm’s results. Now click OK, then click 
the Auto button. The result should be a fairly even distribution of pixel 
lightness values across the tonal range (After). 
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 Before After 

By the way, you don’t have to take our word that the Clip Whites setting 
makes a difference—try experimenting with it yourself! 

 Now choose Instant Artist from the Effects menu and select Paint and 
Ink in the list. You’ll see most of the image in the preview window. To 
see a different part of the image, drag with the hand cursor. Click the 
Zoom buttons to zoom in or out. This filter really does yield a nice result 
instantly, without much additional tweaking! Click OK to see the effect 
applied to the entire image. (Shown here: Level 5, Paint Detail 69.)  

 
Now let’s get a sense of how much variety is possible within a single effect. 

 Use Undo to remove the previously applied effect, and choose Instant 
Artist again. This time select Pointillist and click the 
Advanced button to reveal the full range of settings. 
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Online help includes detailed coverage of all the parameters, but here’s a 
quick synopsis. Dot Size, amazingly enough, determines the size of the 
dots. A lower Colour Jitter setting yields a closer match between the 
brush colour and the original image. Weight and Length both affect the 
brush strokes you see, while Curve determines how closely original 
edges in the picture are followed. Edge Blur reduces image detail, while 
the Enhance setting restores detail by enhancing edges. Depending on 
the settings, you can achieve snappier results, for example, or more/less 
of a brushed effect. (Here we’ve used Dot Size 3, Colour Jitter 80, 
Weight 70, Blur 8.)  

 
 Keep on experimenting with other Instant Artist effects! Some will work 

better than others on this particular photo, so you might want to try a 
different starting image, perhaps one of your own photographs—for 
example, a portrait, still life, or landscape. 

 
Instant Artist/Oil effect (Brush 6, Accuracy 75) 
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HANDS ON: Antiquing a Photo 
This sequence will show you how to make a new colour photo look like an 
old sepia-toned image. The approach here is a bit labor-intensive, but it 
serves to introduce some new layer techniques—a preview of Chapter 5’s in-
depth coverage. (For colourizing images quickly, you might also try the 
Hue/Saturation/Lightness or Channel Mixer adjustments.) 

 Open the file HOUSE.JPG in the PhotoPlus PROJECTS folder. 

 Choose Adjust>Brightness/Contrast… from the Image menu and 
increase both the brightness and contrast by 10 to make the picture look 
a bit faded. 

 Next, add some grain to the image by choosing Noise/Add… from the 
Effects menu. Increase the value to about 15. 

 Choose Adjust>Greyscale 
from the Image menu to make 
the photograph black and 
white. 

 

To create the sepia look, we will 
be adding a semi-transparent 
colour layer above the photo. 

 Choose New Layer from the 
Layers menu. In the dialog, 
call the new layer “Sepia” and set its Opacity to 40. Leave the Blend 
Mode at Normal for the time being.  

 
Click OK and you’ll see the new layer’s name appear on the Layers tab 
(although the image won’t look any different). 

 Using the Colour tab, set the foreground colour to be an orange hue 
(suggested values: R=255, G=166, B=0). 
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  Select the Flood Fill tool and click on the image to fill the active 
layer (“Sepia”) with the foreground colour. (The next chapter will look 
at fills in more detail.) 

Even though the Sepia layer is semi-transparent, its lightness tends to wash 
out the darker details in the photograph. Here’s how changing the layer’s 
blend mode can correct that condition. 

 On the Layers tab, click the drop-down list (now set to “Normal”) and 
choose “Multiply.” The result is a new way of combining the Sepia 
layer’s pixels with those below. Multiply always produces a darker 
value, so the bottom tones in the original picture are preserved.  

The last step is to add a simple frame. 

 On the Colour tab, define black as the background colour by clicking the 
background swatch and setting its RGB value to “0,0,0.” 

 Choose Canvas Size... from the Image 
menu, check relative and enter 40 into the 
New Width and New Height boxes. Click 
the centre anchor point so that the existing 
image will be centred with respect to the 
edge pixels being added. Click OK.  
 

The result? A black border around the sepia-toned photo. If the results don’t 
look quite right to you, feel free to retrace your steps using Undo, and try 
new toning values, transparency, or canvas adjustments. 
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Tutorial Resources 
For more experience with the tools and techniques covered in this chapter, 
we recommend these HTML-based tutorials: 

Try this tutorial... For practice with these tools and techniques... 

Basic Photograph 
Correction 

Routine digital image enhancements: 
AutoContrast/AutoLevels, Red Eye tool, Unsharp Mask 

Replacing Colours Replace Colour filter, Blend Modes 

Adding Colour to 
Black and White 
Images 

Adding colour to a greyscale image 

Oil Painting Effect Median Cut, Edge Enhance image filters; Export 
Optimizer 

Distortion Effects I Mesh Warp tool 

Distortion Effects II Mesh Warp tool’s Deform Mesh function, Crop tool 

Creating Popart Linear fill editing and applying a Gradient Map 

Basic Art Effects Image filters including Blur, Twirl, Edge Enhance, 
Mosaic, Negative Image 

 

 

 



 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

4.  
 

Working with Paint, 
Shapes, and Text 
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The previous chapter described a variety of ways of working with existing 
images—especially photographs, and usually on a single layer. Now it’s time 
to look at creating elements from scratch, using the range of PhotoPlus paint 
and text tools. Perhaps you need to add text to a photo, along the lines of 
Chapter 2’s “cat” Hands-on Project. Or perhaps you’re starting out with a 
blank canvas and want to try some interesting graphic shapes and colour 
combinations for a logo or custom Web button.  

Whatever your creative goals, all of the functions described in this chapter 
can be applied to photographic images or images opened from a file as well 
as to new work! 

Choosing Colours 
At any given time, PhotoPlus allows you to work with any two colours—
called the foreground colour and the background colour. These are always 
visible as two swatches on the Colour tab. In this example, the foreground 
colour is set to RGB 102:102:102 and the background colour to white. 
(Don’t confuse the “background colour” with the “Background layer”—
there’s absolutely no connection!). 

 
 

Here are some things to remember about how these colours are used: 

♦ Cutting, deleting, or erasing an area on the Background layer exposes 
the background colour. On other layers, removing an area exposes 
transparency. 

♦ To swap foreground and background colours, click the 
double arrow to the top right of the Colour tab swatches. 
To reset the colours to black and white, click the black 
and white mini-swatch just to the bottom left. 
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There are a several simple ways to set the foreground or background colour.  

 One is to use the Colour Pickup tool on the Tools toolbar. Left-click 
with the tool anywhere on an image to “pick up” the colour at that point as 
the new foreground colour, and right-click to define a new background 
colour. As a shortcut if you’re working with one of the drawing tools 
(paintbrush, line, etc.), you can press the Alt key to switch temporarily to the 
Colour Pickup tool. Release the key to switch back once you’ve left- or 
right-clicked to make a colour selection. 

Another way is to use the Colour tab. To quickly 
select foreground or background colour, move the 
mouse pointer (dropper cursor) around the tab’s 

Colour Spectrum. As you do so, a preview swatch pops up showing the 
colour at the cursor position. Left-click in the spectrum to set a new 
foreground colour, and right-click to set a new background colour. As a 
shortcut for white, drag up and off the top of the spectrum; for black, drag 
down and off. 

Yet another method is to click either the foreground or the background 
swatch, then use the sliders or enter numeric values in the boxes to define a 
specific colour. The selected swatch updates instantly. 

Double-clicking either a foreground or background colour swatch on the 
Colour tab brings up the more complex Adjust Colour dialog, which lets 
you define and store a set of custom colours interactively, using a colour 
wheel. See the “Choosing colours” topic in online help for details. 

The Colour tab also makes it possible to set the working colour mode to any 
one of the following: RGB (Red, Green, Blue); HSL (Hue, Saturation, 
Lightness); CMYK (Cyan, Magenta, Yellow, Black); or Greyscale. (For lots 
of useful terms and theory relating to colour definition and colour modes, see 
Chapter 8.) 
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HANDS ON: Free Play 
Our approach in exploring the various painting and drawing tools is going to 
be decidedly non-directive... Rather than prescribe step-by-step sequences, 
we’ll let you follow your own muse as you experiment with each tool. As 
you read through the descriptions, watch for the checkbox bullets that will 
offer suggestions. No one is expecting a masterpiece—perhaps just some 
inspired doodling! 

 To begin the session, choose New from the File menu and (on the 
Startup Wizard) click Create New Picture.  

 In the New Image dialog, set the image dimensions large enough to give 
yourself plenty of white space. 500x500 should be about right. Leave the 
resolution at 96 pixels per inch (that’s standard screen resolution). The 
background type should be set to White. 

 Click OK, and the new image window opens. The image initially has a 
single Background layer. 

 Choose New Layer... from the Layers menu, then click OK in the 
dialog. 

You’ve just created a new standard (transparent) layer named Layer 1. You’ll 
see its name on the Layers tab, above the Background layer. As we move 
through the tools, you should try them out on both the Background layer or 
the standard layer, to see the difference.  

 To begin with, click “Background” on the Layers tab, so it becomes the 
active layer for painting on. 
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Painting and Drawing 
PhotoPlus’s basic tools for painting and drawing are located, like the 
selection tools, on the Tools toolbar (initially at the left of the main window).  

 If you wish to display the related online help topic, choose the Context 
Help button and then click the Tools toolbar. (The same goes for any tab or 
toolbar.) 

Using the basic Paintbrush tool 

 The Paintbrush tool is used for freehand drawing. Successful freehand 
drawing requires practice and a steady hand! You might find it easier if you 
use a graphics tablet, rather than a mouse. 

To paint a line using the Paintbrush tool, select it from the Tools toolbar. 
When you move the Paintbrush tool over the image the cursor will change 
into a paintbrush. 

 Select the Paintbrush tool. Left-click and drag to draw a freehand line. 
Release the mouse button, then repeat to draw more lines.  

 If you don’t like what you drew, press Ctrl+Z to undo (but remember, 
this is all experimental—the more paint you get on the screen, the 
better!).  

 Your lines appear in the currently selected foreground colour. To paint 
with the background colour, click the arrow on the Colour tab to switch 
the two colours. Now might be a good time to try various techniques for 
selecting different foreground and background colours, as described 
earlier in the chapter. 

 You might also try customizing the brush cursor, which ordinarily 
resembles the tool you’ve selected (in this case a paintbrush). Choose 
Preferences... from the File menu. On the General tab, switch to the 
Brush Size cursor and click OK. Now, the cursor is a small circle that 
graphically indicates the diameter of the current brush. Depending on the 
task at hand, you may find it more convenient to switch to this cursor—
or perhaps the Precise cursor, a crosshair that leaves no doubt where the 
tool’s “hotspot” is located. Pick any of the three, and let’s continue. 
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Note that if there is currently a selection, the paint tool will only work inside 
the selected region. If you try to paint over the edge of a selection, the cursor 
will continue moving but the line will come to an abrupt halt at the edge of 
the selection. Or if you’ve forgotten that there’s a selection (perhaps you hid 
the marquee) and the brush doesn’t seem to work—you’re probably just 
painting outside a selected region. 

Choosing and customizing brush tips 
All of the paint tools work in conjunction with the Brush Tip and/or Context 
Bar, so let’s see how they work with the basic Paintbrush tool. 

Brush tips determine the basic size and shape of the mark the brush tools 
make on-screen. The lines you’ve drawn so far with the Paintbrush tool may 
be thick or thin, depending which brush is currently selected. 

 Display the Brush Tip tab. 

  
The tab displays a bevy of brush presets grouped into various categories, 
switchable via the drop-down list. Let’s stick with the “Basic” gallery for 
now. Note that each sample clearly shows the brush tip and stroke; the 
number indicates the brush diameter. Other brush attributes aren’t quite as 
obvious, as we’ll see in a moment.  

 Click the topmost sample for a single-pixel brush, and use it to draw a 
squiggly “pencil” line. (For straight lines, you can use a guide or the 
Straight Outline tool, as described below.) 

If you scroll down the gallery, you’ll note that some brushes have hard 
edges, while others appear fuzzy, with soft edges. The hardness of a brush is 
expressed as a percentage of its full diameter. If less than 100%, the brush 
has a soft edge region within which the opacity of applied colour falls off 
gradually. 
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 To see what this means, try drawing a line with a medium-sized, hard-
edge brush, and then switch to a soft-edge brush. You’ll note the 
difference immediately.  

To customize a brush tip’s attributes, right-click its sample and use the popup 
menu to open the Brush Options dialog. Attributes are grouped into seven 
categories: Size, Spacing, Shape, Opacity, Misc, Colour, and Texture. As 
you vary the settings, you can see the effect of each change in the preview 
window.  

 
Each time you move the brush by a tiny interval, you’re laying down one 
“dab” of paint. A line consists of multiple dabs joined together, and the 
Spacing settings let you spread these out to create dotted lines, with greater 
or lesser density depending on the “Dab Count” settings, and a “Scatter” 
option that distributes the dabs left and right of the path you’re drawing. 
With these and several other tip attributes, the “Controller”  setting lets you 
vary the results according to the Direction of your stroke, the Pressure you 
apply with a stylus  input device, or at Random. The Opacity attribute adds a 
Fade controller option so your brush opacity falls off along the stroke in a 
specified number of steps. Use the Misc options Airbrush and Wet Edges for 
spray and wet edge effects. The Colour option sets the way PhotoPlus 
randomly recolours brush applications. The Texture attribute allows you to 
choose a pattern with which to modulate the painted strokes—for example, to 
simulate a textured surface like paper or canvas. See the Brush Tip tab’s 
Visual Reference entry in online help for details on these and other available 
settings. 
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Right-clicking a sample on the Brush Tip tab provides several other choices, 
including deleting a brush tip, creating a new one, or (when using the Picture 
Brush tool) importing a Paint Shop Pro picture tube. To define a custom 
brush tip—for example using a special shape or extending a textured 
region—first select part of the image to be used as a custom brush (for best 
results, use a solid white background), then right-click on the tab and choose 
Define Brush.... 

Setting tool properties 
The Context Bar, an extension of each tool’s functionality, makes the 
property settings of the currently selected tool easily available to the user. As 
its name suggests, the tool properties shown will be specific to the current 
tool. For the Paintbrush tool, the properties for blend mode, opacity, brush 
characteristics, flow and airbrush are available, i.e. 
 

 
The properties can be altered directly on the Context Bar apart from the 
Brush property which displays the brush characteristics set from the Brush 
tip tab. However, it can be double-clicked to reveal the Brush Options dialog. 

Let’s look at each option in turn... 

♦ Blend Mode determines how the pixels the tool lays down interact with 
pixels already on the layer. It can be a bit complicated, with each mode 
comparing “old” and “new” pixels in terms of values like hue, lightness, 
and so on—but see online help’s Effects Gallery for illustrations, and 
Chapter 8 for colour theory. 

♦ Opacity is basically the same concept as “transparency”—they’re just 
different ends of the same scale (0% opaque is 100% transparent). Thus 
a lower opacity value produces paint that’s more transparent, with less 
effect on existing pixels on the layer—more of the underlying paint 
“shows through.” A fully opaque stroke completely replaces all pixels in 
its path. 

♦ Flow controls the build up and rate of application (1% very slow rate to 
100% applied immediately) of the brush colour onto your image, up to 
the current brush opacity setting. This simulates the effect of a pressure-
sensitive pen. 

♦ Airbrush mode behaves like a spray-can. Holding the tool over one spot 
with the left mouse button held down “sprays” more paint.  
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 Take a few moments to experiment with varying the Opacity and 
Airbrush settings. With opacity, note how different settings affect the 
way the foreground colour gets painted over existing colour.  

 Click “Layer 1” in the Layers tab and try painting on the upper, 
transparent layer. Using semi-transparent brush strokes, you’ll begin to 
see how you can combine and overlap colours on different layers.  

 Try airbrushing on both the Background and the standard (transparent) 
layer while varying properties, particularly opacity. 

 If you’re feeling adventurous, try out some different blend modes—but 
those are probably best left for more advanced explorations! 

Painting with a pattern 
You may have encountered the Patterns dialog, with its selection of 
predefined tiled bitmaps, while exploring the “Texture” attribute in the Brush 
Options dialog (click on the Texture rectangle). Using this attribute, you can 
customize a brush tip by picking a pattern that lets you simulate a particular 
surface texture while painting or airbrushing a colour. But that’s just the start 
of what you can achieve with patterns in PhotoPlus! 

 The Pattern tool lets you paint a pattern directly onto your canvas. In 
effect, it “clones” any pattern bitmap you’ve selected while providing the 
flexibility to paint wherever you wish, and control opacity, blend mode, and 
so on. Like the Clone tool (discussed a few pages further on), the Pattern 
brush picks up pixels from a source—in this case, the bitmap pattern—and 
deposits them where you’re drawing.  

 Click the small down arrow next to the  Clone Tool and choose the 
Pattern tool from the flyout. Make sure (on the Brush Tip tab) you’ve 
got a fairly wide brush selected so the results will be more obvious. 

 On the Context Bar, click the Pattern sample to display the Patterns 
dialog. Right-click any of the thumbnails and note that you can select 
from various pattern categories (listed at the bottom of the popup menu). 
For now, choose Patterns-Abstract and select a pattern. 
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 Begin painting in a blank region and you’ll see the pattern develop as 
you brush. The Aligned setting in the Context Bar determines what 
happens each time you begin brushing in a new place. If checked, the 
pattern extends itself seamlessly with each new brush stroke; if 
unchecked, it begins again each time you click the mouse. (Consult 
“Using the Clone tool” for a fuller explanation of the Aligned option. 
Note that with the Pattern Brush tool, the “pickup point” is always the 
upper left pixel of the pattern bitmap.) 

The built-in selection of patterns provides a useful starting point, but you can 
also create your own patterns from any selection—or even the whole image. 
Simply define the selection (if any) and choose Create Pattern... from the 
Edit menu. Select the category where you want to store the pattern, and a 
thumbnail will be deposited there, ready to brush on (or use as a brush tip 
texture or fill) at any time. As you’ve probably noticed, right-clicking the 
thumbnails in the Patterns dialog provides commands for editing the pattern 
categories... even for adding new patterns from stored bitmap files! 

Patterns are versatile indeed... and we’ll have even more to say about them 
later in this chapter (see “Filling Regions”).  

Using the Picture Brush tool 

 The Picture Brush tool works like a custom 
brush that sprays a series of predefined images at 
regular intervals as you drag. The Brush Tip tab 
lets you select from a variety of picture brushes in 
different categories.  

 Choose the Picture Brush tool and (on the 
Brush Tip tab) pick a brush tip to try out.  

 Click in various places on your canvas. Then 
try dragging in a continuous line. 

Note that the tool can be used either to “stamp” single images at specific 
points—by clicking and releasing the mouse button each time, as in the letter 
“S” at right—or to lay out a continuous stream of pictures as you drag along 
a path. Either way, you can scale the size of the elements each brush 
produces, and control their spacing and sequencing. To do so, select and then 
right-click a brush name on the Brush Tip tab, and choose Brush Options. 
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The Spacing setting determines how closely the elements are packed 
together when you draw continuously. At the minimum setting of 1%, the 
brushed line resembles a tube of toothpaste! Higher settings increase the 
separation between each element. 

The Order setting controls how the mini-images are laid down. Select 
Sequentially to apply the original element sequence repetitively along the 
line; Randomly to mix up the order of elements; or By Direction to place 
elements according to the line’s local slope (in other words, the direction of 
your stroke determines which sequence appears). 

How does the Picture Brush work? Each Picture Brush tip has its own stored 
master image where mini-images have been arranged in rows and columns. 
The Rows and Columns settings tell the tool how to partition each tip’s 
master image—so you should leave these values intact.  

By the way, note that if you right-click on any gallery sample, you can edit 
categories, access brush options, and import Paint Shop Pro picture tubes. 
With a bit of forethought, it’s not difficult to lay out your own master images 
and from them create custom Picture Brush tips. (For details, see online 
help.) 

Using the Eraser tools 
Sometimes the rubber end of the pencil can be just as important to an artist as 
the pointed one. The three Eraser tools can replace an existing colour either 
with another colour or with degrees of transparency. This review of basic 
PhotoPlus painting and drawing techniques wouldn’t be complete without 
considering how you can use these three tools—located on the Eraser Tools 
flyout—to enhance an image. 

 The standard Eraser tool works very much like the Paintbrush, with the 
same range of Brush Tip and tool properties options. But instead, on the 
Background layer, erased pixels are replaced by (or mixed with) the current 
background colour. On other layers, they are “watered down” by adding 
transparency. 

 To erase, select the tool from the flyout and drag over the image area. 
Try erasing and experiment with varying the Opacity setting on the 
Context Bar. You’ll see that erasing is by no means an all-or-nothing 
proposition. Some wonderfully creative effects are possible using a 
semi-transparent eraser to reduce the contribution of existing pixels to 
the overall image. 
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 Again, switch between the Background and standard layers to compare 
the results.  

 The Background Eraser tool erases pixels that are similar to a 
sampled reference colour underlying the cursor cross-hair. Hence it’s perfect 
for painting out unwanted background colours. For example, you can use it 
to isolate objects or people photographed against a studio backdrop. You can 
select either “Continual” sampling, which updates the reference colour as 
you drag, or “Once,” which retains the colour sampled at the first click point. 
The “Edge Detected” setting helps to prevent erasure of similar pixels on the 
other side of the edge you’re tracing. “Background Swatch” detects and 
erases the current background colour. 

 The Flood Eraser tool fills a region with transparency, erasing pixels 
similar to the colour under the cursor when you first click. With both the 
Flood and Eraser tools, you can select a “Contiguous” effect to erase only 
pixels in the region around the initial sample point, or switch to a 
discontiguous effect to erase similar pixels anywhere in the image.  

 Try both tools using different settings. Also, experiment with the 
Background Eraser’s “Edge Detect” setting, which improves erasure on 
one side of a contrasting edge or line. 

 By now, you may be getting inspired to create something “interesting” 
instead of just scribbling. Perhaps it’s time to get a beverage, make a few 
phone calls, and while you’re at it (if you haven’t already) save this 
masterpiece-in-progress. 

Warping, Retouching, and Cloning 
In this section we’ll look briefly at the Warp tools (Elastic, Pinch, Punch, 
Twirl, Thick/Thin, and Unwarp), the Retouch tools (Smudge, Blur, Sharpen, 
Dodge, Burn, Sponge, Scratch Remover, and Red Eye), and the Clone tool. 
These will be useful once you’ve established the basic elements of an 
image—perhaps using multiple layers—and are ready to begin removing 
defects, altering details, and improving the overall image either creatively or 
technically.  

Using the Warp tools 
The entries on the Warp Tools flyout work as a group. Most of them shift 
pixels that the brush passes over, while the last one undoes the cumulative 
effects of the others. The actual amount of pixel displacement depends on the 
direction of brush movement, the brush tip, and the Context Bar settings. 
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 The Elastic Warp tool shifts pixels in the direction of brush motion, 
hence the appearance of pulling or elasticity. 

  The Pinch and Punch tools apply, respectively, a concave or 
convex spherical distortion under the brush. To apply this effect to a 
selection or layer, use Effects/Distort>Pinch/Punch....  

  The Twirl tools produce a “spin art” effect—liquid paint on a 
surface revolving either clockwise or counterclockwise around a central 
point. As with Pinch and Punch, you can apply either effect to a selection or 
layer using the Effects/Distort>Twirl. 

 The Thick/Thin Warp tool shifts pixels 90º to the right of the brush 
direction, which has the effect of spreading or compressing edges along the 
stroke. 

Unlike the Retouch tools, the Warp tools result in little blending or blurring. 
In fact, their effect is not easy to describe. The images below are magnified 
views of the two tools in action. Using a hard brush with a diameter of 19 
pixels, we dragged straight across a grid of black, single-pixel dots—in one 
case left to right, in another right to left. 

Elastic 

L to R 

 

 

R to L   

Thick/Thin 

L to R 

 

 

R to L 

Notice the distinct trails left by the Elastic Warp brush; also note that pixels 
below the end point of its brush stroke are unaffected. The Thick/Thin Warp 
effect follows a “right hand rule”—displacing pixels to the right of the drag 
trajectory. Creatively speaking, if you drag the Thick/Thin tool clockwise, 
you’ll get a concave “pinch” effect, while counter-clockwise motion results 
in a convex “punch” effect. 

You should check out the Image Gallery’s before/after examples of these 
effects—but even better, try them for yourself, using the image we’ve 
recommended, or any picture with good detail and contrast.  
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 Open a suitable test image, such as SCORE.JPG in the Projects folder, 
and experiment with the Warp tools. 

 The Unwarp tool quite simply lives up to its name. Drag the Unwarp 
brush across a warped region to restore its unwarped state.  

Note that Unwarp only works as long as you’re still using the Warp tools. 
Once you select some other tool that’s not on the Warp Tools flyout, in effect 
your “warping session” is over. If you return to the flyout later, it’s a new 
session—Unwarp will reset itself and forget any previous warping. Similarly, 
PhotoPlus treats all your operations during one warping session as a single, 
cumulative event; using the Undo command clears the whole session. As a 
safety measure, you might occasionally switch to a non-Warp tool in the 
midst of warping, just to record your work up to that point as a separate 
event. 

On the Context Bar (when a warp tool is selected), the Opacity setting 
determines the degree of warping or unwarping that takes place. The Quality 
setting relates to how carefully each tool calculates new pixel values while 
you’re moving the brush, as opposed to using interpolation to speed things 
up. A higher Quality setting will produce better results on most systems, but 
try a lower setting if brush movement appears jerky. However powerful your 
system, it’s a good idea to click the Refine button when you’re done, to 
update the image using fully recalculated pixel values. 

Using the Retouch tools 
The Retouch Tools flyout includes an assortment of comparatively simple 
brush-based tools that are sure to come in handy at various stages of photo 
editing. Again, you’ll find before/after illustrations in the Effects Gallery in 
the online help.  

 Smudging may sound silly, but the Smudge tool can be quite useful 
for blending pixels the way an artist might hand-blend pastels. Along with 
the Clone tool (see below), it’s useful for blending together separate images 
in collage work, where seamless stitching is essential. 

To use the tool, select it from the Tools toolbar and drag to pick up colour 
from the initial click point and “push” it in the direction of the brush stroke. 
Short back-and-forth strokes work well to blend edges. 
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Smudge tool properties are the same as for the Paintbrush and Airbrush, 
except that there’s no Fade setting.  

 Using an image with multiple lines or sharp edges, try using the tool to 
smear a line or edge outward, or create a mix of two colours (using a 
semi-transparent setting). Experiment with the effects of both a hard-
edge and a soft-edge brush tip. 

 For best results when using extended strokes, set the brush tip’s Spacing 
property to 1. 

 The Blur tool reduces contrast under the brush, softening edges without 
smearing colours the way the Smudge tool would. To apply the same effect 
to a selected region or the active layer, use the Effects/Blur>Blur... 
command. 

 The Sharpen tool has the opposite effect, increasing contrast under the 
brush to accentuate the appearance of sharpness. Use options in 
Effects>Sharpen... to sharpen an entire selection or layer. 

  The Dodge and Burn tools complement one another. In the 
darkroom, while exposing a print from a projected negative, photographers 
have typically used their hands (or specially shaped tools) as needed to vary 
the amount of light reaching specific parts of the print. Dodging means 
reducing the exposure, while burning-in means increasing it. The PhotoPlus 
tools work the same way: brushing with the Dodge tool lightens pixels, while 
the Burn tool darkens the area under the brush.  

 The Sponge tool changes the colour saturation of an area, either 
increasing or decreasing it depending on the Context Bar setting. Lowering 
the Flow value produces a more subtle effect. 

 The Scratch Remover tool, as its name implies, is effective at filling in 
small gaps or dropouts in an image. Like the Clone tool (see below) it “picks 
up” values from one place and puts them down in another. You Shift-click to 
define a pickup point, then brush elsewhere to lay down paint. (We suggest 
you read about—and try—the Clone tool first if this concept is new to you.) 
Unlike the Clone tool, the Scratch Remover attempts to maintain colour 
values in the region under repair. As soon as you stop brushing, you’ll see 
the surrounding colour magically flow into the repaired region! 
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 The Red Eye tool is specifically designed to correct the “red eye” 
phenomenon common in colour snapshots. Simply zoom in on the subject’s 
pupil, select a suitably sized brush, and click to remove the unwanted tint. 
The Tolerance slider adjusts the tool for less or more correction. For 
additional control (if needed) over the results, try Effects/Other>Fix Red 
Eye.... 

Using the Clone tool 

 The Clone tool is one of the most powerful weapons in the electronic 
artist’s arsenal. Like all the preceding tools, it 
uses a brush, but it’s really like two magic 
brushes locked together. While you trace or “pick 
up” an original drawing with one brush, the other 
draws (“puts down”) an exact duplicate 
somewhere else. When retouching, for example, you can use the Clone tool 
to brush away skin blemishes by cloning some “good skin” over them, or 
remove an unwanted object from an image by extending some foliage to 
cover it. Or you can easily clone a sheep... 

           
To clone a region, select the tool from the Tools toolbar and set its properties 
in the Context Bar. Then Shift-click where you want to begin copying; we’ll 
call this the “pickup point.” Click and begin dragging somewhere else—even 
in another image window—where you want to begin placing the copied 
pixels; let’s term this the “putdown point.” You’ll see a crosshair cursor 
appear back at the pickup point. As you drag, pixels from the pickup region 
are cloned in the putdown region by the tool’s brush tip. The crosshair and 
brush tip cursors move in sync. The result? A perfect copy. 

 You really should try this firsthand. Choose the Clone tool and (working 
on either layer), follow the procedures just described. You’ll see the best 
results if you clone a region that’s well painted over, rather than just a 
thin line. Remember: Shift-click to pick up, click and drag to put down. 
Watch the cursors and what’s happening will be evident. 
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In addition to the usual settings, the Clone tool has an Aligned option on the 
Context Bar. This affects what happens if you use more than one brush 
stroke. There are two possibilities when you click to begin another stroke, as 
seen in this example. 

Aligned: The pickup point changes, staying
 a fixed distance from the brush tip

 on each subsequent stroke.  
Non-aligned: The pickup point stays in the 

same place on each subsequent stroke. 

 
In the first case (called “aligned” because the two cursors remain in 
alignment), subsequent brush strokes extend the cloned region rather than 
producing multiple copies. In the second you begin cloning the same pixels 
all over again from the original pickup point. 

 Again, experience is the best teacher. Repeat the cloning procedures you 
tried a moment ago—but this time reverse the Aligned setting. You’ll 
see the difference. 

You may recall from previous coverage of the Pattern and Scratch Remover 
tools that they also feature an Aligned option. Once you’ve gotten 
accustomed to painting with the Clone tool, those more specialized tools will 
seem much more intuitive. 

Creating and Editing Lines and Shapes 
The tools we’ve described so far in this chapter have been for “pixel 
pushing”—manipulating the colour and/or transparency of the image content 
on the Background and standard layers. You may recall (from Chapter 2’s 
Key Concepts) that PhotoPlus stores shapes separately, on special layers. It’s 
a key distinction: lines and shapes in PhotoPlus are vector objects, as 
opposed to the raster or bitmap content that’s stored on the regular pixel-
based layers. So now we’ll switch from covering the various painting tools 
to a different set of tools, used for drawing shapes.  

 The QuickShape Tools flyout features an assortment of tools for 
creating rectangles, ellipses, polygons, and other shapes.  

 The tools on the Outline Tools flyout let you draw outline shapes: 
skinny ones that serve as straight lines, plus outlines for variety.  
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Each of the drawing tools has its own creation and editing rules. Before we 
get to the differences, let’s cover some things that all shape objects have in 
common. First of all, both QuickShapes and outline shapes occupy special 
shape layers, marked with an  symbol on the Layers tab. Each shape layer 
includes a path thumbnail representing the shape(s) on that layer. (We’ll 
cover paths in more detail later; every shape has one.). The path thumbnail 
must be selected to allow the path to be edited with the Shape Edit or Node 
Edit tool. 

 
Path thumbnail selected                 Path thumbnail deselected 

Assuming you’re working on a non-shape layer when you create a shape, the 
new shape appears on a new shape layer. But what about the next shape you 
create? Shape layers can store more than one shape, and it’s up to you where 
the next one will go.  

This decision is made easy by use of the Context Bar when the Outline or 
Quickshape tool is selected. The bar displays a series of combination 
buttons which determine the layer on which the shape will be placed and the 
relationship the new shape will have on any existing shapes on the same 
layer. Only one combination button can be active at any one time so it’s 
important to ensure the correct button is active. 

 New – adds the shape to a new shape layer. 

 Add – adds the shape to the currently selected layer. 

 Subtract – removes the overlap region when a new shape is drawn over 
existing shapes on the currently selected layer. 

 Intersect – includes the intersection area only when a new shape is 
added onto existing selected shapes on the currently selected layer. 

 Exclude - excludes the intersection area when a new shape is added 
onto existing selected shapes on the currently selected layer.  
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Did you notice the other icons on the Context Bar? These icons let you 
choose whether your line or shape is added to a layer, created as a path or is 
created as a filled bitmap, i.e. 

 Shape Layers - we use this to add a shape to a shape layers or create a 
new shape layer. 

 Paths - add your shape or line as a path. See later in this section for 
more information on paths. 

 Fill Bitmaps – creates a filled bitmap of the shape. 

You can alter a shape layer’s transparency using the Layers tab, or apply 
effects like bevel or drop shadow by choosing Effects… from the Layers 
menu. Painting tools and adjustment filters don’t work on shape layers; 
you’ll first need to convert the layer to a bitmap layer first (right-click the 
layer name and choose Rasterize). 

To align shapes on different layers with each other, first link the layers 
by clicking their Link Layer buttons. Then choose Align Linked from 
the Layers menu. You can choose to align tops and bottoms, and so 

on. 

QuickShapes 
QuickShapes in PhotoPlus are pre-designed, filled contours that work just 
like the Adjustable Selection tools—you can instantly add rectangles, 
ellipses, polygons, and other shapes to your page, then adjust and vary them 
using control handles—for innumerable possibilities! 

 

 

The QuickShape Tools flyout contains a wide variety 
of commonly used shapes, including boxes, ovals, 
arrows, polygons, and stars. Each shape has its own 
built-in “intelligent” properties, which you can use to 
customize the basic shape. 

As you draw a QuickShape, it displays as an outline; 
hold down the Ctrl key while drawing to constrain the aspect ratio. Once 
drawn, the shape takes a Solid fill using the foreground colour (see the next 
section). If you now switch to the Node Edit tool, you can adjust the shape. 
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The number of handles varies according to the shape; for example, the 
rectangle has just one control, the polygon has two, and the star has four. To 
adjust a QuickShape, simply drag one of its handles (the tool changes to a 
“+” when it is above a handle). 

 
 You’ll have fun with these! Try building up a pile of shapes, each using 

a different colour with partial transparency so you can see through to the 
shapes below. Or just play around with QuickShape handles to create 
zany designs or meaningful symbols. Often, forms like these can 
communicate quite a lot in a small space—think about the possibilities 
for Web buttons or icons. 

Outline shapes 
Earlier we noted that shape layers include a path thumbnail. The “path” is the 
outline around a shape, and although technically, QuickShapes have paths, 
too—the three Outline tools are genuine DIY (draw-it-yourself) path-
drawing tools. 

 As we mentioned earlier, a straight line in PhotoPlus is just a very thin 
shape. To draw one, select the Straight Outline tool from the Outline Tools 
flyout and drag the tool on the image. 

 
Hold down the Shift key while dragging to constrain the line to 15º angles. 

The Context Bar provides the familiar Blend Mode and Opacity settings for 
the Line tool. You can also set the Weight (thickness) of the drawn line, 
which is always anti-aliased. Anti-aliasing produces smooth edges by fixing 
“jaggies”—making the selection’s edge pixels semi-transparent, as shown in 
the before/after illustration at right. 

  Go ahead and experiment a bit with the Line tool—trying various 
weights.  
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 The Freehand Outline tool, as its name implies, lets you draw a 
squiggly line (or a connected series, starting each segment from another’s 
end point), then attach it back to itself to create a closed shape. Simply click 
and drag! The Smoothness setting on the Context Bar evens out ragged 
contours automatically—useful if your hand shakes.  

 

 The Curved Outline tool can produce complex combination curves 
and shapes in a highly controlled way. After choosing the tool, click and hold 
down the mouse button. An additional pair of handles appear, defining a pair 
of red attractor nodes that orbit the original click point as you continue to 
drag the mouse. What these nodes do is define the curvature of the line 
segment you’re about to draw. The distance between attractors determines 
the depth of the resulting curved line. 

Release the mouse button, then click again where you want the first curved 
segment to end. To extend an existing path, repeat the process for each new 
end point. As with the Freehand Outline tool, you can connect the curved 
outline back to its starting point. And you can switch between the two tools 
to construct a complex outline in a series of segments.  

 
On a shape layer, PhotoPlus needs to treat each path as a closed shape, so if it 
will automatically add a straight “closing segment” (as in the middle 
illustration above) even if you haven’t joined the two end points. You can 
either leave the shape that way, or continue to draw segments until you 
yourself have officially closed it.  
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Editing shapes 

 The Edit Tools flyout includes two tools custom-made for editing 
QuickShapes and outline shapes. To edit either kind, first activate its layer 
and make sure the layer’s path thumbnail is selected.  

 You can use the Move tool to reposition the shapes on a layer as a 
group, but the Shape Edit tool does much more. In fact, it applies the move, 
resize, scale, skew, and rotation functions of the Deform tool to individual 
shapes on a shape layer. While the Shape Edit tool is active, you can also use 
the combination buttons on the Context Bar (see above) to reset how a 
selected shape (other than the first one you created on the layer) interacts 
with other shapes. 

 
A B C 

The illustration above shows a cool feature of QuickShapes: you can deform 
one with the Shape Edit tool (in B, changing A’s wave into a “road”) 
and it will still remain adjustable with the Node Edit tool! If you look 

closely at C, you’ll note we’ve added an extra bend to the “road” after the 
deformation!  

Besides being useful with QuickShapes, the Node Edit tool really comes into 
its own with outline shapes. What is an outline, anyway? It’s a collection of 
line segments and nodes (points where the line segments meet). There are 
three different node types (see Chapter 4’s discussion of comparable Mesh 
Warping), and the node type determines the slope and curvature of adjoining 
segments.  

With the Node Edit tool, you can click and drag directly on a line segment, 
drag one or more individual nodes, or alter the node handles to reshape the 
outline. To add a new node, double-click on a line segment. To straighten a 
line, delete a node or change it from one type to another, use the set of 
buttons on the Context Bar.  
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 Try reshaping, distorting, and rotating all kinds of shapes using the Edit 
tools. Lots of possibilities arise using shapes with the two fill tools as 
described next. Hint: Because it’s easy to create multiple shapes with 
subtly different proportions, QuickShapes lend themselves to animation, 
too. (Chapter 6 has a Hands-on example.) 

Filling Regions 
Filling regions or layers is an alternative to brushing on colours or patterns. 
Making a skillful selection prior to applying a fill, and setting appropriate 
options, can spell the difference between a humdrum effect and a spectacular 
one... so it’s definitely worthwhile getting to know the wide variety of fill 
types available in PhotoPlus. 

The Fill Tools flyout on the Tools toolbar includes two tools: Flood Fill and 
Gradient Fill. In addition, you can use the Edit/Fill... command to apply 
either a Colour or Pattern fill. As with the paint tools, if there is a selection, 
fill operations only affect pixels within the selected region. If you’re 
operating on a shape or text layer (see the previous and next sections), a 
single fill affects the interior of the object(s) on the layer.  

Flood and pattern fills 

 The Flood Fill tool replaces an existing colour region with the foreground 
colour. The tool works only on standard layers, not with shape or text layers. 
Select the tool from the flyout, and set tolerance and layer fill options. Then 
just click with the tool where you want to start the flood! How large a region is 
“flooded” with the fill colour depends on the difference between the colour of 
the pixel you initially click and the colour of surrounding pixels. 

You can use the Context Bar to set a tolerance value—how much of a colour 
difference the tool looks for. With a low tolerance setting, the tool gives up 
easily and only fills pixels very close in colour to the one you click (a setting 
of 0 would fill only pixels of the same colour; 255 would fill all pixels). As 
the tolerance increases, so does the tool’s effect on pixels further in colour 
from the original pixel, so a larger region is flooded. 

Check Contiguous to affect only pixels connected to the clicked pixel; 
uncheck to affect in-range pixels throughout the region. 

If you wish to fill with a pattern—select Pattern rather than Foreground in 
the Fill drop-down box, click the adjacent Pattern box, and select a pattern 
from the Patterns dialog. 
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The Edit/Fill... command lets you flood-fill a region on a standard layer 
using any colour, not just the foreground colour. On the other hand, it’s 
strictly a solid colour flood without the subtleties of the tool properties noted 
above. Simply choose the command to display the Fill dialog.  

 
For a flood fill, set the Type to “Colour,” and specify the blend mode and 
opacity of the fill. If you check Preserve Transparency, transparent areas 
will resist the flood colour; otherwise, everything in the selection or layer 
will be equally washed with the fill.  

The other Type option in the Fill dialog is “Pattern.” The blend options are 
the same, but in this mode instead of choosing a colour you can fill a region 
with any pattern stored in the Patterns dialog—including both the built-in 
bitmaps and any custom patterns you’ve created. (See “Painting with a 
pattern” earlier in this chapter.) Click the pattern sample in the Fill dialog to 
bring up the gallery of pattern thumbnails, then right-click any thumbnail to 
choose a category. 

Experiment with using different selection methods (as covered in the 
previous chapter) in conjunction with colour and pattern fills, to get a feel for 
how partial selections—for example, using feathering or Paint to Select 
mode—can vary the fill effect. 

Gradient fills 
Whereas solid fills use a single colour, all gradient fills in PhotoPlus utilize 
at least two “key” colours, with a spread of hues in between each key colour, 
creating a “spectrum” effect. You can fine-tune the actual spread of colour 
between pairs of key colours. Likewise, a gradient fill in PhotoPlus can have 
either solid transparency—one level of opacity, like 50% or 100%, across its 
entire range—or variable transparency, with at least two “key” opacity levels 
and a spread of values in between. (Remember that opacity is simply an 
inverse way of expressing transparency.) 
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 The Gradient Fill tool lets you apply both colour and/or transparency 
fills directly to a layer. Five types of fill (Solid, Linear, Radial, Conical, 
and Square)  are available. Technically, a Solid fill is different (it uses just 
one colour)—but in practice you can also achieve a unicolour effect using a 
gradient fill. 

             
Solid   Linear        Radial      Conical      Square            

Applying a gradient fill on any kind of layer entails selecting one of the fill 
types, editing the fill colours and/or transparency, then applying the fill. 
However, gradient fills behave differently depending on the kind of layer 
you’re working on. 

On standard and Background layers, the tool creates a “spectrum” effect, 
filling the active layer or selection with colours spreading between the 
current foreground and background colours. The fill is applied rather like a 
coat of spray paint over existing pixels on the layer; colour values in the fill 
gradient interact with the existing pixels to produce new values. In other 
words, once you’ve applied the fill, you can’t go back and edit it (except by 
undoing it and trying again). Transparency works in a comparable way, 
affecting how much the paint you apply is “thinned.” At full opacity, the fill 
completely obscures pixels underneath. 

Because text and shapes are vector objects in PhotoPlus, the Gradient Fill 
tool is even more powerful on these layers—the fill’s colour and 
transparency properties remain editable. Note that the Gradient Fill tool 
doubles on these layers as a solid fill tool; the Flood Fill tool doesn’t work 
with text or shapes.  

When first drawn, a shape takes a Solid fill using the foreground colour. To 
edit the colour or switch to a different fill type, either double-click the layer 
name or choose the Gradient Fill tool and use the Context Bar. Either option 
lets you choose a fill type, and/or click the colour (or gradient) sample to edit 
the fill. Gradient fills incorporate both colour and transparency, and a single 
fill applies to all the shapes on a particular layer. So if you want to draw a red 
box and a yellow box, for example, you’ll need two shape layers. 
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Once you’ve defined the fill, click with the tool where you want to start the 
fill and drag to the point where you want it to end. On shape and text layers, 
the fill path (the line in the illustration above) remains visible even after 
you’ve applied the fill, and you can adjust the fill’s placement after the fact 
by dragging the fill path’s end nodes with the Gradient Fill tool. 

Editing a gradient fill 
As mentioned above, to define a fill before you apply it, or to change it after 
the fact on a shape or text layer, you simply click the gradient sample in the 
Context Bar. The PhotoPlus Gradient dialog appears whenever you’re 
editing a gradient fill, and lets you adjust the fill’s colour and/or transparency 
spreads. Its central feature is a sample window with a spectrum showing both 
colour and transparency. Let’s use the gradient shown here as an example: 

 
The little house-shaped pointers above and below the spectrum are the key to 
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making changes in the dialog. Each pointer marks a stop where a spread of 
either opacity or colour begins and ends. To vary the colour gradient, you’ll 
use the lower pointers, which show key colours. To vary the transparency 
gradient, you’ll work with the upper set of pointers, which use greyscale 
values to represent key opacity levels (white = 100% opaque). In the 
example shown, the gradient has three colour spreads, and one opacity 
spread (actually uniform opacity, with 80% at each end). As you can see, the 
position of the pointers corresponds to transition points in each gradient. 

Whether you’re adjusting the fill’s colour or its 
opacity properties, the same basic steps are 
involved. To make life very simple, you can 
begin by selecting a preset fill from the gallery. 
Right-click the gallery to select a different 
category, or add/delete your own fills or 
categories. A series of gradient categories are also 
available to choose from (in this case Candy). 

For more complex banding in a gradient, add one or more stops to define 
new key values and spreads. Click at the position where you want to place 
the new stop—either just above the spectrum to add a transparency stop or 
just below it for to add a colour stop. A new pointer appears, using an 
intermediate value. (The tip of a selected pointer is black; unselected pointers 
have grey tips.) 

To change a key colour, select its stop and click the Colour box (or just 
double-click the pointer) to display the Adjust Colour dialog, then select the 
new colour. To change a key opacity value, select the stop and type a 
percentage into the Opacity box. To adjust the length of a spread, move an 
intermediate stop by dragging its pointer to a new position along the 
spectrum. You can also select the pointer, then type a number into the 
Location box. To delete a stop you’ve added, click to select its pointer and 
click the appropriate Delete button (or press the Delete key).  

The diamond-shaped markers that appear between stops let you adjust the 
spread of values between the two stops. Initially, values are graduated evenly 
from one stop to the next. To change the value distribution between adjacent 
stops, simply drag the intermediate marker. Adjust the Smoothness slider 
for more even transitions between bands in a multicolour fill. Finally, click 
OK to accept changes. 
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Let’s try a mini-project simulating a sphere, using a radial fill inside a circle. 
First make sure you have some white space (about a square inch should do it) 
available on the Background layer. Perhaps its time to erase a section, or 
enlarge the canvas area. 

 Choose the Ellipse selection tool and Ctrl-drag over the white region to 
create a circular selection about an inch in diameter. 

 Choose the Gradient Fill tool from the flyout, then select Radial as the 
Fill Type on the Context Bar. 

 Click inside the selection, near but not at the top left edge, drag 
diagonally down and to the right across the opposite edge. When you 
release the mouse button, the selected region takes the fill.  

 
Our “sphere” may not have quite the convincing depth of a 3D model—but it 
shows how gradient fills can interact with special selection shapes to create 
unusual effects. Choose the gradient paths carefully so that high and low 
values fall at specific points inside the selection. 

Working with Paths 
Paths are basically outlines. As such, every filled shape you draw (see the 
preceding sections) has a path—namely the outline that defines it. We noted 
that each shape layer has its own path thumbnail next to the layer name, 
representing the shape(s) that reside on that layer. But PhotoPlus also lets 
you work with independent paths: outlines that don’t reside on any 
particular layer, but which are created separately and can be applied in 
various ways to any layer. That’s what we’ll introduce in this section. 

What are paths good for? Consider the precision and editability of vector-
based drawing and apply it to the concept of a selection. Now think of all the 
ways that selections can be used (and reused). In PhotoPlus, selections and 
paths are interchangeable. And there’s more... as you’ll see.  

The Paths tab provides a special window for working with independent 
paths.  
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Each path consists of a path channel, depicted with its own name, and a 
path outline on that channel. First you create the channel, then you create 
the outline—either by drawing it from scratch or basing it on the current 
selection. In the illustration, you can see two path channels and one path 
outline (shown in Path 2’s thumbnail). Once you’ve got a path outline, you 
can reshape it with the same Edit tools you’d use for shapes, and convert it to 
a selection. You can even stroke a path—that is, trace it onto a bitmap layer 
using the current brush. Paths are saved along with the image whenever you 
use the .SPP format. 

To create an empty path channel, display the Paths tab and click the 
New Path button. In the dialog, provide a name for the path, then click OK. 

To create a path outline, select the Paths icon in the Context Bar, then 
draw a path outline using the QuickShape and/or Outline tools. (See 
“Creating and editing shapes.”) Note how a new path either appears in 

the Paths tab, or an existing path is altered—this depends on the combination 
button settings (also on the Context Bar). Alternatively, you can create a path 
from the current selection simply by clicking the Selection to Path button on 
the Paths tab. This method creates a new path channel automatically and lets 
you choose a Smoothness setting to even out jagged selections, if you wish. 
Either way, you’ll end up with an unfilled shape on the path channel. To 
duplicate, delete, or rename a path channel, right-click it and choose from the 
menu. (You can also double-click a path channel to rename it.) 

To edit a path outline, you use the same Node Edit and Shape Edit tools 
described earlier for shape-editing. With them you can move, resize, reshape, 
rotate, and skew the path. Since the same tools are used for both independent 
paths and outline shapes, you’ll need to tell PhotoPlus when to switch out of 
path-editing mode. To exit path-editing mode, deselect the current path on 
the Paths tab by clicking in the blank space below the path names.  
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When deselected, the current path’s thumbnail loses its border, and you’ll no 
longer see the path outlines onscreen. Now you can use the editing tools on a 
shape layer. To re-enter path-editing mode, click a path’s thumbnail again. 

 To create a selection from a path, use the Layers tab to select the target 
Background or standard layer, and on the Paths tab, select the path from 
which you want to create the selection. Click the Path to Selection button. A 
dialog appears with various options for the new selection: feathering, anti-
aliasing, and combination. (Refer to Chapter 3’s section on “Making 
Selections” for details.) Click OK and the selection marquee appears on the 
target layer. 

 Stroking a path is a convenient way of creating painted lines or 
unfilled shapes without having to draw them directly. First select the target 
layer and source path. Choose a brush tool (such as the Paintbrush or Picture 
Brush) and set Colour, Brush Tip, and Tool Properties options. Make sure 
the path is positioned where you want it, then click the Stroke Path button 
on the Paths tab.  

 
Before (path)                       After (bitmap) 

 The Fill Path option lets you fill any created path with the current 
foreground colour. That’s it! 

Click here 
to deselect
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Working with Text 
Use the Text Tools flyout on the Tools toolbar to select from two text 
tools—one for entering solid, colourful text on a new layer, and the other for 
creating a selection in the shape of text with which to manipulate content on 
an existing layer.  

 To create new solid text, choose the standard Text tool from the flyout. Click 
with the tool where you want to insert text (it can be moved later). The Add 
Text window opens. 

  
Type your text and use the formatting options at the top of the dialog. 
Formatting is applied to all the text in the window, so you don’t need to 
select the text first. To apply semi-transparent edges to the characters, check 
the Anti-Alias box. (Anti-aliasing is generally recommended with text sizes 
14pt or larger.) 

To set text colour, click the Adjust Colour button and use the dialog. You 
won’t see the effect of the new colour until you close the Add Text window. 
(For details on using the Adjust Colour dialog, see the “Choosing colours” 
topic in online help.) 

When you’re done, click OK. The text appears on a new transparent layer in 
the image. You can now use the Move tool or other tools and commands to 
manipulate it, just like the contents of any layer. 

The Layers tab designates text layers with a  symbol. Like shapes (as 
discussed earlier), solid text in PhotoPlus is editable: as long as it remains on 
a separate text layer, you can retype it or change its properties at any time. To 
edit existing text, either double-click the text layer’s name on the Layers tab, 
or select the layer and—using the standard Text tool—move the cursor over 
the text until it changes to an I-beam, then click on the text. The Add Text 
window appears, with the text ready for editing.  

In order to keep text editable, only one block of text can occupy a text layer, 
so various functions—such as paint tools, adjustment filters, or the Paste 
Into Layer command—are disabled on text layers. To convert any text layer 
to a standard layer, right-click on the layer name and choose Rasterize  from 
the menu. 
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Text selections work like standard or adjustable selections, except that (you 
guessed it) they’re shaped like text! This opens up a number of creative 
possibilities, such as using the text selections to “pick up” patterns or filling 
the region with unusual fills. 

 To create a text selection, choose the Text Selection tool from the Text 
Tools flyout and click in the image to display the Add Text window. Type 
your text and apply formatting just as when creating solid text. Click OK 
when you’re done. Instead of solid text on a separate layer, you’ll see a 
selection region on the active layer. Now you can cut, copy, move, modify, 
and apply various effects to it, just as with the other types of selection. (Note 
that text selections, unlike solid text, cannot be edited with the Add Text 
window.) 

HANDS ON: Creating Filled Text 
This sequence shows you how to create some text and fill it with a pattern. 
One image will serve as a fill for the text created in another.  

 Open WATER.JPG (our fill image) in the PhotoPlus PROJECTS folder. 

Next, create a new empty image to use for the text.  

 Choose New from the File menu to open the New Picture dialog. Make 
the size 500×100, with a transparent background. 

 Now choose the Text Selection tool and click it in the new image 
window to open the Add Text window. Select Cairo SF and 72 points 
from the formatting options. 

 Type the word “water” in the box and click OK to drop the text on the 
blank image. Use the Move tool to reposition the selection if necessary. 

 
 Now, use Ctrl+Tab to go back to WATER.JPG. Select an area (larger 

than 500x100) from that image and copy the selection to the Clipboard.  

 Toggle back to the new image and paste the Clipboard contents into the 
selection by choosing Paste>Paste into Selection from the Edit menu. 
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The final stage is to give the word a drop 
shadow so that it stands out from the 
background.  

 Choose Effects>Effects... from the 
Layers menu and check Drop Shadow. 

 Use the controls to adjust the drop 
shadow’s properties, and click OK when 
you’re ready to apply the effect. 

 

HANDS ON: Raised Filled Text Effect 
This sequence will show you one way to create a text effect which looks as if 
it has been carved in a block of wood.  

 Open the file WOOD.JPG in the 
PhotoPlus PROJECTS folder. 

 Choose Duplicate... from the Image 
menu to create a working copy in a 
new window.  

We’ll carry out the following steps on the working copy, but keep the 
original file open. 

 Adjust the brightness of the image by  
choosing Adjust>Brightness/ 
Contrast from the Image menu. 
Increase the Brightness by 10 but 
leave the contrast alone. 

 Next, blur the image by choosing 
Effects>Blur>Average Blur… from 
the Effects menu and blurring by a value of 4 or so. 

These steps will have created a background for the effect. Don’t forget to 
save your work as you go along! The next step is to grab a text-based 
selection from the original file.  
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 Switch to the WOOD.JPG window. Choose the Text Selection tool and 
click on the image to open the Add Text box. Choose Basic Sans Heavy 
SF and set the size to 72. 

 Type the text “PhotoPlus” in the box (at least, that’s what we typed!) 
and click OK to place the text-shaped selection on the new layer. Use 
the Move tool to drag the layer until the selection marquee is positioned 
centrally. 

 Choose Copy, then switch to the other window and choose Paste>As 
New Layer from the Edit menu. Position the selection. 

 
At this point the colouration of the letters closely matches that of the 
background.  

 Change the upper layer’s Blend Mode from Normal to Multiply using 
the Layers tab, and the letters will be darker and more visible. 

 
 Next, give the text a raised look by choosing Effects...from the Layers 

menu (or clicking the Layer Effects button on the Layers tab). Check 
Bevel and Emboss and use the dialog to add an Inner or Outer Bevel 
effect. Adjust the settings to your liking. 

 
You can fill lettering with any bitmap from the Clipboard... the best way to 
find out how different fills and effects work is to experiment! 
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Tutorial Resources 
For more experience with the tools and techniques covered in this chapter, 
we recommend these HTML-based tutorials: 

Try this tutorial... For practice with these tools and techniques... 

Selection Tools Basic selection concepts  

Exploring Colour 
Spaces 

Colour Modes: RGB and HSL 

Brush Tips & Tricks Variable brushes using Brush Options 

Introductory Cloning Clone tool basics 

Photograph Restoration 
I 

Clone tool for stitching images back together  

Photograph Restoration 
II 

Principles of image correction using Curves setting, 
Unsharp Mask, etc. 

Text Effects Text creation plus Gradient Fill, Paintbrush, Smudge, 
Blur, Deform tools and various effects 

Framing Photographs QuickShape and Outline Shape tools plus a 3D Effect 

Neon Gel Text Layer effects and the Curves adjustment on text 

Lens Flare Changing tonal qualities with Colour Selection Tool, 
Curves adjustment, adding Lens Flare 

 



 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

5.  
 

Using Layers, 
Masks and Filters
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Layers 
If you’re accustomed to thinking of pictures as flat illustrations in books, or 
photographic prints, the concept of image layers may take some getting used 
to. In fact, layers are hardly unique to electronic images. The emulsion of 
photographic film has separate layers, each sensitive to a different colour—
and we’ve all noticed multiple-image depth effects like shop window 
reflections or mirrored interiors. There is still something magical about being 
able to build up an image in a series of planes, like sheets of electronic glass, 
each of which can vary in transparency and interact with the layers below to 
produce exciting new images and colours. 

 

Kinds of layers 
In a typical PhotoPlus image—for example, a photograph you’ve scanned in, 
a new picture file you’ve just created, or a standard bitmap file you’ve 
opened—there is one layer that behaves like a conventional “flat” image. 
This is called the Background layer, and you can think of it as having paint 
overlaid on an opaque, solid colour surface.  

You can create any number of new layers in 
your image. Each new one appears on top of 
the rest, comprising a stack of layers that you 
can view and manipulate with the Layers 
tab. We call these additional layers standard 
layers to differentiate them from the 
Background layer. Standard layers behave 
like transparent sheets through which the 
underlying layers are visible.  
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In the previous chapter, we covered shape layers and text layers, which are 
specifically designed to keep objects (either shapes or text) separate from the 
other layers so that they remain editable. Chapter 3 described adjustment 
layers, which apply filter effects to lower layers. Refer back to the earlier 
sections for coverage of these special-purpose layers—here we are concerned 
mainly with the Background and standard layers. 

A key thing to keep in mind is that pixels on the Background layer, once laid 
down, are fully opaque, while those on standard layers can vary in opacity 
(or transparency, which is really the same thing). That’s because standard 
layers have a “master” Opacity setting that you can change at any time, while 
the Background layer does not. A couple of examples will show how this 
rule is applied in PhotoPlus: 

Suppose you are creating a new picture image. The New Image dialog 
provides three choices for Background: White, Background Colour, and 
Transparent. If you pick White or Background Colour, the Layers tab shows 
a single layer named “Background.” If you pick Transparent, however, the 
single layer is named “Layer 1”—in this case, the image (typically an 
animation file) has no Background layer. 

 If you cut, delete, or move a selection on the 
Background layer, the “hole” that’s left is 
filled with the current background colour (as 
shown on the Colour tab). The same 
operations on a standard layer leave a transparent hole. 

Many standard operations, such as painting, selecting and moving, Clipboard 
actions, adjusting colours, applying effects, and so on, are possible on both 
the Background layer and standard layers.  

Other operations, such as rearranging the order of layers in the stack, setting 
up different colour interactions (blend modes) between layers, varying layer 
opacity (transparency), masking, or creating animation frames, only work 
with standard layers.  

Once an image has more than just a background layer, the layer information 
can only be preserved by saving the image in the native PhotoPlus (.SPP) 
format or the Adobe Photoshop (.PSD) format. Multiple layers are merged 
when you export an image to a standard “flat” bitmap format like .JPG or 
.BMP. In general, we recommend that you save your work-in-progress as 
.SPP files, and only export to a different file format as the final step. 

Some standard operations can be applied to all layers by using the Use All 
Layers option from the Context Bar. 
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Basic layer operations 
To select a layer, left- or right-click on its name in the Layers tab. The 
selected layer is now termed the active layer. (Note that “selecting” a layer 
doesn’t imply selecting a region of pixels—that’s a separate step, using tools 
described in Chapter 3.) 

 To create a new standard layer above the active layer, click the New 
Layer button on the Layers tab. To clone the active layer and its contents as 
a new standard layer, choose Duplicate... from the Layers menu. To 
duplicate and copy the layer to a new or currently opened image, right-
clicking on Duplicate and use the Duplicate dialog to create the layer. 
Dragging a file icon (or an active selection from any OLE server program) 
and dropping it onto the current window also creates a new layer from the 
dragged image. 

To convert the Background layer to a standard (transparent) layer, right-click 
“Background” on the Layers tab and choose Promote to Layer. The layer’s 
name changes from “Background” to “Layer <number>.” 

 Select New Layer Group to create a group in which you can store 
layers which have some relationship to each other—some layers may only be 
related to a specific photo feature such that any changes to those layers will 
be restricted to the group’s scope only. This gives greater control to enable 
changes to opacity, blend modes and hide/show layer settings for the group 
rather than individual layers. 

 Create a New Adjustment Layer to apply an image adjustment to a 
layer or group as described in the Manipulating Images section. 

 The Add Layer Mask adds a mask to the currently selected layer or 
group. See later in this section. 

 The Add Layer Depth Map creates a depth map for the selected layer 
or group. See later in this section. 

 Create a layer effect with the Add Layer Effect button. This can also be 
applied to a group. 

 To remove the active layer, click the Delete button on the Layers tab. 
(You can delete the Background layer, as long as it’s not the last layer.) 
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 To make a layer’s contents visible or invisible, click the Hide/Show 
Layer button next to its name on the Layers tab. The icon switches between 
an open and closed eye. 

Note that each layer’s entry includes a preview thumbnail, which is visible at 
all times—especially useful if you’re working with many similar layers, 
image fragments, and/or hidden layers. 

A series of lock buttons exist on the Layers tab to prevent accidental 
modification of the active layer or group.  

 Lock Pixel Opacity—locks the opacity on the layer or group. 

 Lock Pixels—locks the opacity and colour of the layer or group. 

 Lock Layer Position—locks position of all objects on the layer or 
group. 

  Lock All—All of the above. 

Manipulating layers 
Control over layers means control over a great variety of creative 
possibilities. This section will review some of the manipulations you should 
know about. 

Note that commands on the Image and Effects menus, such as colour 
adjustments and special effects, typically are applied to the current selection 
(if one exists). Otherwise they affect the active layer or group (the one 
currently selected in the Layers tab). 

Moving the contents of one or more layers 
 To move the contents of the entire active layer, make sure nothing is 

selected, then drag with the Move tool or nudge with the keyboard arrows. 
Note that layer content moved in this way outside the image window (canvas 
area) survives—you can drag it back inside the window later if desired. 
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 You can link one or more layers to the active layer so that when you 
drag with the Move tool, the contents of all linked layers move together. 
Click the Link Layer button next to the layer’s name on the Layers tab. The 
link button is always “down” (as shown) for the active layer. You can see 
which others are linked to it by checking to see which other link buttons are 
also down. Once layers are linked, they remain so regardless of which layer 
in a linked group is active. A quick way of linking layers is to Shift-click on 
a layer to link it to the currently active layer—you must have Automatically 
select layer checked on the Context Bar.   

To align linked layers with each other, select a linked layer and choose Align 
Linked from the Layers menu, then select Top, Vertical Centre, Bottom, 
Left, Horizontal Centre, or Right from the submenu. The alignment is made 
in relation to the object on the selected layer. Additionally, objects on linked 
layers can be distributed equally by their Top Edges, Left Edges, Right 
Edges or Bottom Edges, or distributed to Vertical Centre or Horizontal 
Centre. Alternatively, use the same options as icons on the Context Bar.  

To unlink a layer from the active layer, click its link button again (so it’s now 
“up,” with an open-link icon). 

It is possible to delete all linked or hidden layers in the Layers tab 
simultaneously by selected Delete>Linked Layers or Delete>Hidden 
Layers, respectively, from the Layers menu. 

Clipboard operations involving layers 
To copy (or cut) the contents of the entire active layer to the Clipboard, 
select nothing and use the standard Ctrl+C or Ctrl+X commands. Cut or 
deleted pixels are replaced (on the Background layer) with the current 
background colour, or (on standard layers) with transparency. 

You can paste the copied or cut layer into another PhotoPlus image window, 
using the Paste>As New Layer command on the Edit menu. Note that text 
layers become standard layers when pasted. 

Rearranging standard layers in the stack  
To move a standard layer up or down in the layer stack, click on the layer 
name in the Layers tab and drag up or down. A black line “drop target” 
appears between layers as you drag. Drop the layer on a target to relocate it 
in the stack. 
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Another method is to select the layer and choose Arrange from the Layers 
menu, then choose one of the following: 

• Bring to Top places the layer on the top of the stack. 
• Move Up moves the layer up one in the stack. 
• Move Down moves the layer down one in the stack. 
• Send to Bottom places the layer just above the 
Background layer (if present) in the stack. 

Merging layers 
Merging layers combines multiple layers (or groups) into one, decreasing 
the memory required to store the image. Once layers have been merged, they 
become a single layer and their previous contents are no longer separately 
editable. 

To merge the active layer with the layer below it, choose Merge Down from 
the Layers menu. To merge just the currently visible layers into a single 
layer, choose Merge Visible from the Layers menu. Choose Merge Linked 
to combine currently linked layers. 

To merge all image layers into a single layer, choose Merge All from the 
Layers menu. This is called flattening the image because the result is a “flat” 
file with just a Background layer. 

To copy the selection (or image, if there’s no selection) to the Clipboard in 
flattened form without physically merging its layers, choose Copy Merged 
from the Edit menu. 

Grouping Layers 

 For greater management and efficiency it is possible to place selected 
layers into a pre-defined group, created with the New Layer Group button 
in the Layers tab. There are many reasons why you might want to use groups 
in addition to layers. Here are a few... 

♦ To create a self-contained group of layers which are all related, e.g. all 
the Text Layers used in your photo. 

♦ To collect layers together which make up a specific photo feature. 
♦ To make a mask or blend apply to only specific layers, i.e. those that 

contained within a group. 
♦ To apply changes to a group that you would otherwise have to apply to 

each layer in turn—thus improving efficiency. 
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In reality a group is really just another layer but one which can store layers 
within itself. It’s not surprising then that a group can have its own blend 
mode, opacity and blend ranges just like a layer. A group can also be 
merged, linked and made visible/invisible—or even grouped within another 
group.  

The addition of a layer to a group is very simple. Click on the layer you want 
to add to the group and, while holding the mouse button down, drag the layer 
onto the group name. The layer will then appear indented under the group.  

 
In the above example, the highlighted “Text Additions” group contains two 
text layers called “Little House” and “copyright”.   

To remove a layer, drag the layer away from the group and drop it into an 
ungrouped area of the Layers tab.  

The Merge Layer Group option in the Layers menu can be used to merge all 
layers contained within a selected group.   

Note that you cannot move the background layer to a group. 
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Blend Modes  
You can think of blend modes as different ways of putting pixels together to 
create a resulting colour. In PhotoPlus, we’ve already encountered blend 
modes as a property of individual tools (Paintbrush, Clone, Eraser, Airbrush, 
Fill, Smudge, Shape, and Line), where the tool’s blend mode determines how 
new colour pixels look when painting on top of existing pixels. 

 As a property of individual layers, a layer’s blend mode 
determines the result of combining each pixel on that layer 
with those on layers below. (Because there are no layers 
below the Background layer, it can’t have a blend mode.) 
Note that unlike working with paint tools, changing a 
layer’s blend mode property doesn’t actually alter the 
pixels on the layer. This means you can create different 
blend mode effects after creating the image content, then 
merge layers (see the previous section) when you’ve 
achieved the result you want. 

To set a layer’s blend mode, select it on the Layers tab or 
in the Layer Properties dialog and choose from the drop-
down list as shown at right.  

To learn more about the individual blend modes, choose Effects Gallery 
from the Help menu, then select from the Gallery menu. Each mode is 
illustrated for quick comparisons, and the listing of modes is cross-
referenced to explanatory help topics (just click the green links). 

Blend Ranges 
It’s a good time to clear up the difference between Blend Modes and Blend 
Ranges. As we’ve seen, a Blend Mode can be associated with a tool or layer 
to produce different colour effects when pixels are painted on top of each 
other. Blend Ranges, a more advanced blending feature, differ in that they 
specify the range of colours on a current layer that is to be blended with the 
underlying layer—this is a simple include or exclude of tones or colours in 
the blending process. The Layer Properties dialog allows both the Blend 
Mode and Blend Ranges to be set for layers—take care when using these in 
conjunction with each other as they are a powerful combination.   
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The Blend Range can be set for Red, Green, Blue or Grey (shown) channels. 
The current layer and its underlying layer can be allocated a value from 0/0 
to 255/255 each which represents the tonal or colour value—value pairs 
(e.g., 70\70 or 255\255) are set by moving the triangular sliders to the 
required value on the range selector. In the example above, the grey tones of 
value less than 75 are not included in the blend. This means that the colour of 
the underlying layers pixels is used instead (as there is no blending taking 
place). 

For smoothing between colours 
included and excluded from the 
blend, it is possible to split the 
triangular sliders by dragging 
each half apart with the Alt-
key. This partial blending 
occurs linearly. 
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HANDS ON: Making a Montage 
Now we’ll put several layers from several files together to create one image 
(in this case an ad for a music event) using a base image, text, and 
backgrounds. We’re going to use an image of a musical score as the main 
background for our composite.  

 Open the file SCORE.JPG in the PhotoPlus PROJECTS folder.  

 
 Save the image under the name MONTAGE.SPP. This will become the 

primary working window (we’ll refer to it as the “Montage window”). 

 Now open the file PIANO.JPG in the Sample folder. Copy the image to 
the Clipboard and then close the image window without saving. 

 
 In the Montage window, choose Paste>As New Layer from the Edit 

menu to paste the piano image as a new layer (Layer 1).  

 Choose Adjust>Hue/Saturation/Lightness… from the Image menu and 
boost the layer’s Lightness by 25. 

 Open the file STATUE.JPG in the PROJECTS folder. Carefully select 
around the statue, using the “Ellipse” Adjustable Selection tool to make 
a circular selection including just the statue’s head. 
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 Copy the selected area to the Clipboard and close the image window. 
Then in the Montage window, choose Paste>As New Layer from the 
Edit menu to paste another new layer (Layer 2). 

 Select the Deform tool and drag to enlarge the head slightly, keeping the 
Shift key down to maintain the aspect ratio. 

 
 Save the work-in-progress at this point (and every so often for the rest of 

the project). 

Now, we’ll add some text.  

 Make the foreground colour red on the Colour tab, and then select the 
Text tool. Click the Text tool on the image, and in the Add Text window 
type the words “Liberty Concert.” Use Basic Sans Heavy SF, 72 points, 
with centred alignment and a line break after “Liberty.” Click OK to 
place the text as a new text layer. 

 
 Use the Deform tool to position, resize, and rotate the text on its layer so 

it is parallel to the piano keys, then choose Effects>Effects… from the 
Layers menu and check Drop Shadow to add a shadow behind the text. 
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 Select the piano layer (Layer 1) on the Layers tab. Adjust the Opacity 
for that layer to 75% and set its Blend Mode to Multiply. 

 On the Colour tab, set the foreground colour to black and the 
background colour to white. Then choose the Gradient Fill tool and (on 
the Context Bar) select a Linear fill with both starting and ending 
Opacity values of 50%. Apply the fill to the piano layer by drawing a 
path from the top left to the bottom right of the image. 

 
 Open MOON.JPG in the PROJECTS folder and use the “Crescent” 

Adjustable Selection tool to select a portion of the moon. Double click 
on the crescent to make it a selected.  

 Copy the selected region to the Clipboard, then close the image window. 
In the Montage window, choose Paste>As New Layer from the Edit 
menu. 

 Use the Deform tool to resize and reposition the selection as shown. 

 
 Make the foreground colour in the Colour tab white, and select the Text 

tool. Add the text “Music By Moonlight” in Basic Sans SF, bold, size 14 
points, on three lines, and drag it next to the crescent moon using the 
Move tool. 
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 Select the Text tool again, and add the text “Independence Day” in 
Handscript SF, 24 points. Drag the text to the top of the image using the 
Move tool. 

 Add a slight bevel effect to the new layer by choosing Effects>Effects… 
from the Layers menu, checking Bevel and Emboss, and setting an 
Outer Bevel... and you’re done! 

 
 You can save the image as an .SPP if you want to preserve the layers, or 

choose Merge All from the Layers menu to flatten the file and conserve 
some disk space. 

Extracting part of a layer 
The Edit/Extract... command can speed the task of isolating one portion of a 
layer. Using the special dialog, you simply brush an outline around the edges 
of the region you want to extract, then mark a “foreground” area to be 
retained—usually inside the outline. PhotoPlus applies sophisticated edge 
detection within the marked edge band, decides which pixels to keep, and 
turns the rest of the layer transparent, with variable blending along the edge. 
In preview mode, you can fine-tune and reapply the extraction settings, and 
manually touch up the image until the result is just right. 

 
Instead of marking a foreground region, you can designate a specific “key” 
colour to which edge pixels can be compared. Similar pixels will be kept, 
and dissimilar pixels discarded. (See online help for details.) 
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Layer Effects 
Layer effects are creative effects that you can apply 
to the contents of standard (transparent) layers, text 
layers, or shape layers. Standard or 2D layer effects 
like shadow, glow, bevel, and emboss are 
particularly well adapted to text, while 3D layer 
effects create the impression of a textured surface. 
Because the Background layer doesn’t support 
transparency, the effects are not available there. 
Another thing to keep in mind is that none of the 
layer effects will “do” anything to an empty layer—
you’ll need to have some colour there to see the 
difference they make! 

 For an overview of all the available layer effects, 
take a look at the Effects Gallery in online help. Choose Effects Gallery... 
from the Help menu, or click Effects Gallery on the main help Contents 
menu. You can browse the effects and link directly to details on their 
respective settings. 

 To apply an effect to the active layer, click the Add Layer Effects 
button on the Layers tab (or choose Effects>Effects... from the Layers menu). 
The Layer Effects dialog appears, with a branching checklist of available 
effects. As the checkbox format suggests, you can apply one or more effects 
to the same layer simply by checking boxes to switch them on individually. 
Suppose we preview the settings for one of the basic 2D effects, Drop 
Shadow.  

 
As with all the layer effects, you can check the Automatic box to preview 
the effect continually applied to the image as you make adjustments, or 
uncheck it and click the Manual button only when you want to update the 
preview. You can also choose a Blend Mode to determine how the effect’s 
colours interact with image colours, and adjust the various sliders (or enter 
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specific values) to change the total effect. In this particular dialog, there’s 
also an Angle dial that lets you control the direction of the cast shadow, and 
a Colour swatch to change the base shadow colour. Don’t worry—online 
help includes details on every single layer effect setting! 

Any effect applied to a layer can be switched on or off, as well as copied, 
from the Effects option in the Layers menu.  

3D layer effects are just as easy to apply, but they’re a bit more complex 
than their 2D cousins. Actually, there’s an 
easy way to get started with them: simply 
display the Instant Effects tab and 
preview its gallery thumbnails. There 
you’ll see a variety of remarkable 3D 
surface and texture presets (wood, metal, 
etc.), all generated with the PhotoPlus 
engine. Click any thumbnail to apply it to 
the active layer. Use the Shift key to 
apply more than one Instant Effect to 
existing layer effects cumulatively.  
Assuming the layer has some colour on it 
to start with, you’ll see an instant result!  

Depending on the size of your original image and what’s depicted in it, you 
may want to vary the Scale slider to reproportion the effect (for example, to 
achieve a more realistic orange-peel texture). Having applied a preset effect, 
you can now bring up the Layer Effects dialog and inspect the settings used 
in the preset. The first thing you’ll notice is that the 3D Effects and 3D 
Lighting boxes will always be checked. The master settings of Blur and 
Depth make a great difference; you can click the “+” button to unlink them 
for independent adjustment. As for 3D Lighting, without a “light source” 
switched on, the depth information in the effect wouldn’t be visible.  

Another thing you’ll probably wonder about is that all the 3D effects seem to 
have “map” in their name. So what is a map, anyway? Actually, it’s the key 
to understanding how these effects work. Let’s call it a channel of 
information overlaid on the image, storing values for each underlying image 
pixel. You can think of the layer as a picture printed on a flexible sheet, 
which is flat to start with. Each 3D effect employs a map that interacts with 
the underlying layer’s image to create the impression of a textured surface. 
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Bump Maps superimpose depth information for a bumpy, peak-and-valley 
effect. Using the flexible sheet metaphor, the bump map adds up-and-down 
contours and the image “flexes” along with these bumps, like shrink-wrap, 
while a light from off to one side accentuates the contours. Pattern Maps 
contribute colour variations using a choice of blend modes and opacity, for 
realistic (or otherworldly!) depictions of wood grain, marbling, and blotches 
or striations of all kinds. 

You’ll notice that Bump Maps and Pattern Maps come in two varieties: “2D” 
and “3D.” Don’t be misled! These are all three-dimensional effects; the 
distinction has to do with how each one achieves its result. With the “3D” 
Bump Maps and Pattern Maps, you first pick a mathematical function. With 
the “2D” variants, you begin by selecting a bitmap from a gallery. The 
function-based maps include data about the interior of the “space,” while the 
bitmap-based maps describe only surface characteristics. You’ll see the 
distinction more clearly if you experiment with depth maps, as covered in the 
next section. 

See online help for extended technical coverage of the 3D layer effects. For 
now, just spend some time playing with them! For an exercise combining 
layer effects with depth maps, see the “Letters in the Sand” Hands-on Project 
a few pages on. 

Depth Maps 
Depth maps let you add remarkable 3D realism to ordinary images, with or 
without the use of 3D layer effects (as described above). A standard “flat” 
image, of course, has only two dimensions: X and Y, or width and height. 
Adding a depth map to a layer gives you an extra channel that stores 
information for a third (Z-axis or depth) dimension, in effect adding 
“volume” to the image. It’s as if the original image acquires a surface with 
peaks and valleys—and you can play with the elevation of the landscape to 
achieve different visual results.  

The depth map itself is a greyscale representation that uses lightness values 
to encode the Z-axis or “elevation” data, with 256 possible levels for each 
underlying image pixel. Lighter areas represent peaks and darker areas 
represent valleys. Here’s a schematic view of how an imaginary 3D volume 
(the stack on the left) might be encoded as a depth map: 
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The several levels of elevation on the stack translate or “map” directly to 
lightness values in the greyscale depth map on the right. What PhotoPlus can 
do is take the depth map and translate it back into light-and-shadow 
information that appears (to us) as depth in an image... hence the illusion of 
three-dimensionality. 
 

Typically, you’ll begin by creating a new blank depth map on a layer, then 
modify it by painting or erasing directly on the map. Changes on the 
greyscale map layer produce the effect of highs and lows in the “surface.” 
This kind of greyscale painting is not unlike 
using Paint to Select mode (see Chapter 3) or 
working on a mask... only in this case, it’s 
like using a 3D brush! At right, a typical first 
effort: showing how a solid colour layer 
appears after scrawling in white with a fuzzy 
brush on the depth map... 

 So how can you go about creating a depth map? Just activate the layer 
in the Layers tab and click the Add Layer Depth Map button. You’ll see a 
thumbnail of the depth map appear next to the layer name. Initially, the depth 
map appears solid black, i.e. with zero depth. When you create a depth map, 
the 3D Effects and 3D Lighting layer effects are switched on by default (so 
that depth will be visible); the 3D Lighting contributes a bevel effect around 
the edge, providing initial edge relief. The Colours tab switches to Greyscale 
mode with White initially the foreground colour and Black the background 
colour—and you’re ready to go! 

The basic way to produce an effect is to paint or erase on the depth map. 
Painting in a lighter shade adds “highs,” while painting in a darker shade 
adds “lows.” The fill and selection tools, work, too! For example, instead of 
starting with an all-black depth map, you can fill all or part of the depth map 
with grey to start with, and then use painting or eraser tools. 
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 Try following the steps above and experiment with your own 
“handwriting” in 3D. 

 Try using the Text tool to create a selection in the shape of text, then 
paint inside it. 

While working on the layer, you can switch back and forth between the 
image level, depth map, and (optional) mask by clicking the appropriate 
thumbnail. You can also switch the depth map off and on to assess its 
contribution to the image, or subtract it for creative reasons: Shift-click its 
preview thumbnail, next to the layer name (when the depth map is switched 
off a red ‘X’ appears across the thumbnail). 

 
Bitmap selected                 Depth map selected 

Once you’ve gotten the basic idea of 3D-by-painting, you might want to try 
another way of incorporating depth information: create a suitable bitmap 
image separately (or borrow one from somewhere else) and then paste it via 
the Clipboard to an existing PhotoPlus depth map. See online help for the 
details. And needless to say, you can combine depth maps with 3D layer 
effects or Instant Effects tab presets to create even more fascinating surfaces 
and textures. 

No question about it: these tools will add a whole new dimension to your 
artwork! 
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HANDS ON: Letters in the Sand 
In this sequence, we’ll create a depth map with the aid of the Inner Shadow 
layer effect, and then put it to creative use. 

 Open DESERT.JPG in the PhotoPlus PROJECTS folder. 

 Select a middle grey (128, 128, 128) as your foreground colour. Choose 
the Text tool and click to display the Add Text dialog. 

 Using Basic Sans Heavy SF, type the word “thirst” and set it to 72pt, 
then click OK. 

 Choose the Deform tool and drag to roughly centre the text in the image. 
Drag from the lower corner nodes to enlarge the text block so it’s nearly 
as wide as the image, and drag from the interior to position the word 
near the foreground. Ctrl-drag from each upper corner node, this time 
inward so as to add a perspective deformation. Don’t worry if a couple 
of letters get out of position; you’ll fix them later. 

 
 Choose Effects>Effects... from the Layers menu and check Inner 

Shadow. Select settings as follows: White as the colour, Normal Blend 
Mode, Opacity 100, Blur 15, Distance 4, Intensity 6. Leave the Angle at 
45. 
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Now for a series of operations to turn the text into a depth map where the 
darker interior of the letters will subtract depth, while the white edges will 
serve as the “high ground.” 

 Right-click the text layer and choose Rasterize to convert it into a 
transparent standard layer. If a couple of letters are mis-aligned, now’s 
the time to use the Freehand Selection tool and drag them (kicking and 
screaming) into position. We couldn’t have done this, of course, as long 
as the letters were still on a text layer.  

Your layer structure should now look like this: 

 
 To create a depth map, we need an image layer that supports 

transparency, so right-click the Background layer and choose Promote 
to Layer. 
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  Click the New Layer button to create a new layer between the two 
existing ones. Select White as the foreground colour and use the Flood 
Fill tool to fill this new layer (ensure Use all layers in the Context Bar is 
not ticked). 

 Activate the “thirst” layer and choose Merge Down from the Layers 
menu. Now the layer structure should appear as below, and we’re ready 
to create the depth map. 

 
 On Layer 2, press Ctrl-A to Select All, then Ctrl-C to copy the layer to 

the Clipboard. Click the layer’s  Hide/Show Layer button so all you 
see is Layer 1. 

  With Layer 1 activated, click the Add Layer Depth Map button. 
We’re still in Select All mode with the new map now selected, so choose 
Paste>Into Selection from the Edit menu. You’ll see an instant 
transformation! What started as a text layer has been converted to 
greyscale variations on the depth map. 

  Initially the effect will appear extremely blurry, but a few 
adjustments will fix that. Click the layer’s Layer Effects button and 
adjust the linked Blur and Depth settings for 3D Effects to 10. For 3D 
Lighting, drag the Specular slider to 0 to remove the highlight 
reflections—out of place on sandy terrain. You might also adjust the 
Elevation value to 50.  

 It’s OK to delete Layer 2 at this point. For a clearer visual statement, we 
moved the sandy region up to cover the mountains and create a higher 
horizon line: 
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Masks 
Masking in a program like PhotoPlus is slightly more complicated than 
applying masking tape to the screen! But fundamentally the concept is the 
same: you can hide certain parts of an image—in this case by rendering them 
transparent, hence invisible. To do that, you create a mask on a non-
Background layer. You can also use a mask with an adjustment layer, too—
to restrict the effect to certain regions. 

By changing the greyscale values on the mask (using the paint tools and 
other devices), you can effect corresponding changes in the opacity of the 
underlying layer’s pixels. For example, by “blacking out” on the mask, you 
render the layer’s underlying pixels transparent, and they disappear from the 
image. On an adjustment layer, blacking out hides the adjustment’s effect. 
And because you’re working with 256 levels of grey (i.e. opacity), 
tremendous variations are achievable. 

Besides the creative possibilities, ranging from vignetting to multi-layer 
montage to gradient masking and beyond, a great feature of working on a 
mask is that it is “temporary”—if you don’t like the way things are going, 
you can abandon your changes and start over without ever having affected 
the actual pixels on the layer! 

Each non-Background layer can have one mask at any given time. (The 
Background layer can’t have one because it doesn’t support transparency.) 
Mask information, like layer information, can only be preserved by saving 
the image in the native PhotoPlus (.SPP) format. 



Using Layers, Masks and Filters    129 
 

 

Mask-making 
Here are the three basic steps in using a mask: 

1 Create the mask on a layer. 

2 Edit the mask itself to “preview” changes to the layer. 

3 Merge the mask with the layer to make the changes permanent, or delete 
the mask without applying changes. 

Let’s take these in turn. (The description assumes you’re working with a 
standard layer, but the procedures are similar for adjustment layers.) 

1  Creating the Mask  
Before you can use a mask, you have to create it on a particular layer. The 
mask can start out as all transparent (revealing the whole layer) or all opaque 
(hiding the whole layer)—or you can create a mask from a selection, in 
which case part of the mask will be transparent and the rest opaque. The 
choice depends on how you want to work with the layer’s contents. By 
darkening portions of a clear mask, you can selectively fade underlying layer 
pixels. By lightening an opaque mask, you selectively reveal layer pixels. 

To create a mask, first select the layer where you want to create the mask, 
and select specific region(s) if desired. Choose Add Mask from the Layers 
menu and then one of the following from the submenu: 

• Reveal All for a transparent mask over the whole layer 
• Hide All for an opaque mask over the whole layer 
• Reveal Selection for an opaque mask with transparent “holes” over the 
selected region(s) 
• Hide Selection for a transparent mask with opaque “blocks” over the 
selected region(s) 

 You can also click the layer’s Add Layer Mask button to create a 
Reveal All mask (or Reveal Selection if there is one). 

On the Layers tab, a Mask Thumbnail appears, 
confirming that a mask exists.  
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2  Editing on the Mask 
In Edit Mask mode, you can use the full range of painting tools, selection 
options, and effects to alter the mask’s greyscale values. These manipulations 
cause corresponding changes in opacity, which in turn changes the 
appearance of the pixels on the layer itself.  

Remember, as long as you are editing the mask, you’re only seeing a preview 
of changes on the layer. No permanent changes will be applied until you 
actually merge the mask with the layer. You can switch out of Edit Mask 
mode at any time to work directly on the layer (or any other part of the 
image), then switch back to resume work on the mask. 

To edit the active layer’s mask, click the Mask 
Thumbnail, or check Edit Mask on the Layers 
menu. (Click the layer’s bitmap thumbnail or 
uncheck the menu item to switch out of Edit Mask 
mode.) The Colour tab switches to Greyscale mode 
when you’re editing a mask, and reverts to the 
previous setting when you exit Edit Mask mode. This means anything you 
paste from the Clipboard onto the mask will automatically be converted to 
greyscale. The image window’s titlebar appends “Mask,” indicating that a 
mask is currently being edited.  

In Edit Mask mode, you’re normally viewing not the mask, but rather the 
effects of changes “as if” you were making them on the layer below. Adding 
a Reveal All mask can be a bit confusing, because there’s initially no 
evidence the mask is there at all (i.e. the layer appears exactly the same as it 
did before you added the mask)! It’s sometimes helpful to switch on the 
View Mask setting (Alt-click the mask preview thumbnail, or use the Layers 
menu), which hides the layer and lets you see only the mask, in all its black, 
white, or greyscale glory. For example, a Reveal All mask appears pure 
white in View Mask mode. This represents a clear mask with no effect on the 
underlying pixels’ opacity. 

View Mask can also be useful in the latter stages of working on a mask, to 
locate any small regions that may have escaped your attention. 

You can disable the mask (Shift-click the mask preview thumbnail or check 
Disable Mask on the Layers menu) to see how the layer looks without the 
mask’s effects. Note that disabling the mask is not the same as canceling Edit 
Mask mode—it only affects your view of the layer, not which plane (i.e. 
mask or layer) you’re working on. When the mask is disabled, a red “X” 
appears across its thumbnail. 
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You can also create a selection directly from the mask by selecting its 
preview thumbnail and choosing Create from Mask from the Select menu. 
Within the resulting selection, pixels that are lighter on the mask (conferring 
more opacity) become relatively more selected. This correlates with Paint to 
Select mode (see Chapter 3), where painting in lighter tones also confers 
“selectedness.”  

3  Applying changes to the layer 
Once you’re satisfied with the appearance of the layer as seen with the mask 
enabled, you can choose Merge Mask from the Layers menu to make the 
changes permanent.  

Of course, you may choose to delete the mask (choose Delete Mask from 
the Layers menu) without applying changes... perhaps to try again. In either 
case, whether merged or deleted, the old mask is no longer present and the 
layer is ready to accept a new mask. 

Merging masks reduces clutter and file size, but note that the effects of 
masking appear in exported images whether or not you’ve merged masks. 

HANDS ON: Vignetting 
 Open BRIDGE.JPG in the PhotoPlus PROJECTS folder. 

 Right-click the Background layer and choose Promote to Layer. Now 
that the layer (renamed “Layer 1”) is transparent, we can make a mask 
on it. 

 Select the “Ellipse” Adjustable Selection tool and drag out an elliptical 
selection on the image. Move the selection marquee if necessary so that 
the bridge is exactly centred within it, and double-click to confirm your 
selection. 

The region within the oval selection is our area of 
interest. To create a vignette effect—a gradual 
fade-in from the edges—we’ll want to make the 
pixels at the edge transparent, grading in to opaque 
pixels in the part of the picture we want to keep. 
Feathering the selection will produce this effect.  

Feathering proceeds outwards from the edges of a 
selection, so to feather within the region we’ve 
defined, we’ll first contract the selection and then 
feather out from there. 
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 Choose Modify>Contract... from the Select menu, and type in 20 as the 
number of pixels. Click OK. 

 Now choose Modify>Feather... from the Select menu, and again enter 
20. 

There’s no immediately visible effect on the image, but we have altered the 
selection, as you’ll see... 

 Choose Add Mask>Reveal Selection from 
the Layers menu.  

Right away the effect of the mask created from 
the selection becomes clear—literally! The grey-
and-white checkerboard pattern shows the 
transparent regions of this single-layer image. 
Feathering has produced a gradation of opacity.  

 Merge the mask with the underlying layer by choosing Merge Mask 
from the Layers menu. 

Now let’s put a mat around the image. 

 Choose New... from the Layers menu and click OK to create a new 
layer. 

 On the Layers tab, drag the new layer down below the first one so that 
it’s on the bottom. (You still won’t see any change in the image.) Make 
the new bottom layer the active layer, and press Ctrl+D to remove the 
selection (if there still is one). 

 Pick a neutral beige or pastel foreground colour, and click with the 
Flood Fill tool on the active bottom layer.  

 As a finishing touch, you can 
drag the “bridge” layer slightly 
with the Move tool to centre it 
with respect to the mat. 

 You can now save the image as 
an .SPP, export it to another 
format, print it, or perform more 
manipulations. 
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Filters 
PhotoPlus comes equipped with some stunning filters that can be used to 
give your photos some surprisingly powerful and diverse effects. Filters 
range from the artistic Diffuse Glow to the pleasing Wave filter, and on to 
the awesome Stained Glass filter. In fact up to 30 filters can be directly 
applied not only individually but cumulatively. 

To what do you apply your filters? They can be applied to either a selection 
or layer in your photo so it’s important to ensure that you have the correct 
selection or layer made currently active. 

Filters are managed by using the Filter Gallery dialog, available from the 
Effects menu. The gallery offers a one-stop shop for applying your filters–all 
supported by an impressively large preview window!  

 

Adding a Filter 
 Adding a filter is as easy as selecting the Add Filter button and choosing 

a filter from the flyout menu. As soon as your filter is selected it is added to a 
filter stack where additional filters can be added and built up by using the 
same method. Any filter can be switched on/off, deleted or reordered in this 
list. The order in which filters appear in the filter list may produce very 
different results—don’t worry, if you’re not happy with your current filter 
order—PhotoPlus lets you drag and drop your filters into any position in the 
stack. 
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Filters are applied in the same way that layers are applied, i.e. the first filter 
applied always appears at the bottom of the list and is applied to the photo 
first. In the above example, the Glass filter is applied first, then Diffuse Glow 
next. 

 If at any point you wish to swap one filter for another, while retaining the 
current filter list, simply select the filter to be removed, select Replace Filter 
and pick the replacement filter from the flyout menu.   

Switching on/off Filters 

In the same way in which a layer’s contents can be 
made invisible, the eye icon can make a filter 
invisible (closed eye) or visible (open eye). A click 
on the Glass eye icon (opposite) will make the Glass 
filter invisible like the Diffuse Glow filter. 

Modifying a Filter 
The properties of any selected filter will be displayed in the Filter properties 
box—you can alter and experiment with these at any time.  For example, in 
the above Filter Gallery dialog, the properties of the selected Diffuse Glow 
filter such as Blur, Intensity, Opacity and Threshold can be adjusted by using 
the sliders or value input boxes.  

Reordering Filters 
Filters can be moved around the filter list to change the order in which they 
are applied to the photo. Drag a filter name to another position in the list 
while holding down the mouse button. A red line indicates the new position 
in which the filter will be place if the mouse button is released. 
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HANDS ON: Applying Filters 
For this exercise, let’s apply several filter effects, modifying one of them. 

 To begin, open STATUE.JPG in the PhotoPlus PROJECTS folder. 

 Go to the Filter Gallery dialog and add the 
Diffuse Glow, Mosaic and Twirl filter 
effects without adjustment. 

 Finally, add Noise to the list. Note the order 
in which the filter effects are applied. 

 Switch the Mosaic filter effect off, check the preview and then try 
making some of the other filters invisible to give an appreciation of what 
each filter effect is doing.  Click on the eye icon on the relevant filter. 

 Make only the Twirl filter effect visible so we can make this filter effect 
have more impact. Adjust the filter so that it’s new value is 24. 

 Click OK to apply the cumulative filter effects.  

 

 

The photo will have adopted your chosen filter 
effects.  

Note that once your filters have been applied you 
can undo your changes but cannot directly modify 
the filter effects subsequently. As a solution you 
can record the filter effect changes as a macro. See 
the Macros and Batch Processing chapter. 
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Tutorial Resources 
For more experience with the tools and techniques covered in this chapter, 
we recommend these HTML-based tutorials on the PhotoPlus 10.0 Resource 
CD-ROM. All involve working with multiple layers: 

Try this tutorial... For practice with these tools and techniques... 

Basic Montaging Extract command, working between two images 

Advanced 
Montaging 

Adding shadows, reflection, and more with the Deform 
tool, Crop tool, layer duplication and flipping, custom 
selections with feathering and layer opacity 

Photograph 
Retouching 

Retouching and a photo frame, using Clone tool, 
Replace Colour filter, layers 

Replacing a 
Photograph’s 
Background 

Extract command to transform a group picture into an 
array of “fakes” 

Vector Shapes Adding dimensionality with QuickShapes, gradient fills, 
transparency 

Combining Depth 
Masks with 3D 
Effects 

Depth map fingerprint on a square of “chocolate” 

Using Paths Depth map hand print, using functions on the Paths tab 

Oil Painting Effect II Oil effect applied to a photo 

Web Banner Using the Filter Gallery and layers together 

 

 



 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

6.  
 

Preparing Web 
Graphics 
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One of the main uses for PhotoPlus is to produce graphics for use on the 
World Wide Web. This chapter looks at the prevalent Web graphics file 
formats, techniques for creating and editing animations, and two specialized 
techniques (image slicing and image maps) used to extend the performance 
of Web images. 

 “Performance” may seem like an odd aspect of graphic design, but it’s 
actually one of the key factors in designing for the Web. Among other things, 
it means load time: how long it takes for your whole page, including text and 
graphics, to display completely in a Web browser. In practice, it’s hard to 
measure. Things like connection bandwidth and server speed all play a part. 

Load time is a function of the total size of all the page objects that need to 
load; and graphics usually take up the lion’s share. Is there anything you can 
do to reduce the total size of your graphics, aside from using fewer graphics? 
An obvious suggestion is not to make them any larger than they need to be to 
get your point across. Since file size increases as the square of each 
dimension, shrinking both height and width by half reduces the file size by 
75%. 

The PhotoPlus Export Optimizer will greatly help you in reducing file sizes 
as far as possible while maintaining image quality. For related background 
material, be sure to consult the “Colour concepts” and “Optimizing images” 
sections of Chapter 8. 

Formats for the Web 
Here are some general notes on the principal file formats used for Web 
pictures and animation—.GIF, .JPG, and .PNG—and details on the options 
you’ll encounter in the PhotoPlus Export Optimizer.  

   The details will make a lot more sense if you have the Export 
Optimizer open. Try using Double or Quad view (see Chapter 3) for 
side-by-side quality comparisons at different settings.   

.GIF format 
The .GIF (Graphics Interchange Format) file format is universally supported 
in Web browsers for both static and animated Web graphics. It’s a lossless 
format (there’s no image degradation) with excellent compression but a 
limitation of 256 colours. Use it for non-photographic images with sharp 
edges and geometrics—for example buttons, bursts, decorative elements, and 
text graphics. It’s suitable for greyscale photos as well. 
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The .GIF format supports binary transparency. That is, any portion of the 
image may be either fully opaque or fully transparent. Typically, GIFs use 
transparency to eliminate the box-shaped frame around the graphic that 
would otherwise be present. Thus elements with rounded edges, such as 
characters or shapes, preserve their contours over any background colour or 
pattern.  

The Export Optimizer provides special GIF options that help you preserve 
semi-transparency if you’ve employed anti-aliasing or feathering in your 
original image. The .GIF format still wants “all or nothing,” but you can opt 
to dither the alpha (transparency) channel and/or select a matte colour with 
which semi-transparent pixels will be smoothly blended. Pixels that aren’t 
100% transparent will still end up opaque, but the image will look a lot 
better. 

GIF is also a multi-part format, which means one file can store multiple 
images. As such, it’s the preferred format for Web animations.  

Recommended .GIF export settings 
Colours: 256 colours (8-bit depth) is the only available setting for 
animations, and the maximum supported by the format. For pictures, lower 
bit depths are also possible. 

Palette: Choose Optimized to let the PhotoPlus export filter determine the 
best colours to apply, but without regard for standard colours. Choose Web 
to reduce the colours to only those found in the 216-colour palette used by 
Web browsers. This will ensure that an image you place on a Web page 
won’t change its appearance when viewed by users of most other systems or 
browsers. 

Dither: Dithering schemes substitute pixel patterns for original colours to 
preserve apparent colouration when the actual number of colours in the 
image is being reduced. Choose Ordered (not available for animations) for a 
more regular dot pattern, and Error diffusion for a more adaptive dot pattern.  

Transparent: As noted above, GIF files support transparency—one reason 
they’re commonly used over backgrounds on Web pages. PhotoPlus gives 
you the option of exporting GIFs with or without a transparent background. 
Check Transparent to turn clear “checkerboard” regions of your graphic 
(those with 100% transparency, i.e. 0% opacity) into fully transparent 
regions in the GIF. All other regions will become opaque. If unchecked, 
transparent regions will become white (or the selected Matte colour). You 
can also select a dithering method for just the alpha-channel pixels... try each 
option and see which looks best! 
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Matte: Check this option and click the colour sample to choose a colour with 
which semi-transparent pixels will be smoothly blended. 

Interlaced: Check this option to use an image format that will display 
“progressively” in a browser: first a low-quality image will display, followed 
by an improved image as the complete GIF is loaded. 

.JPG format 
The .JPG or JPEG (Joint Photographic Experts Group) file format, like 
.GIF, is universally supported in Web browsers. Unlike .GIF, it encodes 24-
bit images and is a lossy format (i.e. it discards some image information) 
with variable compression settings. JPG is clearly the format of choice for 
full-colour photographic images. For “black and white” (256-level, 8-bit 
greyscale) photos, it has no particular advantages over .GIF. 

The unique aspect of exporting as a JPEG is in fact the slider control you use 
to choose one setting from 10 possible levels. At one end of the scale, the 
export applies maximum compression and produces an extremely small (but 
quite ugly) image. At the other end, there is effectively no loss of quality, but 
file sizes are relatively much larger, although still compact compared to 
BMPs, for example. 

When choosing a quality setting for JPEG export, keep in mind the number 
of times you expect to be re-exporting a particular image. A photograph may 
look fine in the Export Optimizer the first time you export it at JPEG level 6, 
but after several such saves, you’ll really see a cumulative quality loss. 

PhotoPlus also supports the new JPEG 2000 (.JP2, .J2K) format, which uses 
wavelet compression and reduces file sizes significantly better than .PNG 
(see below) but does not support transparency. This “format of the future” 
can store channels of data—ICC profiles, for example—and is definitely 
worth knowing about! 

.PNG format 
For Web graphics, the newer .PNG (Portable Network Graphics, pronounced 
“ping”) format has a number of advantages over .GIF—the main ones, from 
an artist’s perspective, being “lossless” 24-bit images and support for 
variable transparency. Whereas .GIF supports simple binary (“on-off”) 
transparency, .PNG allows up to 254 levels of partial transparency for 
normal images. The image file includes an “alpha channel” that directs pixels 
in the foreground image to merge with those in a background image.  
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Most commonly used with 24-bit images, anti-aliasing creates the illusion of 
smooth curves by varying pixel colours—for rounded images that look good 
against any background, not just against a white background. It’s especially 
useful for the small graphics commonly used on Web pages, such as bullets 
and fancy text. Because .PNG is lossless and full colour, it’s also an excellent 
storage format for work-in-progress. Unfortunately, not all browsers fully 
support transparent regions in PNGs—for example, Internet Explorer 5 
renders them as grey. 

HANDS ON: Making A Web Button 
Making labeled buttons is a typical use for text in PhotoPlus. Here, we’re 
going to make a simple “Stop sign” button. 

The first step is to create a basic Background layer for the button. 

  Choose New… from the File menu, or click the New button on the 
Standard toolbar. (Then if the Startup Wizard is enabled, click on 
Create New Picture.) 

 In the New Image dialog, set the size to 600×600 pixels and specify a 
white background. 

 
This is much larger than the finished button will be, when saved as a .GIF 
file, but it is much easier to work on a larger image. We’ll resize it just 
before exporting as a .GIF. 

 Click OK to create an empty image with a layer called “Background.” 

 Before going any further, choose Save As… from the File menu and 
save the image as BUTTON.SPP. 
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The next step is to fill the foreground with a plain 
colour.  

 Select a light blue foreground colour from 
the Colours tab (we suggest R=168, G=245, 
B=255). 

 Select the Flood Fill tool from the Tools toolbar and click on the image 
to fill with the foreground colour. 

Now we’ll add a bevel effect to make the image look like a button. You can’t 
apply Layer effects to the Background layer, so right-click on “Background” 
on the Layers tab and choose Promote to Layer. 

 Choose Effects>Effects… from the Layers 
menu and check Bevel and Emboss, then set 
an inner bevel. Bearing in mind that the image 
will eventually be reduced in size considerably, 
increase the Opacity to 75, Blur to 20, Depth to 
200, Angle to 138 and Elevation to 42. 

Next, we’ll add a graphical element. We’ll put this on its own layer, so we 
need to add a new layer. 

 On the Layers tab, right-click on “Layer 1” and choose New Layer…. 
In the dialog, name the layer “Shape.” 

 Change the foreground colour to deep red, then 
select the Polygon tool from the QuickShape 
Tools flyout.  

 Draw a polygon shape. With the Node Edit tool, 
adjust the left handle so the shape is octagonal, with eight sides, and 
drag the top handle to rotate the figure into a “stop sign” orientation. 
Then double-click inside the figure to complete 
drawing the shape.  

 Choose Effects>Effects… from the Layers menu 
and check Bevel and Emboss, and this time set 
an inner bevel with Opacity 75 and Blur 5. 

Next, select White as the foreground colour. 

 Select the Text tool and click it on the image. In the Add Text window, 
type the word “STOP” and format it as Arial, Bold, 72 points. 
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 Use the Deform tool to shrink or expand the word so it fills the centre of 
the octagon. (Or you can click the text with the Text tool and use the 
Add Text box to adjust the pointsize.) 

Finally, we’ll resize the image to a more suitable size for a Web button. 

 To preserve the proportions of the bevel effect, choose Merge All from 
the Layers menu before resizing. 

 Choose Image Size… from the Image menu 
and resize the image to 50×50 pixels.  

 Finally, choose Export Optimizer… from the 
File menu and export the image as a .GIF after 
checking the options. 

Producing Web Animations 
Animation creates an illusion of motion or change by displaying a series of 
still pictures, rapidly enough to fool the eye—or more accurately, the brain. 
With PhotoPlus, it’s easy to create and edit images with multiple frames, 
then export them as animated GIFs that a Web browser can play back. You 
use exactly the same tools and interface as for creating standard, multi-layer 
PhotoPlus images, with an extra tab window that includes all the additional 
controls you need to set up frames, add special effects, and preview the 
animation. Once you’re satisfied, use the Export Optimizer to output to the 
.GIF file format. 

The .GIF format is what makes Web animation possible, for a couple of 
reasons. First, it’s universally supported by Web browsers. Second, it’s a 
multi-part format, capable of encoding not just one image but multiple 
images in the same file. A GIF animation player or Web browser can display 
these images in sequence, in accordance with certain settings (looping, frame 
delay, etc.) included in the file. The result—it moves! 

PhotoPlus gives you the choice of creating your animations from scratch, 
then exporting to .GIF, starting out by importing a .GIF animation and then 
editing it or for existing photos in PhotoPlus, the Animation mode can be 
entered by selecting Convert to Animation from the File menu. Either way, 
once PhotoPlus detects an animation is required, it switches on the 
Animation tab. If the image file is new, you’ll see a single, blank frame, 
labeled “Frame 1.” If you’ve imported an animation, the tab displays each 
frame separately. Animation files can have one layer, or many (see below), 
but all their layers are standard (transparent) layers; there’s no Background 
layer. (If you need to brush up on the concept of layers, see Chapter 5.) If a 
photo is used, the first frame will be the photo image.  
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Layers and frames 
Animations are defined by the Animation tab working together with the 
Layers tab. Let’s look at a little animated GIF of a rotating spiral.  

 Open the file SWIRL1.GIF in the PhotoPlus PROJECTS folder. When the 
image opens, the Animation tab appears. 

 
Notice the playback control buttons on the right, below the frames. 

   Click the Play button to preview the animation, and click 
 Stop to freeze it. Try the other playback buttons, while you’re at it! 

As well as play, stop, rewind etc., the dialog allows for cloning of selected 
frames, applying animation effects, tweening between frames, and looping 
options. 

Tweening , short for “in-betweening”, automatically creates a chosen 
number of frames between the previous or next frame and the current frame. 
This gives a smoother transition of your animation during playback. 

Additional options are available by right clicking on any of the frames. The 
flyout lets you Add Layer to Each New Frame which means that each new 
frame can be edited independently as it occupies its own layer. Reverse 
Frames, as it suggests, reverses the order of selected frames.     

Let’s examine the Swirl animation more closely. 
In this file (as in any imported GIF animation) the 
individual frames each have been assigned one 
layer in the PhotoPlus image. 

On the Layers tab, the layer stack for this 
animation corresponds nicely with the frame 
sequence, with default names—in this case, 
“Frame 1 of 6” through “Frame 6 of 6.”  
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 Select Frame 1 on the Animation tab. 

Notice that on the Layers tab only the “Frame 1” layer is marked as shown, 
with an open-eye button; the other layers are all hidden, with closed-eye 
buttons.  

 Now select Frame 2 on the Animation tab. 

This time, only the “Frame 2” layer will be shown, and the rest will be 
hidden. And so on with the other frames. 

The above example, with its one-to-one correspondence between frames and 
layers, is easy to grasp but deceptively simple. Don’t make the mistake of 
thinking that a “frame” is just another name for a “layer.” Frames in 
PhotoPlus are actually much more versatile! 

Key point: A so-called “frame” is really just a particular state or snapshot of 
the various layers in the image, in terms of three layer properties:  

1 Shown/Hidden: Which layers are shown and which are hidden 
2 Position: The position of the contents of each “shown” layer  
3 Opacity: The opacity setting of each “shown” layer 

As you switch between frames, you are switching between states of the 
image. In the simple example above, the six frames define six states in terms 
of Property 1—each of the six frames defines a different layer as “shown.” 
We could rearrange the stacking order of the layers, or rename them—and 
the animation itself wouldn’t change.  

Thus, when you create a new frame on the Animation tab, you’re not adding 
a new layer. The new frame merely enables you to define a new state of the 
layers that already exist. Of course, you could go on and create an additional 
layer, but then all your frames would need to take that layer into account—in 
other words, hide it when it wasn’t needed. 
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HANDS ON: Follow the Bouncing Ball 
To demonstrate single-layer animation, let’s create an example with a 
bouncing ball—created with four frames but on just one layer. In this 
animation, the four frames will define four states in terms of Property 2—the 
position of the layer contents.  

 Close the Swirl animation window (we’re done with it). To begin 
creating a new animation, choose New… from the File menu. If the 
Startup Wizard is enabled, click on Create New Animation to open the 
New Image dialog. You’ll notice that the Animation option box is 
checked.  

 Specify dimensions (100x100 is fine), set the Background to 
“Transparent,” and click OK. 

 
A new, untitled image window will open, and the Animation tab will now 
look something like this: 

 

  For this project, make sure the Endless Loop button is down. 
 

 Working in the image window, choose the “Ellipse” 
Shape tool and Ctrl-drag to draw a small, dark circle 
at the left side of the square canvas. (The colour 
doesn’t matter, as long as it shows up.) The new 
shape appears on its own layer. 

 Now click the  New Frame button on the Animation tab twice to 
add two clones of Frame 1. 



148    Preparing Web Graphics 

 
 

 On the Animation tab, click on the second dot (Frame 2) to select it. In 
the image window, choose the Move tool and (with nothing selected) 
drag the whole layer so the ball is now at the top of the canvas. When 
you release the mouse, you’ll see Frame 2 on the Animation tab update 
to show the new “state” of the image. 

 Click Frame 3 and drag the layer so the ball is at the right of the 
window. The Animation tab will show the three frames like this: 

 
 Select Frame 1 and choose the Tween button. Select Tween with Next 

Frame and set Number of Frames to 4. Set Attributes to be Position. 
Click OK. 

 Select Frame 7 and again choose the Tween button. Select Tween with 
Previous Frame, Number of Frames to 4. Set Attributes to be 
Position. Click OK. 

 
 Note the new frames automatically added to the Animation dialog and 

how the bouncing ball gradually changes position between frames. 

 Click the  Play button. Not bad for a few minutes’ work!  

 If the animation runs too fast, you can increase the frame delay. Each 
frame has its own delay factor, but here’s how to set one factor for all 
frames. Just click all four frames while holding down the Shift key (that 
selects them all), then enter the new number in the Frame Delay box. Try 
playing the animation again.  
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 Click the Fixed Loop button and try entering a specific number of 
repeats in the box. (The most common setting here would be “1,” for 
example with a longer sequence that only needed to play once.)  

 We suggest that besides saving your creation as an .SPP file, you also 
export it as a .GIF. You’ll notice that the Export Optimizer has a special 
tab for previewing and setting final animation options before exporting 
to the .GIF format. On the Optimizer’s main Options tab, you can check 
or uncheck the Transparent box. Since this little example has only an 
opaque dot on a clear background, it should export well as a transparent 
animation.  

 You can also choose Preview in Browser from the File menu to 
preview your animation in your Web browser. 

We’ll leave it to you to create another example, varying only opacity on a 
single layer, perhaps some text (like “CLICK HERE”) blinking on and off. 
Two frames could accomplish that—in one, the layer set to 0% opacity, and 
in the other, to 100%. 

Notes on animation 
♦ In practice, you can use one, two, or even all three of the layer properties 

when creating a given piece of animation. Just remember that a separate 
layer is only required for each element that moves independently, or 
each differently-drawn state of a given element. An element that doesn’t 
change its shape or colour, but merely moves about or changes opacity 
(appears or disappears), can be animated on a single layer. 

♦ With a little forethought and sketching, you can figure out in advance 
how many layers you’ll need. Then you can set up the image with the 
right number of layers to begin with.  

♦ To preserve layer properties, be sure to save the image in the native 
PhotoPlus (.SPP) format. You can reopen an image you’ve exported as a 
GIF, but it will have lost PhotoPlus layer properties like opacity and 
position.  

♦ Although .SPP animations and .SPP pictures share the same file 
extension, there’s no direct conversion option—a file either has 
animation properties, or it doesn’t. To convert an .SPP picture file to an 
animation, or extract a single frame from an animation to a picture, first 
create a new image window and then use conventional copy/paste 
commands to copy elements and/or layers from one file to the other. 
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♦ Use animations sparingly on Web pages. Like all attention grabbers, 
they can lose their impact if overused. Also, animated .GIFs (because of 
the additional image information) are substantially larger than a static 
graphics, a consideration if you expect people to view your pages over a 
slow Internet connection. 

♦ PhotoPlus also lets you export animations to the .AVI movie format (for 
details, search “AVI” in the online help Index). AVIs are suitable for 
specialized multimedia work, but are neither compact nor universal 
enough for general use on Web pages. 

Animation effects 
You can turn a variety of PhotoPlus effects (as illustrated in the Effects 
Gallery, plus Fade and Move) into animated transition sequences. The 
process “in-betweens” or “morphs” a layer from a designated starting frame 
to some end-state over a specified number of frames, creating one new layer 
per frame. If you like, you can select a “Ping Pong” option that includes a 
reverse transition so the final frame looks just like the first one.  

The Fade effect steps the opacity of each frame in the sequence up or down 
between the Start and End values, for a fade-in or fade-out. The Move effect 
displaces the contents of the frame in a straight line between designated Start 
and End positions. Note that objects on text or shape layers can only use the 
Fade and Move effects. To use text or shapes with one of the other animation 
effects, first merge the layer into a standard layer, or convert it to a standard 
layer by right-clicking on the layer name and choosing Rasterize  from the 
menu. 

You can either have PhotoPlus create a sequence of new frames for the effect 
(check Create as new frames) or you can create some empty frames 
yourself and then generate the effect with the Create as new frames option 
unchecked. This will integrate the new layers into the existing blank frames, 
beginning with the designated Start frame. 
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Image Slicing 
Image slicing and image maps are two convenient ways to create navigation 
bars and clickable graphics for Web pages. With image slicing, a graphic is 
carved up into smaller graphics—each of which can have its own link, like 
any Web graphic—and PhotoPlus saves the sections as separate files when 
you export the image. The process also exports HTML tags describing a 
table containing the separate graphics, allowing a Web browser to 
reassemble them seamlessly. The result appears as a single larger graphic, 
but with different regions linked to different targets. 

For example, this menubar graphic... 

 
...can be sliced into four separate graphics, each linked to a different Web 
page. 

 
The Image Slice tool lets you divide the image into sections, which can be 
exported using the .GIF or .JPG format. You can specify alternate text and 
URL links for each of the image sections individually. 

Slicing an image 

 The Image Slice tool on the Standard toolbar looks like a small, black-
handled knife. When it is selected, the cursor also changes to a small knife. 

To slice an image horizontally (left to right) select the image slice tool and 
left-click on the image. Shift-click to slice an image vertically (top to 
bottom). Repeat as many times as necessary. Each click inserts a red slice 
guide. You can move a guide up or down by dragging it, or delete a guide by 
dragging it out of the image window. 

To specify the alternate text and/or URL link for an image slice, right-click it 
and enter the information into the dialog, then click OK.  

When exporting a sliced image, check the Create Image Slices box on the 
Export dialog. Specify a name and folder for the files as usual, and choose 
either .GIF or .JPG as the export file type. We recommend using .GIF for 
non-photographic images and .JPG for photo-quality images. 
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This will create multiple files in the specified folder, depending on how 
many slices you have defined. There will be a series of image files (for 
example, MYFILEH0V0.GIF, MYFILEH0V1.GIF, etc.) and a single HTML 
file (for example, MYFILE.HTM). The HTML file contains the tags for the 
set of image slices, ready to be pasted into the source code for the Web page. 

Image Maps 
Whereas image slicing subdivides an entire graphic into smaller graphics and 
exports them separately, image maps consist of hotspots that you draw with 
special tools over selected parts of an image. When a visitor passes their 
mouse cursor over the hotspot, a small caption is displayed and the pointer 
will change to a pointing hand. Clicking the mouse while the cursor is over 
the hotspot will invoke a hyperlink to a specified URL. 

 
You assign each hotspot its own target—for example, the URL of a Web 
page. Hotspots aren’t attached to a particular image, but become part of a 
larger “map” that gets exported along with an image and turns into HTML 
code. It’s then up to you or your Web developer to embed the image map 
code properly into the Web page. 

Creating image maps by hand can be difficult and time-consuming, but 
PhotoPlus makes it easy. The Image Map Tools flyout on the Standard 
toolbar displays a flyout menu of tools for creating and editing image maps. 

There are four image map tools: 

♦ The  Selection tool, used to modify the area drawn with one of the 
other tools and to actually set the image map properties; 

♦ The  Rectangle tool, used to draw a rectangular hotspot; 

♦ The  Circle tool, used to draw a circular hotspot; 

♦ The  Polygon tool, used to draw a polygonal hotspot. 

Creating hotspots 
To begin, click the Image Map Tools flyout and choose the Rectangle, 
Ellipse, or Polygon tool. Use the tool to draw a hotspot on the active layer. 
To draw a polygon, drag and release the mouse button to define each line 
segment; double-click to close the polygon. 
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To edit a hotspot, click the Image Map Tools flyout and choose the 
Selection tool then click on the hotspot. To resize the hotspot, drag from an 
edge. To move the hotspot, drag from the centre. Right-click the hotspot with 
the Selection tool to delete it, set layer options, or access hotspot properties. 

In the Image Map dialog, enter the text 
which will pop up when the cursor moves 
over the hotspot, and the full URL for the 
hotspot to link to. Previously-used URLs 
are saved and can be selected from the 
drop-down list by clicking on the arrow at 
the end of the box. 

Normally you will export the image for which you have created the image 
map as a .GIF (for non-photographic images) or a .JPG (for photographic 
images). We recommend that you use the Export Optimizer (choose Export 
Optimizer… from the File menu) to compare the quality and file size which 
results from various settings. 

Make sure that the Create HTML for Image Maps box is checked in the 
Export dialog, then click Save. This will create identically named .HTM and 
image files. The HTML file contains the tags for the image map, ready to be 
pasted into the source code for the Web page. 

If you’re looking for a powerful yet easy-to-use tool for Web page design, 
look no further than Serif WebPlus, which lets you create your own Web 
site from scratch or with Web Page Wizards (using its Resource CD-ROM). 
WebPlus enables effortless, WYSIWYG Web page design—and you can 
incorporate the animations, sliced images, and image maps you’ve created 
with PhotoPlus. 

Tutorial Resources 
For more experience with the tools and techniques covered in this chapter, 
we recommend these HTML-based tutorials on the PhotoPlus 10.0 Resource 
CD-ROM: 

Try this tutorial... For practice with these tools and techniques... 

Further Animation Instant Effects, Mesh Warp tool to create an animation 

Creating Web 
Buttons 

Multi-layer graphical buttons using QuickShapes, Image 
Browser, Image Slice, Image Map tools 
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Macros and Batch 
Processing 
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Understanding Macros 
If there is a command that you want to repeatedly perform in PhotoPlus, you 
can apply a macro. Put simply, a macro is a saved sequence of commands 
that can be stored and then recalled at a later date. Examples of where macros 
can be used include: 

♦ Downsampling 
♦ Reformatting 
♦ Applying effects 
♦ Image adjustments 

There are hundreds, possibly 
thousands, of macros that could be 
recorded for PhotoPlus. The good 
news is that PhotoPlus already offers 
up to 200 pre-recorded macros ready 
for your use. These macros are 
available in the Macros tab, where 
they are separated into various 
categories including Colour, 
Commands, Effects, and Frames 
(shown) to name but a few. 

Each category is accessible via a drop-down menu. When a new category is 
selected a scrollable list of macros for that category is made available. 

Next to each macro you may have noticed an  icon 
which, when clicked, displays the commands that make 
up the macro. For example, a macro that creates a 
chrome frame around your photo would have a series of 
recorded commands listed. These are listed in 
chronological order and may be enabled, disabled, 
reordered or made interactive “on the fly”.  

As with many objects within PhotoPlus, you can cut, 
copy, paste or even duplicate any macro. This allows 
you to reorganize your macros into different categories if 
required.  
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Recording a Macro 
Of course at some point you may want to record your own macro. It’s 
probably a good idea to create a new category into which you can save your 
newly recorded macros—this keeps them separate from the pre-recorded 
macros supplied with PhotoPlus. This is because recorded macros will be 
indistinguishable from your preset macros once recorded. 

When recording macros, it can be a good idea to ensure that the Layout 
Rulers/Grid units in File>Preferences are set to “percent”. This approach 
ensures that recorded macro commands such as document resizing or 
framing are carried out in proportion to the original photo rather than by an 
absolute value. Imagine adding an absolute frame size to a small photo that 
would otherwise be acceptable on the larger photo. Obviously, on some 
occasions you may want to use absolute values—simply use absolute grid 
units. 

Let’s look at recording a macro..  

 Use the New Category and  New Macro buttons at the 
bottom of the Macros tab to provide, firstly, a suitable category name in 
the dialog, e.g. Borders, and then, secondly, a macro name in advance of 
you recording your macro. Let’s choose “Silver border 50 pixels” as the 
macro name. 

 
 Make a rough note about what you want to achieve by recording your 

macro. If you jot down your intended command sequence your planning 
will help you make fewer mistakes.    

  Now for some recording! This is possible from within the Macros 
tab by choosing the Start Recording button. Any command you invoke 
while recording is in progress will be stored. 

 Carry out the command sequence you want to record, following the 
instructions when necessary.   

  Stop recording your macro with the Stop Recording button! 
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 Click on the macro name, and select the adjacent  icon to view the 
command list recorded by the macro. 

Congratulations—you’ve recorded your first macro! 

Playing a Macro 
To play a macro you need to choose a photo to which you want to apply your 
recorded or pre-recorded macro. Any macro, whether recorded or pre-
recorded, needs to be played to repeat the recorded commands. 

 Open the photo you wish to apply the macro to.   

 Select your macro by highlighting the macro name. 

 Choose the Play button in the Macros tab to play the macro.  

Modifying a Macro 
It’s time to look at the contents of the macro in more detail. We know that 
when a macro has been recorded the commands are listed under the macro 
name. So what can we do with this command list? Well it’s possible to 
perform a number of operations—these are described in the following 
illustration (compare this with the illustration for the Chrome macro at the 
beginning of this chapter). 

Before going any further, some advice about modifying your macro presets. 
It’s advisable to copy and paste any preset to your own macro category to 
preserve the integrity of the original macro. This ensures that macros will 
continue to be of use to you in the future. 
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By default, macro commands will be enabled (checked) so you are able to 
disable them if you need to experiment.  

You may have noticed that there is a command “New Type Layer” - this was 
recorded in a separate macro and then moved into this macro by drag and 
drop. You can copy and paste macros but not individual commands within 
each macro. 

 The interactive pop-up, as its name suggests, allows you to intervene in 
the macro running process to alter some dialog values while the macro is 
temporarily “paused”. Check the empty box to display a dialog box icon; this 
will pop-up the appropriate dialog as the macro is run.  

Another example of interactivity is the inclusion of a pause into your macro. 
This allows you to pop up either an instruction or some important notes at 
pre-defined points as your macro runs. There are a number of reasons for 
doing this—your macro can’t record selections or operations that are 
particular to each photo so manual selection is essential in some instances, or 
maybe you want to add a warning to yourself to perform an action (e.g., “try 
a test export”). Pauses are added after a selected command by right- clicking 
and selecting Insert Pause... from the flyout menu.    
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It is also possible to perform a right-click to delete, rename or duplicate a 
command in the same flyout menu. The command order can be rearranged by 
simple drag and drop. 

All of the above features provide a high level of control when editing your 
recorded macro. Try out different combinations of commands to build up 
your structure. Clearly if you significantly modify your macro command list 
your macro may become unusable, so it’s important to exercise some 
restraint while editing—experimentation and testing is the rule of thumb. 
Any changes you make will be applied to the macro such that no file saving 
is required.   

The Hands On exercise at the end of this chapter will walk you through using 
batch processing with a pre-recorded macro and with a macro you will record 
yourself. 

Batch Processing 
The batch processing feature is especially useful if you want to repeat the 
same operation again and again... Batch processing allows you to: 

♦ Specify a source and destination folder as your input and output. There 
are several advantages to this, mainly that your original photos are not 
overwritten and that time consuming Save As commands are avoided.  

♦ Bulk convert selected files to a new file type (with different file 
properties if needed). 

♦ Use a pre-recorded macro as part of the batch process.  
♦ Use a macro you’ve recorded yourself. 

The Batch dialog, available from the File menu, is used to perform all of the 
above operations. 
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Using Macros 
Macros can be applied to a batch process easily. Click the Use Macro 
checkbox and pick a category and macro name.  PhotoPlus doesn’t 
differentiate between pre-recorded and recorded macros. If available, they 
are selected from the same Category: and Macro: drop-down menus 
equally. 

Changing File Type 

It is possible to convert your 
photos into one of many different 
file types available in PhotoPlus. 
In addition, conversion options 
such as bit depth, 
compression/quality, dithering 
etc. can be selected in context 
with each file type.  

File conversions can be carried 
out independently or in 
conjunction with macros (as 
shown).  
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Choosing Source and Destination 
You may be wondering how batch processing affects your currently loaded 
photos. PhotoPlus’s batch processing only operates on source folder contents 
and not on the currently loaded photos themselves—so these remain 
unaffected. However, as a visual check, you will see each photo being 
converted in the Photo window during batch processing.  

Whether you are using macros or not you can select a Source Folder and a 
Destination Folder to define which photos are for processing and where you 
want to save your photos once processed, respectively. To save you time, 
PhotoPlus will remember previously selected Source and Destination folders 
while PhotoPlus is loaded.  

It is also possible to define a Destination File Name for the files to be 
processed by selecting Modify... In the File Name Format dialog you can 
select new file names that can be built up using the current date/time, 
document names, sequence number, or text string, individually or in 
combination. Remember to use the sequence number to generate a separate 
file for every file to be converted—otherwise your first converted file will be 
overwritten continually.  

NOTE: If you don’t select a destination folder the source files will be 
processed and your original files will be overwritten—exercise caution with 
this option.  

HANDS ON: You’ve been Framed! 
We’re now going to bring together the macro and batch processing features 
to frame some photos. A hammer won’t be needed... 

Two exercises will be necessary for this.. 

♦ Exercise 1: To electronically frame a series of photos by using a pre-
recorded macro and batch processing—all in one go! 

♦ Exercise 2: As for Exercise 1, but you’ll record and use your own 
macro instead of the pre-recorded macro. 

Let’s start Exercise 1:  

 Choose the Batch option in the File menu. 

 Check the Use Macro button. 
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 In the Category and Macro drop-down 
menus, select the “Frames” category and 
“Glass” macro as the pre-recorded 
macro. 

 Let’s choose our source photos... In the 
Source Folder box choose the 
Browse... button and navigate to the 
PhotoPlus PROJECTS folder. This will 
pick up the folder contents as our source 
photos.  

 Now for the Destination Folder—we want to save the batch processing 
output. Navigate to the same location as above but create a new 
subfolder under the PROJECTS folder called “framed”—use the Make 
New Folder button in the Browse for Folder dialog for this. 

 Press OK.  

After each photo is processed, you will receive a warning message. 

 
You may see this message frequently when carrying out batch processing. As 
the Glass macro contained features (e.g., layers) that cannot be saved in the 
required format, the option exists to also save the photo in its native format, 
i.e. as an SPP. file. Selecting Yes will prompt you for an SPP filename in a 
Save As dialog. 

 Select No for each photo in each of the warning dialogs. 

Your converted photos will be stored in the “framed” folder. 

..and onto Exercise 2: 

  Create a new Macro category called “MyMacros – Borders”. 

 Navigate to the new category and 
create a new macro called “Orange”.  
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 Let’s plan a little—we want an orange border with a proportional width 
of 15 % of the photo.  We need to create a duplicate layer, adjust the 
canvas size, and apply a fill. An additional requirement is to have a drop 
shadow around our photo. ..but first we need a photo. 

 Select  MOON.JPG from the PhotoPlus PROJECTS folder. 

  It’s time to record the macro. Click on the Record button. Don’t 
panic!! 

 To apply the drop shadow we need to duplicate the layer.  In the Layers 
tab, select the background layer, right click and choose Duplicate.... 
Select OK. 

 With the duplicated layer selected, go to Canvas Size on the Image 
menu, check the Relative checkbox and enter a new width and height of 
15 percent for both (change the units drop-down menu to select percent 
first). This sets a border proportional to all photos. 

 Apply a drop shadow to the duplicated layer from Effects>Effects in the 
Layers menu and click OK. 

 Select the Background layer. Use Edit>Fill to create a custom colour fill 
with orange ( RGB 255,153,51). 

 Select the duplicated layer again, right click and select Merge Down.  

 Click on the Stop button in the Macros tab. 

 Quickly check the recorded macro by 
clicking the expand macro icon—this 
displays the Macro command list.  

Congratulations – you’ve recorded your macro. 
Let’s continue. 

 Follow Exercise 2 ensuring that the Category and Macro drop-down 
menus have the “MyMacros – Borders” and “Orange” options selected 
instead of  “Frames” and “Glass”. 
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 Choose your source photos as before but set up the Destination File 
Name by selecting Modify... In the File Name Format dialog select 
Text as a token, click Add and enter “test” in the Text box. Add a 
Sequence token with start number “01” —this creates files as test01, 
test02, test03, etc. during the batch process. 

 
 Press OK. You will see each photo being converted as the batch process 

proceeds. 

Your converted photos will be stored in the “framed” folder. 
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Options 
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This chapter ties together a variety of loose ends... mindful of the fact that 
every PhotoPlus user will arrive with different needs and prior experience. 
The other Companion chapters focus on step-by-step procedures to build 
familiarity with tools and functions. Much of the important theory that 
underlies the program’s workings has had to take a back seat.  

As you read through the topics here—all dealing in one way or another with 
different ways of representing pictures as on-screen bits and bytes—you’ll 
realize how indispensable these underlying concepts are. Although this is the 
final chapter, it can make a good starting point, too. 

Colour Concepts 
It’s always difficult to draw a line between concepts you should understand 
before you get started, and those that can wait until you absolutely need 
them. Here we’ve collected a few key terms and concepts relating to colour, 
and presented them roughly in order of priority, trying to keep it simple 
without oversimplifying. So we suggest you just begin at the beginning, and 
treat this as a reference section you can revisit at any time.  

Bitmaps 
First of all, PhotoPlus is all of the following things and more: a “photo 
editor,” a “paint program,” a “bitmap editor.” It lets you create manipulate 
images called “bitmaps,” “paint-type” images,” or “raster graphics.” Don’t be 
overwhelmed by the jargon—all these terms communicate a single concept! 
Bitmaps (let’s settle on that term) are digital pictures (which may or may not 
be photographs) represented by lots of coloured dots (“pixels”) on a 
computer screen (“raster”). You create these images by “painting” or filling 
in regions on the screen, regions that can be as small as a single pixel or as 
large as the whole screen (or larger). 

Bit depth 
A bitmap is basically a bunch (literally a “map”) of numbers that tell each dot 
(pixel) on a computer monitor what colour it should be. And since computer 
numbers consist of binary digits (1’s and 0’s, or “bits”), each pixel in effect 
has one or more bits backing it up, telling it what to do. From this fact arises 
the concept of bit depth (also known as “pixel depth”), one of the essential 
attributes of any bitmapped image. Bitmaps not only have height and width, 
they have depth. The more bits assigned to each pixel, the more possible 
colour states the pixel can be told to take—the greater its “colour depth.”  
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For example: If you’re only using 1 bit per pixel, the pixel can only be ON or 
OFF, in other words “1” or “0,” the two states of the bit—hence white or 
black (monochrome). By comparison, a bit depth of 4 bits per pixel can 
store 16 values; 8 bits per pixel, 256, and so on. 16-bit images have roughly 
“thousands” of values to describe each pixel’s colour, and 24-bit images 
have “millions.” Not surprisingly, the file 
size of an image is basically the product of 
its linear dimensions (number of pixels) 
times its bit depth, so a picture saved as a 
24-bit image would take up three times as 
much disk space as an 8-bit version. 

Of course, the appearance of a bitmap on a screen depends not only on the 
bit depth of the picture but on that of the computer screen displaying it. Just a 
few years ago (in the “old days”), many monitors were limited to 16 colours, 
and 256 was a big deal. There were “VGA” and “SVGA,” and today the 
choices include “High Colour” (16 bit) and “True Colour.”  

Just because you may have a higher-end system, don’t forget that many 
others do not. A 24-bit image with millions of colours may look abysmal on 
a 256-colour monitor—a key consideration when it comes to creating 
graphics for the Web, as opposed to CMYK separations for a print 
publication. In print publishing, designers must worry about whether the 
colours specified in their electronic images will produce “true” output when 
reproduced in ink, under standard lighting conditions. In Web or CD-ROM 
publishing, the main worry is how to optimize or reduce the file size as far as 
possible, while maintaining some semblance of quality in the image (more 
about optimizing below). Fortunately, PhotoPlus includes tools to support all 
these needs. 

Bit depth in PhotoPlus 
One of the main differences between PhotoPlus and most other paint 
programs is that we’ve put aside the restrictive notion of working with a 
limited number of colours. You can work on any image in 24-bit mode, 
accessing the full colour spectrum via the Colour tab. Native format (.SPP) 
images are stored in this mode. When and if the time comes to save in a 
different format, and reduce colours, PhotoPlus provides the Export 
Optimizer for maximum quality control. 

While novices will appreciate the ease of use this approach brings, more 
experienced users may at first need to adjust to the absence of colour 
swatches and the constraints of working in 256-colour mode. Still, we’re 
confident that the benefits of concentrating on image production first, and 
colour reduction last, will soon become apparent! 
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Tip: You can use the Open dialog to peruse images on your system one at a 
time, or the Image Browser to display a folder-full of thumbnails at a time. 
The Open dialog gives the bit depth and dimensions of each image, while the 
browser shows dimensions (plus additional file data if you right-click a 
thumbnail and choose Information...). 

Resolution 
Bitmaps are created at a fixed resolution, measured in dpi (dots per inch) 
and hence lose quality if resized upwards. Resizing downwards is a different 
matter, which is why it’s always a good idea to scan pictures at higher dpi 
settings and scale down later (see the “Scanning Tips” section later in this 
chapter). The reproduction quality of bitmaps can vary dramatically, and 
depends on factors such as the dpi stored in the original file, the dpi used for 
reproduction (printing), the bit depth, and the scaling factor used in 
reproduction.  

High resolution bitmaps compensate for quality problems, but tend to be very 
large files. 

Colour modes 
The PhotoPlus Colour tab includes a control that lets 
you select one of four colour modes: RGB, CMYK, 
HSL, or Greyscale. You should know something 
about these modes, even if you only have occasion to 
work in one or two of them. Much of the terminology 
overlaps. Let’s consider these, starting with the simplest. 

A greyscale image looks like what we would call a “black and white” 
photograph, which properly speaking has many levels of black and white 
(not just two, as in a monochrome line drawing). On computers, Greyscale 
mode stores 256 shades of grey or levels of lightness. A value of 0 represents 
pure black, a value of 255 pure white. Sometimes we speak of the “tones” in 
a greyscale image—it’s just another word for the different “values” or 
“lightness levels.” 
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To understand HSL, imagine the difference between watching a TV program 
on a black and white set as opposed to a colour set. It’s the same colour 
signal, right? But the black and white set doesn’t reproduce the colour. What 
it does pick up is the greyscale or lightness channel of the signal. In the same 
way, any colour image in PhotoPlus has a channel that stores lightness 
information. The “L” in HSL stands for Lightness. To repeat—and this is 
important when it comes to understanding topics like masking and blend 
modes—lightness and greyscale values (and for that matter tones, luminance, 
and brightness) all refer to the same thing.  

The additional Hue and Saturation channels in HSL mode together store the 
colour information that’s missing from a simple greyscale image. Like 
Lightness/Greyscale values, Hue and Saturation channel values are expressed 
in numbers, ranging from 0 to 255. (If you’re alert, you’ll note that 256 is 
equivalent to 8 bits of information, so H+S+L has three 8-bit channels 
totaling 24 bits—which is where the “24” in “24-bit” comes from.  

Hue refers to the colour’s tint—what most of us think of as rainbow or 
spectrum colours with name associations, like 
“blue” or “magenta.” A colour wheel (like the one 
in the PhotoPlus Adjust Colour dialog) is useful 
for representing the spectrum of hues as a 
continuous cycle, like a clock. The hue “red” is 
arbitrarily assigned the value 0 at a certain 
position, and the values run around the circle. 
Saturation describes the colour’s purity—a totally unsaturated image has 
only greys.  

RGB mode is much less intuitive than HSL as a method of mixing colours, 
but it’s the standard way of describing colours the way they’re displayed on 
computer monitors—as additive mixtures of separate Red, Green, and Blue 
components. Anyone who’s seen (in school, perhaps) a demonstration of 
three projector beams in a dark room, one of each colour, merging to produce 
a pool of white light, has seen a primitive version of the RGB system. Turn 
all the elements off and you get black. On computers, as with the HSL 
system, 8 bits are used to encode each of the three channels, for a total of 24 
bits, and with 256 possible levels (0-255) for each channel. An RGB value of 
“0,0,0” represents pure black, while a value of “255,255,255” represents 
pure white. 

To quickly get a feel for the HSL and RGB colour mode variables, double-
click either the foreground or background colour swatch on the Colour tab 
and try mixing your own colours using the Adjust Colour dialog. (See online 
help for details.) 



Colour and Input/Output Options    173 
 
 

 

Finally, CMYK is a colour model used for preparing printed work, where 
ink on paper is the medium that determines colour reproduction. It’s based 
on the subtractive principle by which our perception of a pigment’s colour 
depends on which light wavelengths it absorbs and reflects. The four process 
inks are Cyan, Magenta, Yellow, and BlacK (Black is referred to as Key). 
Mix these four inks, and you get black. No ink gives you white (i.e., the 
colour of the paper)—so if you want white, you must use no ink and let the 
paper show through! In this subtractive model, the more ink applied, the less 
light reflected, hence the darker the colour.  

In PhotoPlus, the C, M, Y, and K channel values are given as percentages, 
from 0 to 100%. PhotoPlus supports CMYK output of process colour 
separations (see the section later in this chapter). 

Colour matching 
As you might expect from the foregoing descriptions of CMYK and RGB, 
when it comes to colour reproduction, printing devices and computer screens 
are on totally different “wavelengths.” Printing creates colours by mixing 
inks which absorb light, while a monitor produces an image by mixing the 
light itself—as R, G, and B primary colours. The variable brightnesses of 
each element give the typical computer monitor a range or gamut of colours 
much greater than can be printed with CMYK inks.  

The fundamental differences between the CMYK and RGB colour models, 
and the limited gamut of the printed page compared to the computer screen, 
create the colour matching problem: the challenge of getting your printed 
output to match what you see in your on-screen design. By calibrating your 
equipment and using great care, you can achieve a close approximation—but 
the cardinal rule is “Trust, but verify!” Never simply assume the colours on 
your screen will turn out exactly the same when printed. It’s just very 
difficult to convert accurately between the two models! 

For more accurate results, we strongly recommend that you take advantage 
of PhotoPlus’s colour management features, which let you select ICC device 
profiles that specify how the internal RGB and/or CMYK colours in your 
publication’s fills and bitmaps will map to on-screen and printed colours. 
The International Color Consortium (ICC) defines industry standards for 
converting colour information between various colour spaces and gamuts. 
Choose Colour Management...  from the File menu to view a dialog that 
lets you select from profiles available on your system. Your monitor or 
printer manufacturer’s Web site should have additional information on how 
those devices use ICC profiles.  
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Colour mode tips  
♦ The colour mode setting (on the Colour tab) determines how image data 

gets pasted from the Windows Clipboard—in other words, as greyscale 
values in Greyscale mode, or as full 24-bit colour in any of the other 
modes.  

♦ If you start editing a layer mask (which represents opacity values by 
shades of grey), the Colour tab switches temporarily to Greyscale mode. 
Applying the Image>Adjust>Greyscale filter or equivalent adjustment 
layer, however, doesn’t affect the colour mode. 

♦ You can use the Colour Pickup tool as a probe to read component values 
in an image. Move the tool around the image and watch the HintLine. 
Depending on the colour mode, you’ll see a readout of values (R, G, B, 
H, S, L, etc.) under the current cursor position. 

Using the Histogram 
The histogram tab is used to view the 
distribution of colours and tones spread 
throughout your current selection, selected layer 
or entire photo (by default).  The X-axis shows 
the colour level (from 0 to 255) and the Y-axis 
the number of matching colour pixels of that 
colour level, i.e. the intensity values.    

A histogram can be shown for the individual 
Red, Green or Blue channel, or the composite of 
the three, the RGB channel (shown). Luminance 
(or lightness) can also be shown as a histogram. 

You can right click on the histogram to reveal a flyout (shown). To change to 
a different channel, pick a channel from the list.  

The flyout will also let you optionally display statistics by checking Show 
Statistics.  

See the PhotoPlus 10 Online Help System for more information. 

Viewing statistics 
With statistics enabled, you can place the pointer at any point on the 
histogram to view pixel intensity values for composite RGB, each specific 
colour or luminance level. To view values for a range of colour or luminance 
levels, hold down your mouse button and drag to select the area for analysis.  
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The statistics display will show:  

♦ Mean—The average intensity value. 
♦ Median—The middle value in a range of intensity values. 
♦ Std Dev.—Shows how intensity values deviate from normal. 
♦ Pixels—Total number of pixels present in the histogram. 
♦ Level—Shows intensity level under the mouse cursor. 
♦ Count—The total no. of pixels for the intensity level under the mouse 

cursor. 
♦ Percent—The cumulative number of pixels at the selected intensity 

levels (hold down mouse button and drag), expressed as a percentage of 
the total number of pixels in the histogram.  

By analysing histogram information you can build up an understanding of 
the colour distribution in your photo, and more importantly any colour 
deficiencies that may exist.  

Optimizing Images 
In a perfect world, there would be just one digital picture format that 
everybody used. Infinite storage capacity and bandwidth would allow full-
colour images to be stored and transmitted instantly, uncompressed... but 
let’s leave that for a sci-fi novel! The reality is that at least hundreds of 
picture formats have been created, with more on the way. A dozen or so are 
currently in widespread use among computer professionals. The tradeoff 
between image quality and file size will remain a fact of life. Hence the need 
to optimize images—that is, achieve the best quality in the least file size, 
and within whatever other constraints (such as number of colours) the job 
may impose. 

PhotoPlus features a powerful Export Optimizer (introduced in Chapter 2) 
that serves as your “command centre” for exporting images to various 
formats. It not only provides a variety of options for each supported format, 
but lets you compare image quality using different settings and even retains 
your preferred settings for each format. You can access the Export Optimizer 
at any time—not just when exporting—to take advantage of its comparison 
capabilities. While the visual previews speak for themselves, some of the 
available settings may need some explanation. 
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Palettes 
The PhotoPlus Export Optimizer offers two standard Palette options when 
you export using 8 bits or less. A colour palette (no relation to a “floating” 
palette) is a table of colour values that gets stored with any image having 256 
colours or less. This could mean a .BMP, .GIF, .PCX, or .WMF image—plus 
quite a few more. Computer users with high-colour monitors may not give it 
much thought, but in the realm of 256-colour displays, palettes can make a 
great deal of difference. Windows itself reserves “slots” for its own “system” 
colours, and each application must “declare” a palette while the graphics 
system tries to ensure peaceful coexistence. When several colourful 
applications are in use, and you switch from one you another, you sometimes 
see the ghastly result of palettes clashing as neither application wants to 
relinquish its hold on a scarce system resource.  

To avoid that kind of calamity when displaying Web pages, both Netscape 
and Microsoft browsers use the same Web-safe palette of 216 colours to 
display images. Since you’ve gotten this far, you may be interested to know 
that the Web-safe palette is based on RGB values that are either 0, or 
divisible by 51. Permissible values are in the series 0, 51, 102, 153, 204, 255. 
So, for example, the RGB definition “0,102,51” would be a safe Web colour, 
while “0,102,52” would not. 

If you’re exporting at 256 colours or less, and Web display is not an issue, 
there’s no question you should choose the Optimized setting—as a quick 
side-by-side comparison in the preview window will always confirm. The 
program will always do a better job when it’s allowed to select a range of 
colour values that best match those in the 24-bit version, rather than having 
to apply the same 216 colours every time.  

Note: When you open an image that already has an associated palette, 
PhotoPlus doesn’t attempt to hold on to the palette—it always re-optimizes, 
even if you use the Save Original command. Usually this yields the best 
possible results; but if keeping exactly the same image palette is essential to 
your particular application, our advice would be to export from PhotoPlus in 
24-bit mode and use a third-party program to apply the palette. 
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Dithering 
Dithering of the digital kind (not to be confused with “showing flustered 
excitement or fear”) comes into play with images being reduced to 256 
colours or less. It’s a method of approximating colours outside the actual 
image palette—for example, by alternating pixels of red and blue from 
within the palette to produce the visual impression of a purple colour that’s 
not in the palette. Applications (including Web browsers) use dithering in 
256-colour mode if the images being displayed include colours outside the 
application palette. This can degrade solid-colour areas and is one of the 
main reasons to export Web-bound images using the Web-safe palette. 

When you’re exporting to 256 colours or less, PhotoPlus lets you choose 
whether or not to use dithering. If you have an image with few colours, and 
preserving areas of solid colour is essential, you should opt for no 
dithering—and the export filter will pick “nearest-match” colour values from 
the palette being applied. You may see some colour shifting, but the solid 
colour areas will be preserved. For photographic images, on the other hand, 
dithering is clearly the best choice. With the “optimized palette” option, you 
can choose either ordered or error diffusion dithering. The former produces 
a discernibly patterned effect, while the latter tends to average away the 
patterns for a more natural result. 

When exporting to the 256-colour .GIF format, PhotoPlus includes an option 
that lets you select a method of dithering the alpha (transparency) channel 
separately from the image’s colour information. This produces a kind of 
scattered “see-through” effect that may improve your results, depending how 
you intend to use the final image. 

Compression 
Compression schemes, which apply different algorithms to encode the 
image information with fewer total bits and bytes, are used in many formats. 
With some, like .BMP and .TIF, the Export Optimizer gives you a choice of 
compression scheme. In general, use the default setting unless you know for 
a fact that some other scheme is called for.  
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The .JPG format, widely used for photographs (and detailed in Chapter 6), is 
unusual in that you can set the level of quality desired using a slider. As you 
might expect, the highest-quality setting uses least compression, with no loss 
of image quality but the largest file size. The lowest-quality setting applies 
maximum compression for smallest size, but yields rather poor quality. With 
the aid of the Export Optimizer, you can judge for yourself—but another 
factor to keep in mind is the number of times you expect to be re-exporting a 
particular image. A photograph may look fine the first time you export it at 
JPG level 6, but after several such saves, you’ll really see the quality loss. As 
a rule, keep images in the native .SPP format, or export them using only 
lossless compression schemes, until it’s time for the final export. 

File Formats 
PhotoPlus can import and export most types of graphics file which you’re 
likely to encounter. In order to use PhotoPlus images in other programs, you 
will have to export them into one of the widely used formats.  

For pictures and animations intended for use on the World Wide Web, the 
two prevalent formats are .GIF (for both) and .JPG (just for photos). A newer 
format, .PNG, affords excellent compression and variable transparency but 
older browsers may not support it. See Chapter 6 for details on these Web 
format features and options. (PhotoPlus also lets you export animations to the 
.AVI movie format.)  

For print use, we recommend that you use .TIF or .BMP as most other 
programs allow you to import files in that format.  

If you’re exporting an image so that it can be used in four-colour process 
printing, be sure to enable the CMYK option in the Export Optimizer. The 
other export formats use the RGB colour model (see the section on “Colour 
modes” earlier in this chapter), which is not suitable for use in process 
printing. 

The .WMF metafile format used by Windows can include bitmap data, vector 
data, or both (in vector images the picture is stored compactly as a set of 
lines). To generate vector information for scalable images you can work with 
in a draw program, choose the Autotraced Metafile export option (available 
only as an add-on with the PhotoPlus Resource CD-ROM). PhotoPlus 
processes the image and includes traced vector data in the output file. 
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Tips for Scanning 
Scanning hardware and software varies considerably. One myth is that the 
higher the resolution of your scanner, the better results you’ll achieve. While 
that’s true in theory, the real limit to quality is how the image will ultimately 
be reproduced. Will it end up on the printed page or on-screen? Either way, 
the real issue is how many “extra pixels” you’ll need in the original scan. 

If the image will be professionally printed, will that be onto a sheet of 
newsprint or a glossy coated stock? Paper itself puts a ceiling on 
reproduction quality. Lower-grade paper tends to spread ink around more 
easily, so the dots of ink used to print a picture need to be larger. This means 
a wider halftone screen with fewer lines per inch (lpi).  

If you’ll generate your output on a desktop printer, the device will be putting 
bits of toner or droplets of ink on the paper. On a laser printer, shades of grey 
result from variations in toner coverage. Desktop colour printers create 
colour by laying down dots of cyan, magenta, yellow, and black ink. Again, 
printer resolution and paper type are quite variable. Dpi (dots per inch) is 
the most common measure of print quality. But the lines per inch, based on 
halftone reproduction, is equally useful. A print resolution of 600 dpi 
corresponds to about 100 lpi. 

♦ As a general rule, the optimal scanning resolution for print work (in dpi) 
is about one-third the dpi setting (i.e. twice the resultant lpi) on the 
printer or other device that will be used. 200 dpi scanning is fine for 
most printed output 

Or will your image end up on-screen instead of in print? If so, it will no 
doubt be viewed at standard screen resolution of 96 dpi. (That’s why this is 
the default resolution in PhotoPlus.) If you’re producing Web images, it 
makes more sense to regard resolution as a fixed factor, and think in terms of 
image dimensions instead.  

This means that, for an image that will end up on a Web page, it’s just 
possible you can get great results scanning at 100dpi, at exactly the screen 
dimensions you need. But that’s cutting it close, especially if you’ll be 
editing the image at all. 

For either print or screen images, you must always take into account what 
kinds of manipulations you plan to carry out on the image in your photo 
editor, i.e. PhotoPlus. Colour adjustments, resizing (with resampling), 
blurring, and other effects tend to disturb the arrangement of pixels in the 
original scanned image. So let’s add another guideline: 
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♦ If preserving detail is a consideration—as it almost always is—and you 
plan to manipulate the image, then give yourself enough pixels to work 
with! Scan at a higher resolution (or higher size) and scale the image 
down later. 

Of course, file size and the capacity of your system are also factors in 
choosing scanner settings. It makes little sense to work slowly on a 20MB 
file, if you’d get the same final quality working quickly with a 5MB file. 

Depending on your scanner software, your may be able to perform initial 
adjustments right at the source. For example, you can use the controls to get 
a true black on one end and true white on the other. Often you can de-screen 
images to eliminate possible moiré patterns (interference between the 
regular dot patterns in printed images and the scanner’s path).  

♦ If your scanner software doesn’t provide de-screening, try using the 
PhotoPlus Gaussian Blur filter to remove moiré. Make sure you’ve 
scanned at higher resolution (or size) so that you can then scale down the 
image to regain detail. 

Some other tips: 

♦ If you’re scanning a number of pictures, you may find it’s faster to save 
scanned images to disk rather than bringing them directly into 
PhotoPlus. 

♦ In PhotoPlus, you can rotate an image if necessary to correct for any 
mis-alignment in the scan, then crop to remove any unwanted border 
pixels. Use the Brightness/Contrast, Hue/Saturation/Lightness, 
Gamma, Equalization, and/or Stretch adjustments to improve image 
quality.  
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EXIF Information 
Exchangeable Image File (EXIF) information may be appended to any photo 
obtained via digital photography. This information relates to picture taking 
conditions and your digital camera specification. 

It is possible to read the EXIF information for any digital photo from 
File>Exif Info...  

 

Advanced Printing 
In Chapter 2, we dealt with basic single-image printing via the Print dialog’s 
General tab. Now it’s time to take a look at the range of advanced printing 
options PhotoPlus affords. 

Positioning, scaling, and tiling 
Select the Print dialog’s Layout tab to specify positioning, scaling, and tiling 
options. 
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If you uncheck Centre image, you can specify the absolute position of the 
top left corner of the image. To print at actual size, select Scale and choose 
“100%.” To print at a larger or smaller size, choose or type a different 
percentage value in the list. You can also Scale to fit a particular 
dimensional area or specify the exact Width and/or Height.  

Selecting Print tiled pages lets you print oversized artwork on several sheets 
of paper. Each section or tile is printed on a single sheet of paper; the sheets 
can then be joined to form the complete page. This option is used for printing 
at larger sizes than the maximum paper size of your printer (e.g. for posters). 
To simplify arrangement of the tiles and to allow for printer margins, you can 
specify a Tile overlap value. 

The Preview area shows where on the page the image will be printed. It 
changes according to whether the printer driver is set to portrait (wide) or 
landscape (tall) orientation. 

After specifying options, click one of the other tabs to set more options, or 
click Print to proceed with printing (or Cancel to abandon changes). 

CMYK colour separations 
An offset press needs one independent plate for each colour that will print on 
the job. PhotoPlus will let you choose to print either a composite copy or 
colour separations which are used when printing the job to an imagesetter or 
platesetter.  

If the job is created properly, you then get, for each page, one complete 
negative for each colour. If you were working on a flyer, you could print out 
a composite copy on your laser or ink jet printer which would give you one 
piece of paper with the whole flyer, or seps, which would give you four 
sheets of paper. 
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The Separations tab controls the printing of colour separations. 

 
If you are using a PostScript® output device, checking the Print 
Separations box on the Separations tab allows you to choose whether to 
print separations for process printing and if selected, which separations to 
print. This box will be greyed out if you are not using a PostScript printer 
driver. 

Normally, separations are not enabled. On a colour printer (e.g. an ink jet), if 
separations are not enabled you will get a single composite colour page and 
on a mono printer (e.g. a laser printer) it will give a single greyscale page.  

After specifying options, click one of the other tabs to set more options, or 
click Print to proceed with printing (or Cancel to abandon changes). 

Including printer marks 
On the Prepress tab, you can specify whether to print various marks as well 
as the image. 

 
Marks and file information can only be printed if the physical paper size is 
one inch or more larger all round than the image. 
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After specifying options, click one of the other tabs to set more options, or 
click Print to proceed with printing (or Cancel to abandon changes). 

Multi-Image Printing 
The last time we checked, photo-quality printer paper was still an expensive 
commodity! Multi-image printing in PhotoPlus lets you conserve this 
precious resource by “ganging” several images onto a single output sheet. 
The same functionality lets you position a single image precisely on the 
printed page. There’s no need for complex calculations... in Automatic mode, 
simply choose a grid template, then drag and drop open images into the cells 
on the preview page. Other layout options include various Fit commands to 
expedite image placement; Manual mode, which dispenses with the grid and 
lets you place images anywhere; and Edit mode, which lets you design your 
own templates. Once you’ve placed images into a layout, you can move, 
resize, rotate or flip them—and of course, print out your page! 

For an introduction to this versatile PhotoPlus feature, try the following 
exercise yourself, or just read along. Online help provides complete details 
on the various buttons and functions. 

HANDS ON: Fit to Print 
 Start by closing any open images. Then use File/Open... to open 

CAT.JPG and BRIDGE.JPG in the PhotoPlus PROJECTS folder. 

 Choose Print Multiple... from the File menu.  

The PhotoPlus window changes to display the currently open images in a 
scrolling gallery at the left, a page layout region in the centre, and a selection 
of layout templates at the right. 
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 Take a moment to run the mouse pointer across the active toolbar 

buttons and inspect the tooltips. Notice that you can open and save 
layouts, open images, access print functions, switch modes (Manual, 
Automatic, or Edit), and switch the dot grid and snapping functions on 
or off. 

  You can also open images directly from the multi-image window. 
Click the Open Images button and open STATUE.JPG. A thumbnail 
appears at the left. 

The layout templates on the right offer pre-arranged grids consisting of 
empty cells. To insert any template into the central page layout region, you 
simply click its gallery thumbnail. (Right-clicking on any template pops up a 
menu that lets you add or delete templates and categories.) 

 Select the “A4” or “Letter” size category and click the 6 x 4 template, 
which will have two cells above and one below—the third in the 
illustration above.  

 Now “populate” the cells as follows: Drag the BRIDGE thumbnail into 
the upper left cell, the STATUE thumbnail into the upper right, and the 
CAT into the bottom cell. 
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  Just for practice, click the Save Layout button to store the current 
page layout for later use. PhotoPlus saves your layout exactly as is, with 
or without images in the cells. 

On the layout, the cell outlines represent where images will be cropped when 
they are printed. By default, each image you drop into a cell initially scales to 
fit into that cell without changing its aspect ratio—i.e. using Scale to Fit 
without cropping or distortion. From that point, if you wish you can drag an 
image’s corner to resize it smaller or larger; Shift-drag to resize 
unconstrained; or Ctrl-drag to constrain to a square shape.  

On the toolbar, a number of new buttons have been activated that help you fit 
any selected image to its cell in various ways. Fit Width and Fit Height are 
self-explanatory, as is the Align flyout which positions the image with 
respect to the cell. Stretch to Fit makes sure the image exactly fills the cell. 
You can also re-orient images as needed to fit cells using the Flip and Rotate 
buttons, or click Rotate/Scale to Fit to let PhotoPlus determine an 
undistorted “best fit.”  

 Experiment with the various image-fitting functions until you are 
comfortable with them. 

So far we’ve been in Automatic mode, where layout templates determine 
the multi-image arrangement.  

  For greater flexibility, click the Manual Mode button. 
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Immediately the cell outlines (and the template gallery itself) disappear, 
leaving only the current images. In Manual mode you can freely move and 
resize images on the page layout. The image-fitting functions now operate 
with respect to the page edges rather than cell boundaries. Use the Status 
Editor dialog for precise image placement; the keyboard arrows let you 
nudge a selected image. You can still save your layout at any point—and if 
you decide you’d like to create a template based on the manual layout, 
simply switch back to Automatic Mode (which restores cells around each 
image), then right-click in the template gallery and choose Add Template.... 

  For yet another level of control, click the Edit Mode button. 

In this mode you see only the cell outlines, which you can move, resize, and 
align to create any template format without image content. To delete a 
selected cell, press the Delete key; to add a new cell, click the Add Cell 
button. Don’t forget, you can turn the snapping and/or dot grid aids on or off 
as needed. Again, to save a template, switch back to Automatic mode first.  

 Once you’ve fully explored the multi-image window (note the 
Preferences button that lets you set layout and fit properties behaviour), 
try printing a test sheet if you wish. 

  To return to the main PhotoPlus window, click the Close button. 

Publishing a PDF File 
PDF (Portable Document Format) is a cross-platform file format developed 
by Adobe. In a relatively short time, PDF has evolved into a worldwide 
standard for document distribution which works equally well for electronic 
or paper publishing. PDF documents are uniformly supported in the 
Windows, Macintosh, and UNIX® environments. Anyone with the free 
Adobe Acrobat® Reader can view or print out PDF files, either from within 
a Web browser window or directly—for example, when delivered over a 
network or on CD-ROM. PDF documents are compact—one-fifth the size of 
comparable HTML files—for faster transmission. 
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PDF works well as a medium for distributing standalone files. By letting 
people download an online PDF file, you can save yourself the trouble and 
expense of printing multiple copies! PDF is also used extensively for 
delivering files to professional printers. In recent years, print shops are 
moving toward the newer PDF/X formats—more reliable than PostScript 
and expressly targeted for graphic arts and high quality reproduction. Several 
different “flavors” of PDF/X exist; PhotoPlus supports PDF/X-1 and PDF/X-
1a.  

To export a PhotoPlus picture as a PDF, choose Publish as PDF...  from the 
File menu) to display the Publish PDF dialog.  

 
Set basic output options on the dialog’s General tab. If handing off a file to a 
professional printer, choose either “PDF X/1” or “PDF X/1a” in the 
Compatibility list as advised by your print partner. In the Colour 
Management section, the Output colour space setting should always be 
“CMYK” for professional printing. Select the Destination profile 
recommended by your print partner. Checking Preview PDF file in Acrobat 
automatically opens the PDF in Acrobat after it’s been created, so you can 
review it immediately. (If anything looks amiss, you’ll need to fix the 
problems in the file and regenerate the PDF.)  

The Security tab lets you add password protection to keep the contents of 
your document away from unintended eyes. You can also lock certain 
capabilities to prevent unauthorized dissemination or changes. For example, 
you can specify No document printing to prevent paper reproduction of the 
publication’s contents, or No content copying to help ensure your text can’t 
be easily duplicated somewhere else. You can even enter a master password 
to give you—and only you—the right to alter these security settings. (Just be 
sure to remember your password!) 
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Tutorial Resources 
For more experience with the tools and techniques covered in this chapter, 
we recommend these HTML-based tutorials on the PhotoPlus 10.0 Resource 
CD-ROM: 

Try this tutorial... For practice with these tools and techniques... 

Exploring Colour 
Spaces 

Colour modes: RGB and HSL  

Image Formats Choices in the Export Optimizer 
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PhotoPlus Keyboard Shortcuts 

Tool shortcuts 
Press...   With... To... 

Shift  ------ ------- Selection tools Add to current selection 

 Alt  ------- Selection tools Subtract from current selection 

  Ctrl  Selection tools Move selection contents 

 Alt  Ctrl  Selection tools Duplicate selection contents 

 Alt  ------- Move tool Duplicate selection contents 

  Ctrl  Adjustable  
Selection tools, Crop 

tool, QuickShape tools, 
Image Map rectangle 

Constrain aspect ratio when 
dragging to define shape or 
region 

Shift    Straight Outline tool Constrain to 15° angle intervals 

 Alt  ------- Text, Paintbrush, 
Airbrush, Fill, Outline, 

QuickShape tools 

Left-click to pick up foreground 
colour; right-click to pick up 
background colour 

Shift  ------ ------- Deform tool, Deform 
Mesh tool, Shape Edit 

tool 

Drag centre to constrain rotation 
to 15° angle intervals 

Shift  ------ ------- as above Drag corner handle to constrain 
aspect ratio 

 Alt  ------- as above Drag corner handle to resize 
relative to fixed point 

Shift  Alt  ------- as above Drag corner handle to resize 
relative to fixed point while 
constraining aspect ratio 

  Ctrl  as above Drag corner handle to skew 

Shift  Alt  Ctrl  as above Drag corner handle to change 
perspective 



 

Menu command shortcuts 
Press...   With... To... 

  Ctrl  Z Undo last action 

  Ctrl  Y Redo last undone action 

  Ctrl  L Paste from Clipboard as new layer 

Shift  ------ Ctrl  L Paste from Clipboard into selection 

  Ctrl  C Copy selection or layer to Clipboard 

Shift  ------ Ctrl  C Copy merged (all layers as one layer) to 
Clipboard 

  Ctrl  X Cut selection to Clipboard 

  Ctrl  V Paste from Clipboard as new image 

  Ctrl  D Deselect pixels 

Shift  ------ Ctrl  G Switch on/off guides 

Shift  ------ Ctrl  I  Invert selection 

  Ctrl  A Select all 

  Ctrl  B Image Browser 

  Ctrl  G Switch on/off grid 

  Ctrl  N New image 

  Ctrl  O Open file 

  Ctrl  P Print 

  Ctrl  R Switch on/off rulers 

  Ctrl  S Save 

  Ctrl  Tab Switch between image windows 

  Ctrl  0 Zoom to fit 

  Ctrl  + Zoom in 

  Ctrl  -  Zoom Out 



 

 

  Ctrl  F4 Close current image window 

 Alt  ------- F4 Close PhotoPlus 

 Alt  ------- ------- Activate menus 

 Alt  ------- ]  Selects layer below 

 Alt  ------- [  Selects layer above 

  Ctrl  ]  Moves layer down 

  Ctrl  [  Moves layer up 

Shift    C View curves 

Shift    B View colour balance 

Shift    H View hue, saturation and lightness 

Shift    L View levels 

   Del Clears current layer selection to reveal lower 
layer or background colour  

   Tab  Hide/show active tab windows 

 



 

 
 



 

Index 
3D layer effects, 121 
active layer, 73, 109 
Add Mask command, 129 
Add Text window, 40, 100, 117 
Adjust Colour dialog, 72, 100 
Adjustable Selection tools, 43 
adjustment filters. See filters 
adjustment layers, 59, 128 
Airbrush property, 77 
aligning layers and shapes, 88, 111 
animation 

.GIF format for Web, 140, 144 
creating, 144 
effects, 150 

Animation tab, 145 
anti-aliasing, 89, 100, 140 
arranging layers, 111 
arrow 

drawing, 88 
selecting shape, 43 

artistic effects, 63 
aspect ratio, constraining, 43, 88 
AutoContrast and AutoLevels, 38, 57 
autotraced metafile, 178 
AVI file format, 150 
background colour, 16, 40, 71, 80, 123 
Background Eraser tool, 81 
Background layer. See layers 
Batch dialog, 161 
Batch Processing, 161 
Bevel (effect filter), 103, 143 
bit depth, 140, 169 
bitmap, 169 
blend modes, 58, 67, 77, 103, 108, 114, 

120, 122, 172 
blend ranges, 114 
blur filters. See filters 
Blur tool, 84 
box, drawing, 88 
Brightness/Contrast (adjustment filter), 38, 

57 
browser, previewing images in, 149 
Brush Options, 76 
Brush Tip tab, 75 

brush tips, creating custom, 77 
Bump Map (layer effect), 122 
Burn tool, 84 
canvas, resizing, 15, 49, 67, 144 
captions, adding, 37, 40 
Channel Mixer (adjustment filter), 57, 66 
Channels, 55 
circle 

drawing, 88 
placing hotspot, 152 
selecting shape, 43 

Clipboard operations, 48, 111, 174 
Clone tool, 85 
CMYK 

colour separations, 182 
mode, 72, 173 

Colour Balance (adjustment filter), 57 
Colour Management, 173, 188 
Colour Pickup tool, 72, 174 
Colour Selection tool, 44 
Colour tab, 16, 23, 40, 71 
colours 

adjusting, 56 
choosing, 40, 72 
colour matching, 173 
colourizing images, 66 
key colours in gradient, 96 
modes, 72, 171 
palettes, 176 
replacing, 57, 58 
separations, 182 
theory, 169 
wheel, 172 
Windows system, 176 

combination options 
for selection, 46 
for shapes, 87 

compression, 139, 141, 177 
Conical (gradient fill type), 94 
Context Bar, 15, 44, 46, 75, 80, 81, 84, 89, 

91, 92, 94 
Paintbrush, 77 

Context Bar, 77 
Context Help button, 33, 74 



 

contrast, adjusting, 38, 57 
Controller settings (Brush Options), 76 
Copy command, 48, 111 
Create HTML for Image Maps setting, 153 
Create Image Slices setting, 151 
Crop to Selection command, 37, 49 
Crop tool, 37, 49 
Curved Outline tool, 90 
Curves (adjustment filter), 57 
custom filters, 60 
Cut command, 48, 111 
dabs, 76 
Deform tool, 51 
Delete command, 48 
Delete Mask command, 131 
depth maps, 122 
Deselect command, 46 
device profiles, 173 
diameter (of brush), 75 
digital camera (TWAIN) input, 27 
Disable Mask command, 130 
distortion filters. See filters 
dithering, 140, 177 
Dodge tool, 84 
dpi (dots per inch), 171, 179 
drag and drop, 27 
drawing. See also tools 

hotspots (image maps), 152 
lines, 74, 89 
shapes, 88 

Drop Shadow effect, 120 
Duplicate command, 28 
Duplicate Layer command, 109 
duplicating a selection, 48 
edge filters. See filters 
Edit Mask mode, 130 
Edit tools, 91, 98 
effect filters. See filters 
Effects Gallery, 58, 60, 114, 120, 150 
Elastic Warp tool, 82 
ellipse 

drawing, 88 
selecting shape, 43 

Emboss (effect filter), 61 
Equalization (adjustment filter), 58 
Eraser tools, 80 
Exif, 181 
Export Optimizer, 18, 29, 149, 175 

exporting files, 18, 29 
animation, 149 
image maps, 153 
image slices, 151 
optimization, 175 

Extract command, 44, 119 
Fade effect (animation), 150 
feathering, 47, 93, 131, 140 
features, key, 7 
file formats 

.AVI, 150 

.GIF, 139 

.JPG, 141 

.PNG, 141 

.SPP, 18, 29, 108, 128, 149, 170 

.WMF, 178 
for Web graphics, 139 

Fill command, 92 
Fill tools 

Flood, 92 
Gradient, 92 

Filter Gallery, 133 
filters 

AutoContrast and AutoLevels, 38, 57 
Bevel, 103, 143 
blur, 61, 62 
Brightness/Contrast, 38, 57 
Channel Mixer, 57, 66 
Colour Balance, 57 
Curves, 57 
custom, 60 
effects, 60 
Emboss, 61 
Equalization, 58 
gallery for, 133 
Gaussian Blur, 180 
Gradient Map, 57 
Greyscale, 58, 66 
Hue/Saturation/Lightness, 57, 62, 66 
Levels, 38, 57, 63 
Median, 60 
Negative Image, 58 
plug-in, 25 
Posterize, 62 
Replace Colour, 57 
Selective Colour, 57 
Threshold, 58 
Unsharp Mask, 60, 62 



 

 

flattening an image, 41, 112 
Flip command, 50 
Flood Eraser tool, 81 
Flood Fill tool, 67, 92 
foreground colour, 16, 40, 71, 74, 78, 88, 

92, 94, 123 
formatting text, 100 
frames (animation), 145 
Freehand Outline tool, 90 
Gaussian Blur (effect filter), 62, 180 
GIF file format, 139 
Gradient Fill tool, 92 
Gradient Map (adjustment filter), 57 
Greyscale (adjustment filter), 58, 66 
Greyscale mode, 72, 123, 130, 171, 174 
Grow Selection command, 46 
guides, 75 
halftone screen, 179 
hardness (of brush), 75 
heart, selecting shape, 43 
help, getting in PhotoPlus, 33 
HintLine, 33, 51, 174 
Histogram 

Using the, 174 
hotspots (for image maps), 152 
HSL mode, 72, 172 
HTML 

for image maps, 153 
for image slices, 152 

hue, defined, 172 
Hue/Saturation/Lightness (adjustment 

filter), 57, 62, 66 
hyperlinks 

for image maps, 153 
for image slices, 151 

ICC device profiles, 173 
Image Browser, 27 
image formats. See file formats 
Image Map tools, 152 
Image Slice tool, 151 
importing from TWAIN source, 27 
installation, 11 
Instant Artist effects, 63 
Instant Effects tab, 60, 121 
Invert Selection command, 46 
JPEG (.JPG) file format, 141 
key colours, 96 
Layer Groups, 112 

layers, 16, 107 
active layer, 17, 73, 109 
adjustment layers, 59, 128 
aligning, 111 
and animation frames, 146, 149 
arranging, 111 
Background layer, 16, 28, 48, 50, 63, 

71, 73, 80, 94, 107, 108, 109, 111, 
112, 114, 120, 128 

blend modes, 114 
Clipboard operations, 111 
creating, 66, 73, 109 
deleting, 109 
depth maps, 122 
hiding and showing, 110 
layer effects, 60, 120 
linking and unlinking, 111 
merging, 112 
moving, 110 
opacity, 50, 146 
Promote to Layer, 50, 109, 143 
shape layers, 17, 87, 92, 150 
standard layers, 17, 107 
text layers, 17, 41, 92, 100, 150 

Layers tab, 107, 111, 145 
Levels (adjustment filter), 38, 57, 63 
lighting (render) filters. See filters 
lightness 

adjusting, 57 
defined, 172 

Linear (gradient fill type), 94 
looping (animation), 147, 149 
lpi (lines per inch), 179 
Macros 

modifying, 159 
playing, 159 
recording, 158 

Macros tab, 157 
manipulating photos, 37, 62, 63, 66 
marquee, 16, 42, 43, 45, 46, 47, 49, 75, 99 
masking, 128 
matte (export option), 31, 140 
Median, 60 
Merge command (layers), 112 
Merge Mask command, 131 
Mesh toolbar, 53 
Mesh Warp tool, 53 
metafiles, 178 



 

moiré patterns, 180 
monochrome, 170, 171 
montage, creating, 116 
Move effect (animation), 150 
Move Marquee cursor, 45, 48 
Move tool, 41, 48, 110 
multi-image printing, 184 
Navigator tab, 26 
Negative Image (adjustment filter), 58 
New Frame button, 147 
Node Edit tool, 91 
noise filters. See filters 
opacity, 17, 50, 75, 77, 80, 96, 108, 131, 

146 
Opacity attribute (Brush Options), 76 
opening an existing file, 27 
optimizing images, 175 
Outline tools, 86, 98 
oval, drawing, 88 
Paint to Select mode, 47, 93 
Paintbrush tool, 74 
painting. See tools 
palette, Web-safe, 140, 176 
palettes, colour, 140, 176 
Pan tool, 26 
Paste command, 48, 100, 103, 111 
paths, 97 
Paths tab, 97 
Pattern Brush tool, 78 
pattern fill, 93 
Pattern Map (layer effect), 122 
PDF publishing, 187 
pen (input device), 76 
PhotoPlus 

.SPP file format, 18, 29, 98, 108, 128, 
149, 170 

key concepts, 15 
key features, 7 
Resource CD-ROM, 27, 33, 178 
shortcuts, 191 

Photoshop .PSD format, 18, 28, 108 
Picture Brush tool, 79 
picture tubes (Paint Shop Pro), 77, 80 
pie, selecting shape, 43 
Pinch/Punch tools, 82 
Ping Pong (animation), 150 
pixels, 15, 44, 48, 83, 92, 108, 169, 174 
plug-in filters, 25 

PNG file format, 141 
polygon 

drawing, 88 
placing hotspot, 152 

Posterize (effect filter), 62 
preferences, setting, 25, 38 
Preview in Browser command, 149 
Print Multiple, 184 
printer marks, including, 183 
printing 

advanced, 181 
basic, 32 
scaling output, 182 
tiling, 182 

printing, multi-image, 184 
process inks (CMYK), 173 
profiles (device), 173 
Promote to Layer command, 50, 109, 143 
properties, setting for tools, 77 
PSD file format, 18, 28, 108 
Publish as PDF, 188 
quality 

adjustments for, 180 
in exported images, 141 
in exported images, 139 

QuickShape tools, 86, 88, 98, 143 
Radial (gradient fill type), 94 
raster, 86 
Rasterize command, 88, 100, 150 
rectangle 

drawing, 88 
placing hotspot, 152 
selecting shape, 43 

Red eye, removing from photo, 85 
registration, 10 
render filters. See filters 
Replace Colour (adjustment filter), 57 
resizing, 15, 49, 67 
resolution, 171, 179 
Resource CD-ROM, 27, 33, 178 
retouching photos, 83 
Revert command, 28 
RGB mode, 72, 172 
Rotate command, 50 
saturation 

adjusting, 57 
defined, 172 

saving files, 18, 29, 176 



 

 

Scale to fit option, 182 
scaling, 181 
scanning, 27, 179 
Scratch Remover tool, 84 
security options (PDF), 188 
Select Similar command, 46 
selection, 16, 41 

creating, 41 
deselecting, 46 
duplicating, 48 
feathering, 131 
from mask, 131 
inverting, 46 
modifying, 45 
Paint to Select mode, 47, 93 
resizing, 51 
rotating, 51 
Text Selection tool, 101 
to and from path, 98 
variable, 46 

Selective Colour (adjustment filter), 57 
separations, CMYK colour, 182 
sepia tone, adding to photo, 66 
Shape Edit tool, 91 
shape layers, 87, 92, 150 
shapes 

aligning, 88 
Sharpen tool, 84 
shortcuts, table of, 191 
Smudge tool, 83 
Snapping, 42, 48 
Solid (fill type), 94 
solid fill. See flood fill 
special effects filters. See filters 
spiral, selecting shape, 43 
Sponge tool, 84 
SPP file format, 18, 29, 98, 108, 128, 149, 

170 
square 

drawing, 88 
selecting shape, 43 

Square (gradient fill type), 94 
Standard Selection tools, 42, 49 
star 

drawing, 88 
selecting shape, 43 

Starting PhotoPlus, 18 
Startup Wizard, 19 

Statistics 
in Histograms, 174 

Straight Outline tool, 89 
stroking a path, 98 
stylus (input device), 76 
support, technical, 10 
system requirements, 11 
tab windows, 15 

Animation tab, 23, 145 
Brush Tip tab, 75 
Colour tab, 16, 40, 71 
Context Bar, 44, 46, 75, 80, 81, 84, 89, 

91, 92, 94 
docking and undocking, 21 
Instant Effects tab, 23, 121 
Layers tab, 23, 107, 111, 145 
Macros tab, 157 
Navigator tab, 23, 26 
Paths tab, 97 
Undo History tab, 38 

tablet (input device), 76 
Tabs 

saving layout of, 25 
technical support, 10 
text 

adding, 40, 100 
creating selection in shape of, 101 
deforming, 51 
editing, 100 

text layers, 92, 100, 150 
Text Selection tool, 101 
Text tool, 40, 100 
Texture attribute (Brush Options, 76 
Thick/Thin Warp tool, 82 
Threshold (adjustment filter), 58 
Threshold command, 47 
tiling, 181, 182 
tolerance setting, 44, 92 
toolbars 

Mesh, 53 
Tools, 15 

Toolbars, 22 
tools, 15 

Adjustable Selection tools, 43 
Blur tool, 84 
Burn tool, 84 
Clone tool, 85 
Colour Pickup tool, 72, 174 



 

Colour Selection tool, 44 
Crop tool, 37, 49 
Curved Outline tool, 90 
Deform tool, 51 
Dodge tool, 84 
Eraser tools, 80 
Flood Fill tool, 67, 92 
Freehand Outline tool, 90 
Gradient Fill tool, 92 
Image Map tools, 152 
Image Slice tool, 151 
Mesh Warp tool, 53 
Move tool, 41, 48, 110 
Node Edit tool, 91 
Paintbrush tool, 74 
Pattern Brush tool, 78 
Picture Brush tool, 79 
QuickShape tools, 143 
Red Eye tool, 85 
Scratch Remover tool, 84 
Shape Edit tool, 91 
Sharpen tool, 84 
Smudge tool, 83 
Sponge tool, 84 
Standard Selection tools, 42, 49 
Straight Outline tool, 89 
Text Selection tool, 101 
Text tool, 100 
Warp tools, 81 

Tools toolbar, 15 
transparency. See also opacity 

in exported images, 140, 141 
tutorials, 33 
TWAIN input, 27 
Tweening, 145 
Twirl tools, 82 
Undo options, 38, 83 
Unsharp Mask, 60, 62 
URLs 

for image maps, 153 
for image slices, 151 

vector, 86 
View Mask setting, 130 
vignetting, 131, 135 
Warp tools, 81 
wave, selecting shape, 43 
Web images 

animations, 144 
file formats for, 139 
performance issues, 139 
previewing in browser, 149 
Web-safe palette, 140, 176 

weight (line thickness), 89 
Windows system colours, 176 
WMF file format, 178 
Workspace tabs 

saving layout of, 25 



 

Notes 
The remaining pages are provided for you to make your own notes. 
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